aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorflo <flo@FreeBSD.org>2011-08-17 02:36:10 +0800
committerflo <flo@FreeBSD.org>2011-08-17 02:36:10 +0800
commitf30e4f8c2ccfccd22500e1dab7986252daec9c75 (patch)
tree09bd069151a392d047530baff70488647f82fc18 /www
parentd0640767d953a29134f9019f7bec356f719ff180 (diff)
downloadfreebsd-ports-gnome-f30e4f8c2ccfccd22500e1dab7986252daec9c75.tar.gz
freebsd-ports-gnome-f30e4f8c2ccfccd22500e1dab7986252daec9c75.tar.zst
freebsd-ports-gnome-f30e4f8c2ccfccd22500e1dab7986252daec9c75.zip
retire GECKO_PTHREAD_LIBS just use PTHREAD_LIBS.
this will enable compilation with clang. firefox 6 and thunderbid 6 now build fine with clang. other gecko ports should become compilable as soon as they are based on the same gecko version as firefox and thunderbird 6
Diffstat (limited to 'www')
-rw-r--r--www/kompozer/Makefile7
-rw-r--r--www/libxul/Makefile4
-rw-r--r--www/seamonkey2/Makefile5
3 files changed, 3 insertions, 13 deletions
diff --git a/www/kompozer/Makefile b/www/kompozer/Makefile
index 538164039a98..7ef879537395 100644
--- a/www/kompozer/Makefile
+++ b/www/kompozer/Makefile
@@ -39,13 +39,8 @@ NOT_FOR_ARCHS_REASON_ia64= does not build
.include <bsd.port.pre.mk>
-.if ${ARCH}=="powerpc"
-GECKO_PTHREAD_LIBS!=${CC} -dumpspecs | ${GREP} -m 1 '%{\!pg: %{pthread:' | ${SED
-} -e 's|^.*%{\!pg: %{pthread:|| ; s|}.*$$||' || ${TRUE}
-.endif
-
post-patch:
- ${REINPLACE_CMD} -e 's|%%PTHREAD_LIBS%%|${PTHREAD_LIBS:C/-pthread/${GECKO_PTHREAD_LIBS}/}|' \
+ ${REINPLACE_CMD} -e 's|%%PTHREAD_LIBS%%|${PTHREAD_LIBS}|' \
${WRKSRC}/storage/build/Makefile.in
@${RM} -f ${WRKSRC}/config.status ${WRKSRC}/config.cache
@${ECHO_CMD} "LDFLAGS += -L${LOCALBASE}/lib" >> ${WRKSRC}/toolkit/components/Makefile.in
diff --git a/www/libxul/Makefile b/www/libxul/Makefile
index f7c936d1e79d..19851191afc5 100644
--- a/www/libxul/Makefile
+++ b/www/libxul/Makefile
@@ -51,8 +51,6 @@ OPTIONS= DBUS "Enable D-BUS support" on
.include <bsd.port.pre.mk>
-GECKO_PTHREAD_LIBS!=${CC} -dumpspecs | ${GREP} -m 1 '%{\!pg: %{pthread:' | ${SED} -e 's|^.*%{\!pg: %{pthread:|| ; s|}.*$$||' || ${TRUE}
-
.if ${OSVERSION} < 700000
LIB_DEPENDS+= pulse.0:${PORTSDIR}/audio/pulseaudio
EXTRA_PATCHES= ${FILESDIR}/releng6_pulseaudio
@@ -77,7 +75,7 @@ LIB_DEPENDS+= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
.endif
post-patch:
- ${REINPLACE_CMD} -e 's|%%PTHREAD_LIBS%%|${PTHREAD_LIBS:C/-pthread/${GECKO_PTHREAD_LIBS}/}|' \
+ ${REINPLACE_CMD} -e 's|%%PTHREAD_LIBS%%|${PTHREAD_LIBS}|' \
${WRKSRC}/storage/build/Makefile.in \
${WRKSRC}/db/sqlite3/src/Makefile.in
${REINPLACE_CMD} -e 's|/usr/local/include|${LOCALBASE}/include|' \
diff --git a/www/seamonkey2/Makefile b/www/seamonkey2/Makefile
index be95e7724b2c..e6f8672117f4 100644
--- a/www/seamonkey2/Makefile
+++ b/www/seamonkey2/Makefile
@@ -74,9 +74,6 @@ CFLAGS+= -mminimal-toc
MOZSRC:= ${WRKDIR}/comm-1.9.1/mozilla
WRKSRC= ${WRKDIR}/comm-1.9.1
-GECKO_PTHREAD_LIBS!=${CC} -dumpspecs | ${GREP} -m 1 '%{\!pg: %{pthread:' | ${SED
-} -e 's|^.*%{\!pg: %{pthread:|| ; s|}.*$$||' || ${TRUE}
-
.if ${HAVE_GNOME:Mlibgnomeui}!=""
USE_GNOME+= libgnomeui
MOZ_OPTIONS+= --enable-gnomeui
@@ -125,7 +122,7 @@ post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' \
${WRKSRC}/mozilla/security/manager/ssl/src/Makefile.in \
${WRKSRC}/mozilla/js/src/config/mkdepend/Makefile.in
- ${REINPLACE_CMD} -e 's|%%PTHREAD_LIBS%%|${PTHREAD_LIBS:C/-pthread/${GECKO_PTHREAD_LIBS}/}|' \
+ ${REINPLACE_CMD} -e 's|%%PTHREAD_LIBS%%|${PTHREAD_LIBS}|' \
${WRKSRC}/mozilla/storage/build/Makefile.in
@${REINPLACE_CMD} -e '/accessibility.typeaheadfind.enablesound/s/true/false/' \
${WRKSRC}/mozilla/modules/libpref/src/init/all.js