aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2006-11-29 17:37:35 +0800
committerijliao <ijliao@FreeBSD.org>2006-11-29 17:37:35 +0800
commit05c30e949489be160fec360df350576d598ce31c (patch)
treee658393b3c1532c75f290d0773d200ba7164120b /www
parent2bcdb4217cd2543c4edf2226643ab0b01d04b701 (diff)
downloadfreebsd-ports-gnome-05c30e949489be160fec360df350576d598ce31c.tar.gz
freebsd-ports-gnome-05c30e949489be160fec360df350576d598ce31c.tar.zst
freebsd-ports-gnome-05c30e949489be160fec360df350576d598ce31c.zip
add p5-CGI-Cookie-Splitter 0.01
Split big cookies into smaller ones
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-CGI-Cookie-Splitter/Makefile25
-rw-r--r--www/p5-CGI-Cookie-Splitter/distinfo3
-rw-r--r--www/p5-CGI-Cookie-Splitter/pkg-descr8
-rw-r--r--www/p5-CGI-Cookie-Splitter/pkg-plist7
5 files changed, 44 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 3f598fb71e7b..aa2a1eff807c 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -517,6 +517,7 @@
SUBDIR += p5-CGI-Builder
SUBDIR += p5-CGI-Builder-TT2
SUBDIR += p5-CGI-Cache
+ SUBDIR += p5-CGI-Cookie-Splitter
SUBDIR += p5-CGI-Ex
SUBDIR += p5-CGI-FastTemplate
SUBDIR += p5-CGI-FormBuilder
diff --git a/www/p5-CGI-Cookie-Splitter/Makefile b/www/p5-CGI-Cookie-Splitter/Makefile
new file mode 100644
index 000000000000..985f855f2606
--- /dev/null
+++ b/www/p5-CGI-Cookie-Splitter/Makefile
@@ -0,0 +1,25 @@
+# ex:ts=8
+# Ports collection makefile for: CGI::Cookie::Splitter
+# Date created: Nov 29, 2006
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= CGI-Cookie-Splitter
+PORTVERSION= 0.01
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Split big cookies into smaller ones
+
+BUILD_DEPENDS= p5-CGI-Simple>=0:${PORTSDIR}/www/p5-CGI-Simple
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= CGI::Cookie::Splitter.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-CGI-Cookie-Splitter/distinfo b/www/p5-CGI-Cookie-Splitter/distinfo
new file mode 100644
index 000000000000..4ace495f3096
--- /dev/null
+++ b/www/p5-CGI-Cookie-Splitter/distinfo
@@ -0,0 +1,3 @@
+MD5 (CGI-Cookie-Splitter-0.01.tar.gz) = 220caea7b6760e1219b9e4d946b62d01
+SHA256 (CGI-Cookie-Splitter-0.01.tar.gz) = b6b4b85ab7773096d5ad973a36eeb2fc0f27f187dcc742150a8463374860060e
+SIZE (CGI-Cookie-Splitter-0.01.tar.gz) = 4838
diff --git a/www/p5-CGI-Cookie-Splitter/pkg-descr b/www/p5-CGI-Cookie-Splitter/pkg-descr
new file mode 100644
index 000000000000..c872a570f252
--- /dev/null
+++ b/www/p5-CGI-Cookie-Splitter/pkg-descr
@@ -0,0 +1,8 @@
+RFC 2109 recommends that the minimal cookie size supported by the client is
+4096 bytes. This has become a pretty standard value, and if your server sends
+larger cookies than that it's considered a no-no.
+
+This module provides a pretty simple interface to generate small cookies that
+are under a certain limit, without wasting too much effort.
+
+WWW: http://search.cpan.org/dist/CGI-Cookie-Splitter/
diff --git a/www/p5-CGI-Cookie-Splitter/pkg-plist b/www/p5-CGI-Cookie-Splitter/pkg-plist
new file mode 100644
index 000000000000..7dbd33ceec47
--- /dev/null
+++ b/www/p5-CGI-Cookie-Splitter/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/CGI/Cookie/Splitter.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/CGI/Cookie/Splitter/.packlist
+@dirrmtry %%SITE_PERL%%/CGI/Cookie
+@dirrmtry %%SITE_PERL%%/CGI
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/CGI/Cookie/Splitter
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/CGI/Cookie
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/CGI