aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2014-06-05 13:18:55 +0800
committermiwi <miwi@FreeBSD.org>2014-06-05 13:18:55 +0800
commit08030ea9ec2027490d151084dd5e7fa4f9deb9b4 (patch)
tree9d1795bcaabd0f1240fab3d007f2a998ca9f97cf /www
parent56261c606b242145cab9cdc1008c33aea88e46bf (diff)
downloadfreebsd-ports-gnome-08030ea9ec2027490d151084dd5e7fa4f9deb9b4.tar.gz
freebsd-ports-gnome-08030ea9ec2027490d151084dd5e7fa4f9deb9b4.tar.zst
freebsd-ports-gnome-08030ea9ec2027490d151084dd5e7fa4f9deb9b4.zip
- Stage support
PR: 190347 Approved by: maintainer
Diffstat (limited to 'www')
-rw-r--r--www/pivotx/Makefile43
-rw-r--r--www/pivotx/pkg-plist2
2 files changed, 11 insertions, 34 deletions
diff --git a/www/pivotx/Makefile b/www/pivotx/Makefile
index 633ca641d4e6..f85cafa4f754 100644
--- a/www/pivotx/Makefile
+++ b/www/pivotx/Makefile
@@ -18,7 +18,6 @@ LICENSE= GPLv2
PORTDOCS= LICENSE.txt README.txt
PORTEXAMPLES= example.htaccess example.web.config
-NO_STAGE= yes
# Requirements:
# http://book.pivotx.net/index.php?page=app-e#anchor-determining-if-your-server-meets-pivotxs-requirements
@@ -79,44 +78,20 @@ post-patch:
@cd '${WRKSRC}' && ${FIND} . -type f -name '*.orig' -delete
do-install:
- @if ${TEST} -e '${TEMP_DIFF}'; then ${RM} -f '${TEMP_DIFF}'; fi
- @${TOUCH} '${TEMP_DIFF}'
-.for DIR in ${USEREDITABLEDIRS}
- @if ${TEST} -d '${WWWDIR}/${DIR}'; then \
- cd '${WRKSRC}/${DIR}' && { ${DIFF} -auwr . '${WWWDIR}/${DIR}' | ${EGREP} -v -e '^Only[[:space:]]+in[[:space:]]' >>'${TEMP_DIFF}' || ${TRUE}; } \
- fi
-.endfor
- @if ${TEST} -s '${TEMP_DIFF}'; then \
- ${ECHO} '*******************************************************'; \
- ${ECHO} 'CAUTION CAUTION CAUTION CAUTION CAUTION CAUTION CAUTION'; \
- ${ECHO} '*******************************************************'; \
- ${ECHO} 'Output of diff: ${TEMP_DIFF}'; \
- ${ECHO}; \
- ${ECHO} 'Installer will *OVERWRITE* files on ${WWWDIR}'; \
- ${ECHO} 'Press ctrl-C *now* to backup them manually.'; \
- sleep 7; \
- fi
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} '${DOCSDIR}'
+ @${MKDIR} '${STAGEDIR}${DOCSDIR}'
.for FILES in ${PORTDOCS}
- @${INSTALL_DATA} '${TEMP_WRKSRC}/${FILES}' '${DOCSDIR}'
+ @${INSTALL_DATA} '${TEMP_WRKSRC}/${FILES}' '${STAGEDIR}${DOCSDIR}'
.endfor
-.endif
-.if ${PORT_OPTIONS:MEXAMPLES}
- @${MKDIR} '${EXAMPLESDIR}'
+ @${MKDIR} '${STAGEDIR}${EXAMPLESDIR}'
.for FILES in ${PORTEXAMPLES}
- @${INSTALL_DATA} '${TEMP_WRKSRC}/${FILES}' '${EXAMPLESDIR}'
+ @${INSTALL_DATA} '${TEMP_WRKSRC}/${FILES}' '${STAGEDIR}${EXAMPLESDIR}'
.endfor
-.endif
- @${MKDIR} '${WWWDIR}'
- @cd '${WRKSRC}' && ${COPYTREE_SHARE} . '${WWWDIR}'
+ @${MKDIR} '${STAGEDIR}${WWWDIR}'
+ @cd '${WRKSRC}' && ${COPYTREE_SHARE} . '${STAGEDIR}${WWWDIR}'
.for DIR in ${WRITABLEDIRS}
- @${CHOWN} -R '${WWWOWN}:${WWWGRP}' '${WWWDIR}/${DIR}'
- @${FIND} '${WWWDIR}/${DIR}' -type d -print0 | ${XARGS} -0 ${CHMOD} u=rwx,go=rx
- @${FIND} '${WWWDIR}/${DIR}' -type f -print0 | ${XARGS} -0 ${CHMOD} u=rw,go=r
+ @${CHOWN} -R '${WWWOWN}:${WWWGRP}' '${STAGEDIR}${WWWDIR}/${DIR}'
+ @${FIND} '${STAGEDIR}${WWWDIR}/${DIR}' -type d -print0 | ${XARGS} -0 ${CHMOD} u=rwx,go=rx
+ @${FIND} '${STAGEDIR}${WWWDIR}/${DIR}' -type f -print0 | ${XARGS} -0 ${CHMOD} u=rw,go=r
.endfor
-post-install:
- @${CAT} ${PKGMESSAGE}
-
.include <bsd.port.mk>
diff --git a/www/pivotx/pkg-plist b/www/pivotx/pkg-plist
index c09f1bd4ae5a..d1ecb6b3f5dd 100644
--- a/www/pivotx/pkg-plist
+++ b/www/pivotx/pkg-plist
@@ -1,3 +1,5 @@
+@owner www
+@group www
%%WWWDIR%%/images/index.html
%%WWWDIR%%/index.php
%%WWWDIR%%/pivotx/ajaxhelper.php