aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2012-06-04 04:52:29 +0800
committerpgj <pgj@FreeBSD.org>2012-06-04 04:52:29 +0800
commit0a710f368469e3e4eae0e43e8df218c8a9983268 (patch)
treef1130d11cb235986af009fc8b05aa63a6548dcdd /www
parentba25a6ecc79a73710fb284c6682d27fad65d1d0e (diff)
downloadfreebsd-ports-gnome-0a710f368469e3e4eae0e43e8df218c8a9983268.tar.gz
freebsd-ports-gnome-0a710f368469e3e4eae0e43e8df218c8a9983268.tar.zst
freebsd-ports-gnome-0a710f368469e3e4eae0e43e8df218c8a9983268.zip
- Update The Glorious Glasgow Haskell Compiler to version 7.4.1
Please note that port revision for all the Haskell ports without version changes are also bumped. Other per-port updates are coming soon (in separate commits)! In addition to that, separate -docs ports are no longer needed so they are now removed. Thanks ashish@ for the assistance. Obtained from: FreeBSD Haskell
Diffstat (limited to 'www')
-rw-r--r--www/Makefile7
-rw-r--r--www/hs-cgi/Makefile2
-rw-r--r--www/hs-css-text/Makefile1
-rw-r--r--www/hs-fastcgi/Makefile2
-rw-r--r--www/hs-hS3/Makefile2
-rw-r--r--www/hs-http-server/Makefile2
-rw-r--r--www/hs-http-server/files/patch-Network__HTTP__Server.hs13
-rw-r--r--www/hs-http-server/files/patch-Network__HTTP__Server__Utils.hs18
-rw-r--r--www/hs-oeis/Makefile2
-rw-r--r--www/hs-recaptcha/Makefile1
-rw-r--r--www/hs-scgi/Makefile2
11 files changed, 41 insertions, 11 deletions
diff --git a/www/Makefile b/www/Makefile
index 9a7f06f9c2cb..3868e2190dd9 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -288,13 +288,9 @@
SUBDIR += hs-hS3
SUBDIR += hs-hamlet
SUBDIR += hs-happstack
- SUBDIR += hs-happstack-data
- SUBDIR += hs-happstack-ixset
SUBDIR += hs-happstack-server
- SUBDIR += hs-happstack-state
- SUBDIR += hs-happstack-util
SUBDIR += hs-heist
- SUBDIR += hs-http-enumerator
+ SUBDIR += hs-http-conduit
SUBDIR += hs-http-server
SUBDIR += hs-http-types
SUBDIR += hs-oeis
@@ -322,6 +318,7 @@
SUBDIR += hs-yesod-form
SUBDIR += hs-yesod-json
SUBDIR += hs-yesod-persistent
+ SUBDIR += hs-yesod-routes
SUBDIR += htdump
SUBDIR += html2hdml
SUBDIR += html2wml
diff --git a/www/hs-cgi/Makefile b/www/hs-cgi/Makefile
index 6640af089d47..76f3436f7ab6 100644
--- a/www/hs-cgi/Makefile
+++ b/www/hs-cgi/Makefile
@@ -7,7 +7,7 @@
PORTNAME= cgi
PORTVERSION= 3001.1.7.4
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 1
CATEGORIES= www haskell
diff --git a/www/hs-css-text/Makefile b/www/hs-css-text/Makefile
index b111f7eeeea4..1da62b78119c 100644
--- a/www/hs-css-text/Makefile
+++ b/www/hs-css-text/Makefile
@@ -7,6 +7,7 @@
PORTNAME= css-text
PORTVERSION= 0.1.1
+PORTREVISION= 1
CATEGORIES= www haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/www/hs-fastcgi/Makefile b/www/hs-fastcgi/Makefile
index 213d98f64fe1..9a7d0d680baf 100644
--- a/www/hs-fastcgi/Makefile
+++ b/www/hs-fastcgi/Makefile
@@ -7,7 +7,7 @@
PORTNAME= fastcgi
PORTVERSION= 3001.0.2.3
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= www haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/www/hs-hS3/Makefile b/www/hs-hS3/Makefile
index 6cf8224e086d..3f3ca5c6d1ec 100644
--- a/www/hs-hS3/Makefile
+++ b/www/hs-hS3/Makefile
@@ -7,7 +7,7 @@
PORTNAME= hS3
PORTVERSION= 0.5.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/www/hs-http-server/Makefile b/www/hs-http-server/Makefile
index 77ed28c69664..e3c61e122722 100644
--- a/www/hs-http-server/Makefile
+++ b/www/hs-http-server/Makefile
@@ -7,7 +7,7 @@
PORTNAME= http-server
PORTVERSION= 1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= www haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/www/hs-http-server/files/patch-Network__HTTP__Server.hs b/www/hs-http-server/files/patch-Network__HTTP__Server.hs
new file mode 100644
index 000000000000..0c736fa6a37d
--- /dev/null
+++ b/www/hs-http-server/files/patch-Network__HTTP__Server.hs
@@ -0,0 +1,13 @@
+--- ./Network/HTTP/Server.hs.orig 2009-06-13 03:58:45.000000000 +0200
++++ ./Network/HTTP/Server.hs 2012-05-13 21:03:32.137467690 +0200
+@@ -123,8 +123,9 @@
+
+ client sock addr =
+ do let name = ppSockAddr addr ""
++ let port = ppSockPort addr
+ logInfo lg 0 ("Accepted connection from " ++ name)
+- conn <- socketConnection name sock -- XXX: name?
++ conn <- socketConnection name port sock -- XXX: name?
+ setStreamHooks conn nullHooks { hook_close =
+ logInfo lg 0 ("Closing connection to " ++ ppSockAddr addr "")
+ }
diff --git a/www/hs-http-server/files/patch-Network__HTTP__Server__Utils.hs b/www/hs-http-server/files/patch-Network__HTTP__Server__Utils.hs
new file mode 100644
index 000000000000..d816ca0cf2f9
--- /dev/null
+++ b/www/hs-http-server/files/patch-Network__HTTP__Server__Utils.hs
@@ -0,0 +1,18 @@
+--- ./Network/HTTP/Server/Utils.hs.orig 2009-06-13 03:58:45.000000000 +0200
++++ ./Network/HTTP/Server/Utils.hs 2012-05-13 21:03:02.570464902 +0200
+@@ -48,11 +48,11 @@
+
+ ppSockAddr :: SockAddr -> ShowS
+ ppSockAddr (SockAddrInet port addr) = ppHostAddress addr
+- . showChar ':' . shows port
+ #ifdef _OS_UNIX
+-ppSockAddr (SockAddrInet6 port _ addr _) =
+- ppHostAddress6 addr . showChar ':' . shows port
++ppSockAddr (SockAddrInet6 port _ addr _) = ppHostAddress6 addr
+ ppSockAddr (SockAddrUnix sock) = showString "unix/" . showString sock
+ #endif
+
+-
++ppSockPort :: SockAddr -> Int
++ppSockPort (SockAddrInet port _) = fromIntegral port
++ppSockPort (SockAddrInet6 port _ _ _) = fromIntegral port
diff --git a/www/hs-oeis/Makefile b/www/hs-oeis/Makefile
index 099721e09fc3..e4897d395945 100644
--- a/www/hs-oeis/Makefile
+++ b/www/hs-oeis/Makefile
@@ -7,7 +7,7 @@
PORTNAME= oeis
PORTVERSION= 0.3.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/www/hs-recaptcha/Makefile b/www/hs-recaptcha/Makefile
index ab501b7988b6..6b48d611be4e 100644
--- a/www/hs-recaptcha/Makefile
+++ b/www/hs-recaptcha/Makefile
@@ -7,6 +7,7 @@
PORTNAME= recaptcha
PORTVERSION= 0.1
+PORTREVISION= 1
CATEGORIES= www haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/www/hs-scgi/Makefile b/www/hs-scgi/Makefile
index 11c748c3cb21..f34eff70d020 100644
--- a/www/hs-scgi/Makefile
+++ b/www/hs-scgi/Makefile
@@ -9,7 +9,7 @@
PORTNAME= scgi
PORTVERSION= 0.3.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www haskell
MAINTAINER= haskell@FreeBSD.org