aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-05-17 21:42:49 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-05-17 21:42:49 +0800
commit0d2b51b2684926d76239f627ae8025c3dda1fded (patch)
tree6af078fb4b84d38f79394649f1faa7324c7e7e6c /www
parent1bb1aea0495d49b400f7955a035f9be5ece14158 (diff)
downloadfreebsd-ports-gnome-0d2b51b2684926d76239f627ae8025c3dda1fded.tar.gz
freebsd-ports-gnome-0d2b51b2684926d76239f627ae8025c3dda1fded.tar.zst
freebsd-ports-gnome-0d2b51b2684926d76239f627ae8025c3dda1fded.zip
- Clarify LICENSE
- Add LICENSE_FILE - Switch to USES=localbase - Convert to USES=mysql - Switch to options helpers - Cosmetic fixes - Fix memcached support (needs libmemcached, not memcached dependency)
Diffstat (limited to 'www')
-rw-r--r--www/c-icap/Makefile120
-rw-r--r--www/c-icap/pkg-descr2
2 files changed, 40 insertions, 82 deletions
diff --git a/www/c-icap/Makefile b/www/c-icap/Makefile
index 55977ee60afe..b10c226fc796 100644
--- a/www/c-icap/Makefile
+++ b/www/c-icap/Makefile
@@ -11,101 +11,59 @@ DISTNAME= c_icap-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= ICAP server implementation
-LICENSE= LGPL21
+LICENSE= LGPL21+
+LICENSE_FILE= ${WRKSRC}/COPYING
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --sysconfdir="${PREFIX}/etc/c-icap" \
+ --localstatedir=/var
INSTALL_TARGET= install-strip
-USES= cpe libtool
+USES= cpe libtool localbase
CPE_VENDOR= c-icap_project
USE_LDCONFIG= yes
USE_RC_SUBR= c-icap
-OPTIONS_DEFINE= BDB IPV6 LDAP PERL POSIXSEM LARGE_FILES MEMCACHE
-OPTIONS_DEFAULT= IPV6
-LARGE_FILES_DESC= Enable large files support
-POSIXSEM_DESC= Use POSIX Semaphores instead of SYSV IPC
-MEMCACHE_DESC= Enable memcached
+USERS= ${CICAP_USER}
+GROUPS= ${CICAP_GROUP}
CICAP_USER= c_icap
CICAP_UID= 959
CICAP_GROUP= c_icap
CICAP_GID= 959
-USERS= ${CICAP_USER}
-GROUPS= ${CICAP_GROUP}
-
-CONFIGURE_ARGS+= --sysconfdir="${PREFIX}/etc/c-icap" \
- --localstatedir=/var
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MBDB}
-USE_BDB= yes
-.endif
-
-.if ${PORT_OPTIONS:MIPV6}
-CONFIGURE_ARGS+= --enable-ipv6
-.else
-CONFIGURE_ARGS+= --disable-ipv6
-.endif
-
-.if ${PORT_OPTIONS:MLARGE_FILES}
-CONFIGURE_ARGS+= --enable-large-files
-.else
-CONFIGURE_ARGS+= --disable-large-files
-.endif
-
-.if ${PORT_OPTIONS:MMEMCACHE}
-CONFIGURE_ARGS+= --with-memcached
-BUILD_DEPENDS= memcached:databases/memcached
-PLIST_SUB+= MEMCACHE=""
-.else
-CONFIGURE_ARGS+= --without-memcached
-PLIST_SUB+= MEMCACHE="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MLDAP}
-USE_OPENLDAP= YES
-.endif
-
-.if ${PORT_OPTIONS:MPERL}
-USES+= perl5
-.endif
-
-.if ${PORT_OPTIONS:MBDB}
-CFLAGS+= -I${BDB_INCLUDE_DIR}
-LDFLAGS+= -L${BDB_LIB_DIR}
-CONFIGURE_ARGS+= --with-bdb=yes
-PLIST_SUB+= BDB=""
-.else
-CONFIGURE_ARGS+= --with-bdb=no
-PLIST_SUB+= BDB="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MLDAP}
-CONFIGURE_ARGS+= --with-ldap=yes
-PLIST_SUB+= LDAP=""
-.else
-CONFIGURE_ARGS+= --with-ldap=no
-PLIST_SUB+= LDAP="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MPERL}
-PLIST_SUB+= PERL=""
-CONFIGURE_ARGS+= --with-perl=${PERL}
-.else
-PLIST_SUB+= PERL="@comment "
-CONFIGURE_ARGS+= --without-perl
-.endif
-
-CFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-
LOG_DIR= /var/log/c-icap
RUN_DIR= /var/run/c-icap
-PLIST_SUB+= LOG_DIR=${LOG_DIR} RUN_DIR=${RUN_DIR} \
+PLIST_SUB= LOG_DIR=${LOG_DIR} RUN_DIR=${RUN_DIR} \
CICAP_USER=${CICAP_USER} CICAP_GROUP=${CICAP_GROUP}
-SUB_LIST+= RUN_DIR=${RUN_DIR} CICAP_USER=${CICAP_USER}
+SUB_LIST= RUN_DIR=${RUN_DIR} CICAP_USER=${CICAP_USER}
+
+OPTIONS_DEFINE= BDB IPV6 LDAP PERL POSIXSEM LARGE_FILES MEMCACHE
+OPTIONS_DEFAULT= IPV6
+OPTIONS_SUB= yes
+LARGE_FILES_DESC= Enable large files support
+POSIXSEM_DESC= Use POSIX Semaphores instead of SYSV IPC
+MEMCACHE_DESC= Enable memcached
+
+IPV6_CONFIGURE_ENABLE= ipv6
+
+LARGE_FILES_CONFIGURE_ENABLE= large-files
+
+MEMCACHE_CONFIGURE_WITH= memcached
+MEMCACHE_LIB_DEPENDS= libmemcached.so:databases/libmemcached
+
+LDAP_USE= OPENLDAP=yes
+LDAP_CONFIGURE_ON= --with-ldap=yes
+LDAP_CONFIGURE_OFF= --with-ldap=no
+
+PERL_USES= perl5
+PERL_CONFIGURE_ON= --with-perl=${PERL}
+PERL_CONFIGURE_OFF= --without-perl
+
+BDB_USE= BDB=yes
+BDB_CFLAGS= -I${BDB_INCLUDE_DIR}
+BDB_LDFLAGS= -L${BDB_LIB_DIR}
+BDB_CONFIGURE_ON= --with-bdb=yes
+BDB_CONFIGURE_OFF= --with-bdb=no
post-patch:
@${REINPLACE_CMD} \
@@ -115,11 +73,11 @@ post-patch:
@${REINPLACE_CMD} \
-e 's|\.default|.sample|g' \
${WRKSRC}/Makefile.am ${WRKSRC}/Makefile.in
-.if ${PORT_OPTIONS:MPOSIXSEM}
+
+post-patch-POSIXSEM-on:
@${REINPLACE_CMD} \
-e 's|@SYSV_IPC@|0|g' \
${WRKSRC}/include/c-icap-conf.h.in
-.endif
post-install:
@${MKDIR} ${STAGEDIR}/${LOG_DIR} ${STAGEDIR}/${RUN_DIR}
diff --git a/www/c-icap/pkg-descr b/www/c-icap/pkg-descr
index 77130b16b03e..bd94c69f79fd 100644
--- a/www/c-icap/pkg-descr
+++ b/www/c-icap/pkg-descr
@@ -5,7 +5,7 @@ proxies that support the ICAP protocol to implement content adaptation and
filtering services.
Most of the commercial HTTP proxies must support the ICAP protocol. The open
-source Squid 3.x proxy server supports it.
+source Squid 3.x proxy server supports it.
Major features: