aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorkevlo <kevlo@FreeBSD.org>2014-05-24 23:09:58 +0800
committerkevlo <kevlo@FreeBSD.org>2014-05-24 23:09:58 +0800
commit0dd9fc15a37952b28e4296e6ae773dcb3602dec8 (patch)
tree0a5029b128239927253e7d5d3cf0316863059765 /www
parent6acf8ea2b077589ee0d8fb1ef92ea9acb688edbe (diff)
downloadfreebsd-ports-gnome-0dd9fc15a37952b28e4296e6ae773dcb3602dec8.tar.gz
freebsd-ports-gnome-0dd9fc15a37952b28e4296e6ae773dcb3602dec8.tar.zst
freebsd-ports-gnome-0dd9fc15a37952b28e4296e6ae773dcb3602dec8.zip
Stage support
PR: ports/190144 Submitted by: Joseph Benden
Diffstat (limited to 'www')
-rw-r--r--www/hotcrp/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/www/hotcrp/Makefile b/www/hotcrp/Makefile
index 21eb6c662b93..b6e1c17263b4 100644
--- a/www/hotcrp/Makefile
+++ b/www/hotcrp/Makefile
@@ -10,7 +10,7 @@ COMMENT= Web based conference management software
RUN_DEPENDS= ${PEARDIR}/Mail.php:${PORTSDIR}/mail/pear-Mail \
${PEARDIR}/Mail/mime.php:${PORTSDIR}/mail/pear-Mail_Mime \
- pdftohtml:${PORTSDIR}/textproc/pdftohtml \
+ pdf-to-html:${PORTSDIR}/textproc/pdftohtml \
zip:${PORTSDIR}/archivers/zip
USE_PHP= mysqli gd session ctype
@@ -26,11 +26,10 @@ SUB_FILES= pkg-message
LICENSE= BSD
LICENSE_FILE= ${WRKSRC}/LICENSE
-NO_STAGE= yes
do-install:
- ${MKDIR} ${WWWDIR}
- @cd ${WRKSRC} && ${COPYTREE_SHARE} . ${WWWDIR}
- ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${WWWDIR}
+ ${MKDIR} ${STAGEDIR}${WWWDIR}
+ @cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR}
+ ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${STAGEDIR}${WWWDIR}
post-install:
@${CAT} ${PKGMESSAGE}