aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authortota <tota@FreeBSD.org>2014-05-18 18:22:44 +0800
committertota <tota@FreeBSD.org>2014-05-18 18:22:44 +0800
commit117e28a2970b331b5e9211cec7d40a6f85f5507e (patch)
tree70f7cc01d2828a71e2043f1fca3444773a0877c1 /www
parent8af01110e9203e826cf0ceb4f5d0eeee14a35449 (diff)
downloadfreebsd-ports-gnome-117e28a2970b331b5e9211cec7d40a6f85f5507e.tar.gz
freebsd-ports-gnome-117e28a2970b331b5e9211cec7d40a6f85f5507e.tar.zst
freebsd-ports-gnome-117e28a2970b331b5e9211cec7d40a6f85f5507e.zip
- Convert to new LIB_DEPENDS format
- Make use of AP_FAST_BUILD - Support STAGEDIR * Make PORTDOCS and PORTEXAMPLES unconditional to stage - Add OPTIONS_DEFINE for DOCS and EXAMPLES - Unmute INSTALL_DATA - Fix typo in x-generate-tarball target - Replace tab with a single space after WWW: in pkg-descr - Make use of @sample in pkg-plist
Diffstat (limited to 'www')
-rw-r--r--www/mod_amazon_proxy/Makefile36
-rw-r--r--www/mod_amazon_proxy/pkg-descr2
-rw-r--r--www/mod_amazon_proxy/pkg-plist4
3 files changed, 16 insertions, 26 deletions
diff --git a/www/mod_amazon_proxy/Makefile b/www/mod_amazon_proxy/Makefile
index 546ba9faae93..ae26408ff547 100644
--- a/www/mod_amazon_proxy/Makefile
+++ b/www/mod_amazon_proxy/Makefile
@@ -10,9 +10,10 @@ MASTER_SITE_SUBDIR= tota/${PORTNAME}
MAINTAINER= tota@FreeBSD.org
COMMENT= Amazon Auth Proxy for Product Advertising API
-LIB_DEPENDS= apreq2:${PORTSDIR}/www/libapreq2
+LIB_DEPENDS= libapreq2.so:${PORTSDIR}/www/libapreq2
USE_APACHE= 22
+AP_FAST_BUILD= yes
CONFFILE= httpd-amazon-proxy.conf
CONFDIR= ${PREFIX}/${APACHEETCDIR}/Includes
@@ -20,36 +21,27 @@ CONFDIR= ${PREFIX}/${APACHEETCDIR}/Includes
PORTDOCS= README
PORTEXAMPLES= rpaproxy.yaml
-NO_STAGE= yes
+OPTIONS_DEFINE= DOCS EXAMPLES
+
post-patch:
@${REINPLACE_CMD} -e 's|modules|${APACHEMODDIR}|' ${WRKSRC}/${CONFFILE}.sample
-do-build:
- @${APXS} -c ${BUILD_WRKSRC}/${PORTNAME}.c
-
-do-install:
- @${APXS} -i ${INSTALL_WRKSRC}/${PORTNAME}.la
- ${INSTALL_DATA} ${WRKSRC}/${CONFFILE}.sample ${CONFDIR}
- @if [ ! -f ${CONFDIR}/${CONFFILE} ]; then \
- ${CP} -p ${CONFDIR}/${CONFFILE}.sample ${CONFDIR}/${CONFFILE}; \
- fi
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}
-.endif
-.if !defined(NOPORTEXAMPLES)
- @${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/${PORTEXAMPLES} ${EXAMPLESDIR}
-.endif
+post-install:
+ @${MKDIR} ${STAGEDIR}${CONFDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${CONFFILE}.sample ${STAGEDIR}${CONFDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${STAGEDIR}${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTEXAMPLES} ${STAGEDIR}${EXAMPLESDIR}
x-generate-tarball:
${SETENV} ${FETCH_ENV} ${FETCH_BINARY} -m -o ${PORTNAME}.tar.gz \
https://github.com/machu/mod_amazon_proxy/tarball/master
target=`${TAR} -tvf ${PORTNAME}.tar.gz | head -n 1`; \
dir=`${ECHO} $${target} | ${AWK} '{print $$9}' | ${SED} -e 's|/$$||'`; \
- year=`${ECHO} $${target} | ${AWK} '{print $$8}`; \
- month=`${ECHO} $${target} | ${AWK} '{print $$6}`; \
- day=`${ECHO} $${target} | ${AWK} '{print $$7}`; \
+ year=`${ECHO} $${target} | ${AWK} '{print $$8}'`; \
+ month=`${ECHO} $${target} | ${AWK} '{print $$6}'`; \
+ day=`${ECHO} $${target} | ${AWK} '{print $$7}'`; \
date=`date -j -f "%B %d %Y" "$${month} $${day} $${year}" +"%Y%m%d"`; \
${TAR} -zxf ${PORTNAME}.tar.gz; \
${RM} ${PORTNAME}.tar.gz; \
diff --git a/www/mod_amazon_proxy/pkg-descr b/www/mod_amazon_proxy/pkg-descr
index 870387603492..10d2fd606a61 100644
--- a/www/mod_amazon_proxy/pkg-descr
+++ b/www/mod_amazon_proxy/pkg-descr
@@ -1,4 +1,4 @@
Authentication Proxy Server of Amazon Product Advertising API for
Apache module.
-WWW: https://github.com/machu/mod_amazon_proxy
+WWW: https://github.com/machu/mod_amazon_proxy
diff --git a/www/mod_amazon_proxy/pkg-plist b/www/mod_amazon_proxy/pkg-plist
index 5c1bad985fba..142ae85cca8d 100644
--- a/www/mod_amazon_proxy/pkg-plist
+++ b/www/mod_amazon_proxy/pkg-plist
@@ -1,4 +1,2 @@
%%APACHEMODDIR%%/mod_amazon_proxy.so
-@unexec if cmp -s %D/%%APACHEETCDIR%%/Includes/httpd-amazon-proxy.conf.sample %D/%%APACHEETCDIR%%/Includes/httpd-amazon-proxy.conf; then rm -f %D/%%APACHEETCDIR%%/Includes/httpd-amazon-proxy.conf; fi
-%%APACHEETCDIR%%/Includes/httpd-amazon-proxy.conf.sample
-@exec [ -f %B/%%APACHEETCDIR%%/Includes/httpd-amazon-proxy.conf ] || cp %B/%f %B/%%APACHEETCDIR%%/Includes/httpd-amazon-proxy.conf
+@sample %%APACHEETCDIR%%/Includes/httpd-amazon-proxy.conf.sample