aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2014-05-25 13:22:44 +0800
committermiwi <miwi@FreeBSD.org>2014-05-25 13:22:44 +0800
commit11a7d51056b62ac8b18301b55b122f1db522897c (patch)
tree30e0862ccc1ceda5e9c101745a20485ef3bafe31 /www
parentd33beae8c63b7477d81cae61046909415d9e9a5c (diff)
downloadfreebsd-ports-gnome-11a7d51056b62ac8b18301b55b122f1db522897c.tar.gz
freebsd-ports-gnome-11a7d51056b62ac8b18301b55b122f1db522897c.tar.zst
freebsd-ports-gnome-11a7d51056b62ac8b18301b55b122f1db522897c.zip
- Stage support
PR: 190115
Diffstat (limited to 'www')
-rw-r--r--www/geronimo/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/www/geronimo/Makefile b/www/geronimo/Makefile
index ebc6d20ac6b5..daf115da6eff 100644
--- a/www/geronimo/Makefile
+++ b/www/geronimo/Makefile
@@ -21,7 +21,6 @@ SUB_FILES= pkg-deinstall
OPTIONS_DEFINE= TOMCAT7
TOMCAT7_DESC= Use Tomcat instead of default Jetty
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MTOMCAT7}
@@ -77,10 +76,11 @@ post-patch:
@${REINPLACE_CMD} -e '/^activemq.data/s|= |= ${APP_HOME}/|' ${WRKSRC}/var/config/config-substitutions.properties
do-install:
- ${MKDIR} ${APP_HOME} && ${CHOWN} ${GERONIMO_USER}:${GERONIMO_GROUP} ${APP_HOME}
+ ${MKDIR} ${STAGEDIR}${APP_HOME} && ${CHOWN} ${GERONIMO_USER}:${GERONIMO_GROUP} ${STAGEDIR}${APP_HOME}
@(cd ${WRKSRC} && ${FIND} . |\
- ${CPIO} -pdmu -R ${GERONIMO_USER}:${GERONIMO_GROUP} ${APP_HOME})
- ${INSTALL} -o ${GERONIMO_USER} -g ${GERONIMO_GROUP} -m 0644 /dev/null ${GERONIMO_OUT}
+ ${CPIO} -pdmu -R ${GERONIMO_USER}:${GERONIMO_GROUP} ${STAGEDIR}${APP_HOME})
+ ${INSTALL} -o ${GERONIMO_USER} -g ${GERONIMO_GROUP} -m 0644 /dev/null ${STAGEDIR}${GERONIMO_OUT}
+
post-install:
@${ECHO_MSG} "${APP_TITLE} ${PORTVERSION} has been installed in ${APP_HOME}."
@${FIND} -s ${WRKSRC} -not -type d | \