aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2010-08-31 09:13:56 +0800
committerpgollucci <pgollucci@FreeBSD.org>2010-08-31 09:13:56 +0800
commit1756e09018443c12a90986f07884abac04f3b4af (patch)
tree1deefb32c30bff06f32915c973b00d0b1a199c13 /www
parentc30e62ecd9452c804863daaaba9af71d9462db05 (diff)
downloadfreebsd-ports-gnome-1756e09018443c12a90986f07884abac04f3b4af.tar.gz
freebsd-ports-gnome-1756e09018443c12a90986f07884abac04f3b4af.tar.zst
freebsd-ports-gnome-1756e09018443c12a90986f07884abac04f3b4af.zip
- pet portlint
- add OPTIONS - use apxs not sed in pkg-plist - use PLIST_SUB vars in pkg-plist - bump PORTREVISION PR: ports/147145 Submitted by: myself (pgollucci) Approved by: maintainer timeout (tmueko@kommunity.net ; ~3 months) With Hat: apache@
Diffstat (limited to 'www')
-rw-r--r--www/mod_clamav/Makefile8
-rw-r--r--www/mod_clamav/pkg-plist4
2 files changed, 8 insertions, 4 deletions
diff --git a/www/mod_clamav/Makefile b/www/mod_clamav/Makefile
index 42451c3c850e..93ad9bb30d34 100644
--- a/www/mod_clamav/Makefile
+++ b/www/mod_clamav/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mod_clamav
PORTVERSION= 0.23
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= www security
MASTER_SITES= http://software.othello.ch/mod_clamav/ \
http://www.kommunity.net/download/mod_clamav/
@@ -16,12 +16,16 @@ PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
MAINTAINER= tmueko@kommunity.net
COMMENT= Scans content delivered by the Apache20 proxy module for viruses
-MAKE_JOBS_SAFE= yes
+MAKE_JOBS_SAFE= yes
USE_AUTOTOOLS= libtool:22
USE_APACHE= 2.2
GNU_CONFIGURE= yes
+OPTIONS= CLAMAVDEVEL "Use development version of CLAMAV" off
+
+.include <bsd.port.options.mk>
+
.if defined(WITH_CLAMAVDEVEL)
LIB_DEPENDS+= clamav.7:${PORTSDIR}/security/clamav-devel
.else
diff --git a/www/mod_clamav/pkg-plist b/www/mod_clamav/pkg-plist
index c135a9884b7b..90da21dfd03b 100644
--- a/www/mod_clamav/pkg-plist
+++ b/www/mod_clamav/pkg-plist
@@ -1,3 +1,3 @@
-@unexec /usr/bin/sed -i '' '/LoadModule %%AP_NAME%%_module/d' %D/%%APACHEETCDIR%%/httpd.conf
-%%APACHEMODDIR%%/%%AP_MODULE%%
@exec %D/sbin/apxs -e -a -n %%AP_NAME%% %D/%f
+%%APACHEMODDIR%%/%%AP_MODULE%%
+@unexec %D/sbin/apxs -e -A -n %%AP_NAME%% %D/%f