aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2017-03-28 15:22:10 +0800
committervanilla <vanilla@FreeBSD.org>2017-03-28 15:22:10 +0800
commit179b5ca3251cc7ec972e01d23cb9f8d00135ac61 (patch)
tree74bf8c539e08f32c634d301516dc3be857e1dd0a /www
parente9b9cb90e8bf38804ce4fb54ca20f233dc753863 (diff)
downloadfreebsd-ports-gnome-179b5ca3251cc7ec972e01d23cb9f8d00135ac61.tar.gz
freebsd-ports-gnome-179b5ca3251cc7ec972e01d23cb9f8d00135ac61.tar.zst
freebsd-ports-gnome-179b5ca3251cc7ec972e01d23cb9f8d00135ac61.zip
Update to 1.33.1.
PR: 218171 Submitted by: maintainer
Diffstat (limited to 'www')
-rw-r--r--www/ufdbguard/Makefile16
-rw-r--r--www/ufdbguard/distinfo4
-rw-r--r--www/ufdbguard/files/patch-src_Makefile.in2
-rw-r--r--www/ufdbguard/files/patch-src_check__config__file14
-rw-r--r--www/ufdbguard/files/patch-src_install__etcfiles.sh.in24
-rw-r--r--www/ufdbguard/files/patch-src_sg.h.in11
-rw-r--r--www/ufdbguard/files/patch-src_ufdbGuard.conf.in2
7 files changed, 48 insertions, 25 deletions
diff --git a/www/ufdbguard/Makefile b/www/ufdbguard/Makefile
index d8853126b6ec..21397769ecf3 100644
--- a/www/ufdbguard/Makefile
+++ b/www/ufdbguard/Makefile
@@ -2,9 +2,9 @@
# $FreeBSD$
PORTNAME= ufdbGuard
-PORTVERSION= 1.32.4
+PORTVERSION= 1.33.1
CATEGORIES= www
-MASTER_SITES= SF/ufdbguard/1.32
+MASTER_SITES= SF/ufdbguard/1.33
MAINTAINER= timp87@gmail.com
COMMENT= URL filter for the Squid web proxy
@@ -64,6 +64,16 @@ UNIXSOCKETS_CONFIGURE_OFF= --without-unix-sockets
UNIXSOCKETS_DESC= Unix sockets support
+.include <bsd.port.pre.mk>
+
+.if ${SSL_DEFAULT:Mopenssl-devel}
+BROKEN= Does not build with openssl-devel
+.endif
+
+.if ${SSL_DEFAULT:Mlibressl-devel}
+BROKEN= Does not build with libressl-devel
+.endif
+
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/ufdbguardd \
${STAGEDIR}${PREFIX}/bin/ufdbgclient \
@@ -72,4 +82,4 @@ post-install:
${STAGEDIR}${PREFIX}/bin/ufdbAnalyse \
${STAGEDIR}${PREFIX}/bin/ufdbhttpd
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/www/ufdbguard/distinfo b/www/ufdbguard/distinfo
index 693c6a3f56c0..1a71a1070722 100644
--- a/www/ufdbguard/distinfo
+++ b/www/ufdbguard/distinfo
@@ -1,3 +1,3 @@
TIMESTAMP = 1480157749
-SHA256 (ufdbGuard-1.32.4.tar.gz) = 037d2652087a544e4bfa10fefcb9e155e730536baf39331b3e9dca26c605e3df
-SIZE (ufdbGuard-1.32.4.tar.gz) = 2499206
+SHA256 (ufdbGuard-1.33.1.tar.gz) = f927410049e0ba8d1757daf3de67bb1bb1bf1e5caa1d51f19ed052b52f135a92
+SIZE (ufdbGuard-1.33.1.tar.gz) = 2481303
diff --git a/www/ufdbguard/files/patch-src_Makefile.in b/www/ufdbguard/files/patch-src_Makefile.in
index aa518f6dc686..9bc380725197 100644
--- a/www/ufdbguard/files/patch-src_Makefile.in
+++ b/www/ufdbguard/files/patch-src_Makefile.in
@@ -1,4 +1,4 @@
---- src/Makefile.in.orig 2016-10-19 19:37:29 UTC
+--- src/Makefile.in.orig 2017-03-14 18:52:13 UTC
+++ src/Makefile.in
@@ -224,7 +224,7 @@ install.bin: ufdbGenTable ufdbAnalyse uf
$(INSTALL_PROGRAM) ufdb_top_urls.pl $(DESTDIR)$(bindir)/ufdb_top_urls
diff --git a/www/ufdbguard/files/patch-src_check__config__file b/www/ufdbguard/files/patch-src_check__config__file
index e2bbb3110ddb..fbe412e00493 100644
--- a/www/ufdbguard/files/patch-src_check__config__file
+++ b/www/ufdbguard/files/patch-src_check__config__file
@@ -1,15 +1,15 @@
---- src/check_config_file.orig 2015-06-09 01:03:32 UTC
+--- src/check_config_file.orig 2017-03-01 14:25:22 UTC
+++ src/check_config_file
@@ -32,16 +32,6 @@ then
exit 1
fi
--if [ ! -f $CONFIG.pre-v1.32 ]
+-if [ ! -f $CONFIG.pre-v1.33 ]
-then
-- cp $CONFIG $CONFIG.pre-v1.32
-- if [ ! -f $CONFIG.pre-v1.32 ]
+- cp $CONFIG $CONFIG.pre-v1.33
+- if [ ! -f $CONFIG.pre-v1.33 ]
- then
-- echo "cannot copy configuration file to $CONFIG.pre-v1.32"
+- echo "cannot copy configuration file to $CONFIG.pre-v1.33"
- exit 1
- fi
-fi
@@ -17,11 +17,11 @@
if [ ! -w $CONFIG ]
then
chmod u+w $CONFIG
-@@ -340,7 +330,6 @@ then
+@@ -496,7 +486,6 @@ then
echo "It is recommended to verify all ACLs for the inclusion of these URL categories ******"
fi
--echo "The original configuration file is saved in $CONFIG.pre-v1.32"
+-echo "The original configuration file is saved in $CONFIG.pre-v1.33"
echo
exit 0
diff --git a/www/ufdbguard/files/patch-src_install__etcfiles.sh.in b/www/ufdbguard/files/patch-src_install__etcfiles.sh.in
index f2ca4c68e161..13afd97bcd93 100644
--- a/www/ufdbguard/files/patch-src_install__etcfiles.sh.in
+++ b/www/ufdbguard/files/patch-src_install__etcfiles.sh.in
@@ -1,4 +1,4 @@
---- src/install_etcfiles.sh.in.orig 2016-08-02 02:36:07 UTC
+--- src/install_etcfiles.sh.in.orig 2017-02-27 13:27:26 UTC
+++ src/install_etcfiles.sh.in
@@ -25,15 +25,6 @@ then
DESTDIR=${RPM_BUILD_ROOT:-}
@@ -29,18 +29,20 @@
esac
-@@ -395,14 +384,3 @@ fi
+@@ -395,16 +384,3 @@ fi
# TODO: copy parameters from ufdbUpdate to $SYSCFGFILE ************************************************************
fix_piddir_permissions
-
--SERVICE=`grep -E -e ufdbguardd /etc/services`
--if [ "$SERVICE" = "" ]
--then
-- (
-- echo ""
-- echo "# for URLfilterDB daemon : "
-- echo "ufdbguardd 3977/tcp"
-- ) >> /etc/services
--fi
+-# the addition of the ufdbguardd service to /etc/services is deiabled since
+-# ufdbguardd uses by default a named socket.
+-# SERVICE=`grep -E -e ufdbguardd $DESTDIR/etc/services`
+-# if [ "$SERVICE" = "" ]
+-# then
+-# (
+-# echo ""
+-# echo "# for URLfilterDB daemon : "
+-# echo "ufdbguardd 3977/tcp"
+-# ) >> $DESTDIR/etc/services
+-# fi
-
diff --git a/www/ufdbguard/files/patch-src_sg.h.in b/www/ufdbguard/files/patch-src_sg.h.in
new file mode 100644
index 000000000000..5e9b09db6258
--- /dev/null
+++ b/www/ufdbguard/files/patch-src_sg.h.in
@@ -0,0 +1,11 @@
+--- src/sg.h.in.orig 2017-03-26 18:55:50 UTC
++++ src/sg.h.in
+@@ -56,6 +56,8 @@ extern "C" {
+
+ #define YY_NEVER_INTERACTIVE 1
+
++#include <netinet/in.h>
++#include <sys/socket.h>
+ #include <stdio.h>
+ #include <unistd.h>
+ #include <stdlib.h>
diff --git a/www/ufdbguard/files/patch-src_ufdbGuard.conf.in b/www/ufdbguard/files/patch-src_ufdbGuard.conf.in
index a09beb6449f7..dd471e1c2f9d 100644
--- a/www/ufdbguard/files/patch-src_ufdbGuard.conf.in
+++ b/www/ufdbguard/files/patch-src_ufdbGuard.conf.in
@@ -1,4 +1,4 @@
---- src/ufdbGuard.conf.in.orig 2016-10-16 22:05:14 UTC
+--- src/ufdbGuard.conf.in.orig 2017-03-08 20:47:38 UTC
+++ src/ufdbGuard.conf.in
@@ -33,7 +33,7 @@ logall off
# valid version numbers are: 2.6, 2.7, 3.0, 3.1, 3.2, 3.3, 3.4, 3.5 and 4.0