aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2015-02-23 22:52:19 +0800
committeradamw <adamw@FreeBSD.org>2015-02-23 22:52:19 +0800
commit19dcc9a3e2f95640e17e85c94e0074b4cba174ef (patch)
tree69038f88ebe5d6f46c9cc589831a7d8c7749135f /www
parent6738bd1c509a9d519ce686cd27e4c7c477625cf8 (diff)
downloadfreebsd-ports-gnome-19dcc9a3e2f95640e17e85c94e0074b4cba174ef.tar.gz
freebsd-ports-gnome-19dcc9a3e2f95640e17e85c94e0074b4cba174ef.tar.zst
freebsd-ports-gnome-19dcc9a3e2f95640e17e85c94e0074b4cba174ef.zip
Add www/p5-CGI-Fast.
This is the continuance of the CGI::Fast module from the CGI distribution. CGI::Fast is a subclass of the CGI object created by CGI.pm. It is specialized to work with the FCGI module, which greatly speeds up CGI scripts by turning them into persistently running server processes. Scripts that perform time-consuming initialization processes, such as loading large modules or opening persistent database connections, will see large performance improvements. If there are no problems with this port, in a week I'll transfer maintainership to perl@.
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-CGI-Fast/Makefile26
-rw-r--r--www/p5-CGI-Fast/distinfo2
-rw-r--r--www/p5-CGI-Fast/pkg-descr8
-rw-r--r--www/p5-CGI-Fast/pkg-plist2
-rw-r--r--www/p5-CGI.pm/Makefile2
6 files changed, 40 insertions, 1 deletions
diff --git a/www/Makefile b/www/Makefile
index 04cacf43cfa5..9073576dde79 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -652,6 +652,7 @@
SUBDIR += p5-CGI-Expand
SUBDIR += p5-CGI-ExtDirect
SUBDIR += p5-CGI-FCKeditor
+ SUBDIR += p5-CGI-Fast
SUBDIR += p5-CGI-FastTemplate
SUBDIR += p5-CGI-FormBuilder
SUBDIR += p5-CGI-Framework
diff --git a/www/p5-CGI-Fast/Makefile b/www/p5-CGI-Fast/Makefile
new file mode 100644
index 000000000000..bd46368ffa8f
--- /dev/null
+++ b/www/p5-CGI-Fast/Makefile
@@ -0,0 +1,26 @@
+# Created by: Adam Weinberger <adamw@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= CGI-Fast
+PORTVERSION= 2.07
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:LEEJO
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= adamw@FreeBSD.org
+COMMENT= Perl CGI Interface for FastCGI
+
+BUILD_DEPENDS= p5-FCGI>=0.67:${PORTSDIR}/www/p5-FCGI
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+TEST_DEPENDS= p5-Test-Deep>=0:${PORTSDIR}/devel/p5-Test-Deep
+
+CONFLICTS= p5-CGI.pm-[1-3]*
+
+USES= perl5
+USE_PERL5= configure
+
+# This will need to be added for perl5.22.
+#BUILD_DEPENDS+=p5-CGI>=4:${PORTSDIR}/www/p5-CGI
+
+.include <bsd.port.mk>
diff --git a/www/p5-CGI-Fast/distinfo b/www/p5-CGI-Fast/distinfo
new file mode 100644
index 000000000000..765b1ece697c
--- /dev/null
+++ b/www/p5-CGI-Fast/distinfo
@@ -0,0 +1,2 @@
+SHA256 (CGI-Fast-2.07.tar.gz) = 44ee580c2224f8a018fc2592dfc1252c3e347014c6dd74f64c23066962f6ba13
+SIZE (CGI-Fast-2.07.tar.gz) = 8626
diff --git a/www/p5-CGI-Fast/pkg-descr b/www/p5-CGI-Fast/pkg-descr
new file mode 100644
index 000000000000..ea1dfa124a08
--- /dev/null
+++ b/www/p5-CGI-Fast/pkg-descr
@@ -0,0 +1,8 @@
+CGI::Fast is a subclass of the CGI object created by CGI.pm. It is specialized
+to work with the FCGI module, which greatly speeds up CGI scripts by turning
+them into persistently running server processes. Scripts that perform
+time-consuming initialization processes, such as loading large modules or
+opening persistent database connections, will see large performance
+improvements.
+
+WWW: https://metacpan.org/pod/CGI::Fast
diff --git a/www/p5-CGI-Fast/pkg-plist b/www/p5-CGI-Fast/pkg-plist
new file mode 100644
index 000000000000..b8eeb7dfb9b9
--- /dev/null
+++ b/www/p5-CGI-Fast/pkg-plist
@@ -0,0 +1,2 @@
+%%SITE_PERL%%/CGI/Fast.pm
+%%PERL5_MAN3%%/CGI::Fast.3.gz
diff --git a/www/p5-CGI.pm/Makefile b/www/p5-CGI.pm/Makefile
index 7fa29843b3a6..78ae0eef4c0c 100644
--- a/www/p5-CGI.pm/Makefile
+++ b/www/p5-CGI.pm/Makefile
@@ -15,7 +15,7 @@ COMMENT= Simple Common Gateway Interface Class for Perl
LICENSE= ART20 GPLv1
LICENSE_COMB= dual
-CONFLICTS= p5-CGI-[4-9]*
+CONFLICTS= p5-CGI-[4-9]* p5-CGI-Fast-[0-9]*
USES= perl5
USE_PERL5= configure