aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2018-11-10 18:09:48 +0800
committermat <mat@FreeBSD.org>2018-11-10 18:09:48 +0800
commit1b0417656969bd1c326432fe019d9a6f6bf42997 (patch)
treeec00e643384652d97e7643f40c6342bff01bff0b /www
parente5874ca09869a82a5afd977e105a07506a5f15ad (diff)
downloadfreebsd-ports-gnome-1b0417656969bd1c326432fe019d9a6f6bf42997.tar.gz
freebsd-ports-gnome-1b0417656969bd1c326432fe019d9a6f6bf42997.tar.zst
freebsd-ports-gnome-1b0417656969bd1c326432fe019d9a6f6bf42997.zip
security/openssl-devel was removed, but there is a security/openssl111 now.
Diffstat (limited to 'www')
-rw-r--r--www/node/Makefile4
-rw-r--r--www/node10/Makefile4
-rw-r--r--www/squid3/Makefile2
-rw-r--r--www/ufdbguard/Makefile2
4 files changed, 6 insertions, 6 deletions
diff --git a/www/node/Makefile b/www/node/Makefile
index a52da0b1e8b1..d8e9af2d5f34 100644
--- a/www/node/Makefile
+++ b/www/node/Makefile
@@ -66,8 +66,8 @@ LIB_DEPENDS+= libcares.so:dns/c-ares\
.if empty(PORT_OPTIONS:MBUNDLED_SSL)
-.if ${OPSYS} == FreeBSD && ${SSL_DEFAULT} != openssl-devel
-IGNORE= node.js requires openssl 1.1.0, add DEFAULT_VERSIONS+=ssl=openssl-devel to /etc/make.conf or enable BUNDLED_SSL option
+.if ${OPSYS} == FreeBSD && ${SSL_DEFAULT} != openssl111
+IGNORE= node.js requires openssl 1.1.0, add DEFAULT_VERSIONS+=ssl=openssl111 to /etc/make.conf or enable BUNDLED_SSL option
.endif
.if !empty(SSL_DEFAULT:Mlibressl*)
diff --git a/www/node10/Makefile b/www/node10/Makefile
index a06cc1b253fc..923165fcafb5 100644
--- a/www/node10/Makefile
+++ b/www/node10/Makefile
@@ -67,8 +67,8 @@ LIB_DEPENDS+= libcares.so:dns/c-ares\
.if empty(PORT_OPTIONS:MBUNDLED_SSL)
-.if ${OPSYS} == FreeBSD && ${SSL_DEFAULT} != openssl-devel
-IGNORE= node.js requires openssl 1.1.0, add DEFAULT_VERSIONS+=ssl=openssl-devel to /etc/make.conf or enable BUNDLED_SSL option
+.if ${OPSYS} == FreeBSD && ${SSL_DEFAULT} != openssl111
+IGNORE= node.js requires openssl 1.1.0, add DEFAULT_VERSIONS+=ssl=openssl111 to /etc/make.conf or enable BUNDLED_SSL option
.endif
.if !empty(SSL_DEFAULT:Mlibressl*)
diff --git a/www/squid3/Makefile b/www/squid3/Makefile
index 16af2055f3d6..7e5e5f7667ee 100644
--- a/www/squid3/Makefile
+++ b/www/squid3/Makefile
@@ -114,7 +114,7 @@ SSL_CONFIGURE_ON= --with-openssl=${OPENSSLBASE} \
LIBOPENSSL_CFLAGS=-I${OPENSSLINC} \
LIBOPENSSL_LIBS="-lcrypto -lssl"
SSL_USES= ssl
-SSL_VARS= BROKEN_SSL=openssl-devel
+SSL_VARS= BROKEN_SSL=openssl111
SSL_CRTD_CONFIGURE_ENABLE= ssl-crtd
SSL_CRTD_IMPLIES= SSL
STACKTRACES_CONFIGURE_ENABLE= stacktraces
diff --git a/www/ufdbguard/Makefile b/www/ufdbguard/Makefile
index cf06e4c53ad2..d7615c460a29 100644
--- a/www/ufdbguard/Makefile
+++ b/www/ufdbguard/Makefile
@@ -13,7 +13,7 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
BROKEN_aarch64= fails to compile: error: regparm is not valid on this platform
-BROKEN_SSL= openssl-devel libressl libressl-devel
+BROKEN_SSL= openssl111 libressl libressl-devel
USES= perl5 shebangfix ssl
SHEBANG_FILES= samples/URLblocked.cgi