aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-12-06 22:57:09 +0800
committermiwi <miwi@FreeBSD.org>2008-12-06 22:57:09 +0800
commit1bd10d164226c81de3cd6c05d951279736f69ec2 (patch)
tree433f1acf00d763afcad9a9d321095b059dc57bdc /www
parentb4943826dcc912d9d366acb535fed50486e83144 (diff)
downloadfreebsd-ports-gnome-1bd10d164226c81de3cd6c05d951279736f69ec2.tar.gz
freebsd-ports-gnome-1bd10d164226c81de3cd6c05d951279736f69ec2.tar.zst
freebsd-ports-gnome-1bd10d164226c81de3cd6c05d951279736f69ec2.zip
OrangeHRM is an Open Source HRM information system that will
provide a vast range of features to manage the crucial organization asset - people. It provides a perfect platform for re-engineering and aligning your HR processes along with the organizational goals. WWW: http://www.orangehrm.com PR: ports/129462 Submitted by: Wen Heping <wenheping at gmail.com>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/orangehrm/Makefile39
-rw-r--r--www/orangehrm/distinfo3
-rw-r--r--www/orangehrm/files/pkg-message.in26
-rw-r--r--www/orangehrm/pkg-descr7
5 files changed, 76 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 8629f49fbd75..6922dbc2fd77 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -549,6 +549,7 @@
SUBDIR += opera
SUBDIR += opera-devel
SUBDIR += opera-linuxplugins
+ SUBDIR += orangehrm
SUBDIR += osb-browser
SUBDIR += osb-nrcit
SUBDIR += osb-nrcore
diff --git a/www/orangehrm/Makefile b/www/orangehrm/Makefile
new file mode 100644
index 000000000000..1ecdfaf0aebc
--- /dev/null
+++ b/www/orangehrm/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: orangehrm
+# Date created: 06 Dec, 2008
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= orangehrm
+PORTVERSION= 2.4.0.1
+CATEGORIES= www misc
+MASTER_SITES= SF
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= Open Source Human Resource Management
+
+.include <bsd.port.pre.mk>
+
+USE_PHP= mysql
+NO_BUILD= yes
+PLIST= ${WRKDIR}/plist
+SUB_FILES= pkg-message
+HRMDIR= www/orangehrm
+
+pre-install:
+ @${FIND} -s -d ${WRKSRC} -type f | ${SED} "s#${WRKSRC}#${HRMDIR}#g" >${PLIST}
+ @${FIND} -s -d ${WRKSRC} -type d | ${SED} "s#${WRKSRC}#@dirrm ${HRMDIR}#g" >> ${PLIST}
+
+do-install:
+ @cd ${WRKSRC} && ${COPYTREE_SHARE} . ${PREFIX}/${HRMDIR}
+ @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${PREFIX}/${HRMDIR}
+ @${ECHO_CMD} '@exec ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${PREFIX}/${HRMDIR}' \
+ >> ${TMPPLIST}
+ ${CHMOD} -R 755 ${PREFIX}/${HRMDIR}
+ @${ECHO_CMD} '@exec ${CHMOD} -R 755 ${PREFIX}/${HRMDIR}' >> ${TMPPLIST}
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/www/orangehrm/distinfo b/www/orangehrm/distinfo
new file mode 100644
index 000000000000..131666f94a45
--- /dev/null
+++ b/www/orangehrm/distinfo
@@ -0,0 +1,3 @@
+MD5 (orangehrm-2.4.0.1.tar.gz) = d1b80ba5d1bfda0cfdbd8c34cc7c3e05
+SHA256 (orangehrm-2.4.0.1.tar.gz) = 265aff5cdb3997f2f471c6c337995e5809cd902206f174ee969abfe71d973166
+SIZE (orangehrm-2.4.0.1.tar.gz) = 1806975
diff --git a/www/orangehrm/files/pkg-message.in b/www/orangehrm/files/pkg-message.in
new file mode 100644
index 000000000000..aa53594823f0
--- /dev/null
+++ b/www/orangehrm/files/pkg-message.in
@@ -0,0 +1,26 @@
+POST-INSTALL CONFIGURATION FOR OrangeHRM
+=====================================
+
+1) Add the following to your Apache configuration, and
+ restart the server:
+
+ ### Add the AcceptPathInfo directive only for Apache 2.0.30 or later.
+ Alias /orangehrm %%PREFIX%%/www/orangehrm/
+ AcceptPathInfo On
+ <Directory %%PREFIX%%/www/orangehrm>
+ AllowOverride None
+ Order Allow,Deny
+ Allow from all
+ </Directory>
+
+2) Visit your OrangeHRM site with a browser (i.e.,
+ http://your.server.com/orangehrm), and you should
+ be taken to the setup script, which will lead
+ you through creating a configuration file and then
+ setting up OrangeHRM, creating an admin account, etc.
+
+For more information, see the INSTALL DOCUMENTATION:
+
+ http://www.orangehrm.com/installation-Linux.shtml
+
+================================================================
diff --git a/www/orangehrm/pkg-descr b/www/orangehrm/pkg-descr
new file mode 100644
index 000000000000..842b74e57405
--- /dev/null
+++ b/www/orangehrm/pkg-descr
@@ -0,0 +1,7 @@
+OrangeHRM is an Open Source HRM information system that will
+provide a vast range of features to manage the crucial
+organization asset - people. It provides a perfect platform
+for re-engineering and aligning your HR processes along with
+the organizational goals.
+
+WWW: http://www.orangehrm.com