aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authordirk <dirk@FreeBSD.org>2000-02-26 07:53:06 +0800
committerdirk <dirk@FreeBSD.org>2000-02-26 07:53:06 +0800
commit1c1c430d4be99e0e9aa54c4c98eba345f639106d (patch)
treee23b3462383de0197701ae250c1c23bca3d435dd /www
parent6b4c099efcb99f34d101f8cda518f697fce378c2 (diff)
downloadfreebsd-ports-gnome-1c1c430d4be99e0e9aa54c4c98eba345f639106d.tar.gz
freebsd-ports-gnome-1c1c430d4be99e0e9aa54c4c98eba345f639106d.tar.zst
freebsd-ports-gnome-1c1c430d4be99e0e9aa54c4c98eba345f639106d.zip
Move "apache performance tuning" from Makefile to scripts/configure.php
and thus make it work again.
Diffstat (limited to 'www')
-rw-r--r--www/mod_php3/Makefile6
-rw-r--r--www/mod_php3/scripts/configure.php4
-rw-r--r--www/mod_php4/Makefile6
-rw-r--r--www/mod_php4/scripts/configure.php4
-rw-r--r--www/mod_php5/Makefile6
-rw-r--r--www/mod_php5/scripts/configure.php4
6 files changed, 9 insertions, 21 deletions
diff --git a/www/mod_php3/Makefile b/www/mod_php3/Makefile
index e33a1e782637..bab9b52577e5 100644
--- a/www/mod_php3/Makefile
+++ b/www/mod_php3/Makefile
@@ -80,12 +80,6 @@ CONFIGURE_ARGS= --prefix=${PREFIX} \
OPTIM= -DHARD_SERVER_LIMIT=512 \
-DDEFAULT_PATH=\\"${PREFIX}/bin:/bin:/usr/bin\\"
-.if defined(APACHE_PERF_TUNING) && ${APACHE_PERF_TUNING} == YES
-OPTIM+= -DBUFFERED_LOGS -DFD_SETSIZE=1024
-CFLAGS+= -O6 -funroll-loops -fstrength-reduce -fomit-frame-pointer \
- -fexpensive-optimizations -ffast-math
-.endif
-
CONFIGURE_ENV= OPTIM='${OPTIM}' LIBS='-L${PREFIX}/lib'
SCRIPTS_ENV= WRKDIRPREFIX="${WRKDIRPREFIX}" \
TOUCH="${TOUCH}" \
diff --git a/www/mod_php3/scripts/configure.php b/www/mod_php3/scripts/configure.php
index cd63d8e788f3..65752d828152 100644
--- a/www/mod_php3/scripts/configure.php
+++ b/www/mod_php3/scripts/configure.php
@@ -53,7 +53,9 @@ exec > ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
while [ "$1" ]; do
case $1 in
\"tuning\")
- echo "APACHE_PERF_TUNING= YES"
+ echo "CFLAGS+= -O6 -funroll-loops -fstrength-reduce -fomit-frame-pointer -fexpensive-optimizations -ffast-math"
+ echo "OPTIM+= -DBUFFERED_LOGS -DFD_SETSIZE=1024"
+ echo "CONFIGURE_ENV+= OPTIM='\${OPTIM}'"
;;
\"GD\")
echo "LIB_DEPENDS+= gd.0:\${PORTSDIR}/graphics/gd"
diff --git a/www/mod_php4/Makefile b/www/mod_php4/Makefile
index 53f80b4d8301..db674f72bb83 100644
--- a/www/mod_php4/Makefile
+++ b/www/mod_php4/Makefile
@@ -82,12 +82,6 @@ CONFIGURE_ARGS= --prefix=${PREFIX} \
OPTIM= -DHARD_SERVER_LIMIT=512 \
-DDEFAULT_PATH=\\"${PREFIX}/bin:/bin:/usr/bin\\"
-.if defined(APACHE_PERF_TUNING) && ${APACHE_PERF_TUNING} == YES
-OPTIM+= -DBUFFERED_LOGS -DFD_SETSIZE=1024
-CFLAGS+= -O6 -funroll-loops -fstrength-reduce -fomit-frame-pointer \
- -fexpensive-optimizations -ffast-math
-.endif
-
CONFIGURE_ENV= OPTIM='${OPTIM}' LIBS='-L${PREFIX}/lib'
SCRIPTS_ENV= WRKDIRPREFIX="${WRKDIRPREFIX}" \
TOUCH="${TOUCH}" \
diff --git a/www/mod_php4/scripts/configure.php b/www/mod_php4/scripts/configure.php
index b639c1284e45..7cc83d96a4c8 100644
--- a/www/mod_php4/scripts/configure.php
+++ b/www/mod_php4/scripts/configure.php
@@ -53,7 +53,9 @@ exec > ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
while [ "$1" ]; do
case $1 in
\"tuning\")
- echo "APACHE_PERF_TUNING= YES"
+ echo "CFLAGS+= -O6 -funroll-loops -fstrength-reduce -fomit-frame-pointer -fexpensive-optimizations -ffast-math"
+ echo "OPTIM+= -DBUFFERED_LOGS -DFD_SETSIZE=1024"
+ echo "CONFIGURE_ENV+= OPTIM='\${OPTIM}'"
;;
\"GD\")
echo "LIB_DEPENDS+= gd.0:\${PORTSDIR}/graphics/gd"
diff --git a/www/mod_php5/Makefile b/www/mod_php5/Makefile
index 53f80b4d8301..db674f72bb83 100644
--- a/www/mod_php5/Makefile
+++ b/www/mod_php5/Makefile
@@ -82,12 +82,6 @@ CONFIGURE_ARGS= --prefix=${PREFIX} \
OPTIM= -DHARD_SERVER_LIMIT=512 \
-DDEFAULT_PATH=\\"${PREFIX}/bin:/bin:/usr/bin\\"
-.if defined(APACHE_PERF_TUNING) && ${APACHE_PERF_TUNING} == YES
-OPTIM+= -DBUFFERED_LOGS -DFD_SETSIZE=1024
-CFLAGS+= -O6 -funroll-loops -fstrength-reduce -fomit-frame-pointer \
- -fexpensive-optimizations -ffast-math
-.endif
-
CONFIGURE_ENV= OPTIM='${OPTIM}' LIBS='-L${PREFIX}/lib'
SCRIPTS_ENV= WRKDIRPREFIX="${WRKDIRPREFIX}" \
TOUCH="${TOUCH}" \
diff --git a/www/mod_php5/scripts/configure.php b/www/mod_php5/scripts/configure.php
index b639c1284e45..7cc83d96a4c8 100644
--- a/www/mod_php5/scripts/configure.php
+++ b/www/mod_php5/scripts/configure.php
@@ -53,7 +53,9 @@ exec > ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
while [ "$1" ]; do
case $1 in
\"tuning\")
- echo "APACHE_PERF_TUNING= YES"
+ echo "CFLAGS+= -O6 -funroll-loops -fstrength-reduce -fomit-frame-pointer -fexpensive-optimizations -ffast-math"
+ echo "OPTIM+= -DBUFFERED_LOGS -DFD_SETSIZE=1024"
+ echo "CONFIGURE_ENV+= OPTIM='\${OPTIM}'"
;;
\"GD\")
echo "LIB_DEPENDS+= gd.0:\${PORTSDIR}/graphics/gd"