aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2010-01-12 01:23:35 +0800
committerosa <osa@FreeBSD.org>2010-01-12 01:23:35 +0800
commit20dc8ddb655f3efa229698cb960f591e9efff76b (patch)
treebb8e8c6d17f613df9f7a703bc362b06f403a2330 /www
parent82ef80a590d3baf43d32124f06eca8b26c87e00e (diff)
downloadfreebsd-ports-gnome-20dc8ddb655f3efa229698cb960f591e9efff76b.tar.gz
freebsd-ports-gnome-20dc8ddb655f3efa229698cb960f591e9efff76b.tar.zst
freebsd-ports-gnome-20dc8ddb655f3efa229698cb960f591e9efff76b.zip
Update from 0.8.31 to 0.8.32.
<ChangeLog> *) Bugfix: UTF-8 encoding usage in the ngx_http_autoindex_module. Thanks to Maxim Dounin. *) Bugfix: regular expression named captures worked for two names only. Thanks to Maxim Dounin. *) Bugfix: now the "localhost" name is used in the "Host" request header line, if an unix domain socket is defined in the "auth_http" directive. Thanks to Maxim Dounin. *) Bugfix: nginx did nor support chunked transfer encoding for 201 responses. Thanks to Julian Reich. *) Bugfix: if the "expires modified" set date in the past, the a negative number was set in the "Cache-Control" response header line. Thanks to Alex Kapranoff. </ChangeLog>
Diffstat (limited to 'www')
-rw-r--r--www/nginx-devel/Makefile6
-rw-r--r--www/nginx-devel/distinfo6
-rw-r--r--www/nginx-devel/files/extra-patch-ngx_http_udplog_module.c23
3 files changed, 31 insertions, 4 deletions
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index 6c16a1390209..83fb61830e24 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= nginx
-PORTVERSION= 0.8.31
+PORTVERSION= 0.8.32
CATEGORIES= www
MASTER_SITES= http://sysoev.ru/nginx/
MASTER_SITES+= ${MASTER_SITE_LOCAL}
@@ -453,6 +453,10 @@ post-patch:
${PATCH} -p0 < \
${WRKDIR}/ngx_supervisord-${NGINX_SUPERVISORD_MODULE_VERSION}/patches/ngx_http_upstream_init_busy-0.8.17.patch )
.endif
+.if defined(WITH_UDPLOG_MODULE)
+ @${PATCH} ${PATCH_ARGS} < \
+ ${PATCHDIR}/extra-patch-ngx_http_udplog_module.c
+.endif
do-build:
@cd ${WRKSRC} && ${MAKE}
diff --git a/www/nginx-devel/distinfo b/www/nginx-devel/distinfo
index a2bb56151606..af7ddd04c9bd 100644
--- a/www/nginx-devel/distinfo
+++ b/www/nginx-devel/distinfo
@@ -1,6 +1,6 @@
-MD5 (nginx-0.8.31.tar.gz) = 0bb07c1efc4b972950d210f69081017d
-SHA256 (nginx-0.8.31.tar.gz) = a810044bd7768da89d794dea8d6fb8503c5c46b0cfc4221e5151e04c4b91904e
-SIZE (nginx-0.8.31.tar.gz) = 619261
+MD5 (nginx-0.8.32.tar.gz) = cb3e937e08ec134e2e826768a58790e1
+SHA256 (nginx-0.8.32.tar.gz) = 31f70b30ad0838615acb580eef40576f59d96ef72a1e276af2049f6ed4da189a
+SIZE (nginx-0.8.32.tar.gz) = 619865
MD5 (nginx-accesskey-2.0.3.tar.gz) = 9b5304346d5139b1841f5baa01ab0cbe
SHA256 (nginx-accesskey-2.0.3.tar.gz) = d9e94321e78a02de16c57f3e048fd31059fd8116ed03d6de7180f435c52502b1
SIZE (nginx-accesskey-2.0.3.tar.gz) = 2632
diff --git a/www/nginx-devel/files/extra-patch-ngx_http_udplog_module.c b/www/nginx-devel/files/extra-patch-ngx_http_udplog_module.c
new file mode 100644
index 000000000000..3a369c21a272
--- /dev/null
+++ b/www/nginx-devel/files/extra-patch-ngx_http_udplog_module.c
@@ -0,0 +1,23 @@
+--- ../nginx_udplog_module-1.0.0/ngx_http_udplog_module.c.orig 2010-01-11 19:16:46.000000000 +0300
++++ ../nginx_udplog_module-1.0.0/ngx_http_udplog_module.c 2010-01-11 19:20:17.000000000 +0300
+@@ -280,7 +280,7 @@
+ uc->sockaddr = endpoint->peer_addr.sockaddr;
+ uc->socklen = endpoint->peer_addr.socklen;
+ uc->server = endpoint->peer_addr.name;
+-#if defined nginx_version && nginx_version >= 7054
++#if defined nginx_version && ( nginx_version >= 7054 && nginx_version < 8032 )
+ uc->log = &cf->cycle->new_log;
+ #else
+ uc->log = cf->cycle->new_log;
+@@ -335,7 +335,11 @@
+ }
+
+ if ((size_t) n != (size_t) len) {
++#if defined nginx_version && nginx_version >= 8032
++ ngx_log_error(NGX_LOG_CRIT, &uc->log, 0, "send() incomplete");
++#else
+ ngx_log_error(NGX_LOG_CRIT, uc->log, 0, "send() incomplete");
++#endif
+ return NGX_ERROR;
+ }
+