aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2001-01-01 18:36:22 +0800
committerwill <will@FreeBSD.org>2001-01-01 18:36:22 +0800
commit21c4e05d7f79740a0426c17dd76624d0d4c74c3c (patch)
treed926a4b6674e2edb20c2f536be2a4875a7b190bf /www
parente663ab453111a740e83c3cafe8a6464ebc226e48 (diff)
downloadfreebsd-ports-gnome-21c4e05d7f79740a0426c17dd76624d0d4c74c3c.tar.gz
freebsd-ports-gnome-21c4e05d7f79740a0426c17dd76624d0d4c74c3c.tar.zst
freebsd-ports-gnome-21c4e05d7f79740a0426c17dd76624d0d4c74c3c.zip
Add p5-Apache-Language 0.14, a perl module that provides language-aware
object hashes.
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Apache-Language/Makefile22
-rw-r--r--www/p5-Apache-Language/distinfo1
-rw-r--r--www/p5-Apache-Language/pkg-comment1
-rw-r--r--www/p5-Apache-Language/pkg-descr6
-rw-r--r--www/p5-Apache-Language/pkg-plist14
6 files changed, 45 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index d9d7afb43a54..42d3960d0522 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -134,6 +134,7 @@
SUBDIR += p5-Apache-AuthCookie
SUBDIR += p5-Apache-DBI
SUBDIR += p5-Apache-Icon
+ SUBDIR += p5-Apache-Language
SUBDIR += p5-Apache-Peek
SUBDIR += p5-Apache-Radius
SUBDIR += p5-Apache-Session
diff --git a/www/p5-Apache-Language/Makefile b/www/p5-Apache-Language/Makefile
new file mode 100644
index 000000000000..8c828b438069
--- /dev/null
+++ b/www/p5-Apache-Language/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: Apache-Language
+# Date created: Mon Jan 1 05:22:52 2001
+# Whom: will
+#
+# $FreeBSD$
+#
+
+PORTNAME= Apache-Language
+PORTVERSION= 0.14
+CATEGORIES= www
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Apache
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_PERL5= yes
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/www/p5-Apache-Language/distinfo b/www/p5-Apache-Language/distinfo
new file mode 100644
index 000000000000..1951a756ca08
--- /dev/null
+++ b/www/p5-Apache-Language/distinfo
@@ -0,0 +1 @@
+MD5 (Apache-Language-0.14.tar.gz) = 7c71ad5ca1c7c7082b35b87b2b35bf61
diff --git a/www/p5-Apache-Language/pkg-comment b/www/p5-Apache-Language/pkg-comment
new file mode 100644
index 000000000000..8f229e809829
--- /dev/null
+++ b/www/p5-Apache-Language/pkg-comment
@@ -0,0 +1 @@
+A perl module that provides language-aware object hashes
diff --git a/www/p5-Apache-Language/pkg-descr b/www/p5-Apache-Language/pkg-descr
new file mode 100644
index 000000000000..749328f51f81
--- /dev/null
+++ b/www/p5-Apache-Language/pkg-descr
@@ -0,0 +1,6 @@
+Apache::Language objects act like language-aware hashes. They store key/language/values
+triplets. Using the Accept-Language: field sent by HTTP clients, they can pick the
+best fit language for that specific client. Apache::Language's usage is transparent
+and should prove to be quite convenient (and hopefully, efficient).
+
+--will
diff --git a/www/p5-Apache-Language/pkg-plist b/www/p5-Apache-Language/pkg-plist
new file mode 100644
index 000000000000..6808a9b63c50
--- /dev/null
+++ b/www/p5-Apache-Language/pkg-plist
@@ -0,0 +1,14 @@
+lib/perl5/%%PERL_VERSION%%/man/man3/Apache::Language.3
+lib/perl5/%%PERL_VERSION%%/man/man3/Apache::Language::Constants.3
+lib/perl5/%%PERL_VERSION%%/man/man3/Apache::Language::DBI.3
+lib/perl5/%%PERL_VERSION%%/man/man3/Apache::Language::PlainFile.3
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Apache/Language.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Apache/Language.pod
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Apache/Language/Constants.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Apache/Language/DBI.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Apache/Language/PlainFile.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/Language/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/Language/Language.bs
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/Language/Language.so
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/Language
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Apache/Language