aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorjadawin <jadawin@FreeBSD.org>2008-07-02 23:17:55 +0800
committerjadawin <jadawin@FreeBSD.org>2008-07-02 23:17:55 +0800
commit21d6b12a6f7dc56812076cff0b5ae7452cb5c3b8 (patch)
treef04487352cc71ce9141d36d796863f8a3f41fce1 /www
parentbea6f785414109784ef7466c6a7d2345a0d175d3 (diff)
downloadfreebsd-ports-gnome-21d6b12a6f7dc56812076cff0b5ae7452cb5c3b8.tar.gz
freebsd-ports-gnome-21d6b12a6f7dc56812076cff0b5ae7452cb5c3b8.tar.zst
freebsd-ports-gnome-21d6b12a6f7dc56812076cff0b5ae7452cb5c3b8.zip
This module allows Apache to authenticate a location against an
entry, or entries, in an LDAP database. WWW: http://www.muquit.com/muquit/software/mod_auth_ldap/mod_auth_ldap2.html PR: ports/124400 Submitted by: Gerrit Beine <gerrit.beine at gmx.de>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/mod_auth_ldap/Makefile34
-rw-r--r--www/mod_auth_ldap/distinfo3
-rw-r--r--www/mod_auth_ldap/pkg-descr4
4 files changed, 42 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 459a187de705..ff82752c347d 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -365,6 +365,7 @@
SUBDIR += mod_auth_imap
SUBDIR += mod_auth_imap2
SUBDIR += mod_auth_kerb
+ SUBDIR += mod_auth_ldap
SUBDIR += mod_auth_mysql
SUBDIR += mod_auth_mysql2
SUBDIR += mod_auth_mysql41_ap2
diff --git a/www/mod_auth_ldap/Makefile b/www/mod_auth_ldap/Makefile
new file mode 100644
index 000000000000..15576748e8fe
--- /dev/null
+++ b/www/mod_auth_ldap/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: mod_auth_ldap
+# Date created: 07 June 2008
+# Whom: Gerrit Beine <gerrit.beine@gmx.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_auth_ldap
+PORTVERSION= 2.12
+CATEGORIES= www
+MASTER_SITES= http://www.muquit.com/muquit/software/mod_auth_ldap/
+DISTNAME= modauthldap_apache2
+
+MAINTAINER= gerrit.beine@gmx.de
+COMMENT= Apache module to authenticate against an LDAP directory
+
+USE_OPENLDAP= yes
+USE_APACHE= 2.0+
+AP_FAST_BUILD= yes
+AP_GENPLIST= yes
+SHORTMODNAME= auth_ldap
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-ldap-dir=${LOCALBASE} --with-ssl=no
+MAKE_ARGS+= APXS=${APXS}
+
+PORTDOCS= README mod_auth_ldap_apache2.html ssl_tls.html
+
+.if !defined(NOPORTDOCS)
+post-install:
+ @${MKDIR} ${DOCSDIR}
+ @cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/mod_auth_ldap/distinfo b/www/mod_auth_ldap/distinfo
new file mode 100644
index 000000000000..a62cafa2e566
--- /dev/null
+++ b/www/mod_auth_ldap/distinfo
@@ -0,0 +1,3 @@
+MD5 (modauthldap_apache2.tar.gz) = 2666189a1ec9bef4ae264870b22f8714
+SHA256 (modauthldap_apache2.tar.gz) = 752041bbeac760ba38aa44083cf876882adb0e67f1903b03d9620b3aee154eef
+SIZE (modauthldap_apache2.tar.gz) = 155812
diff --git a/www/mod_auth_ldap/pkg-descr b/www/mod_auth_ldap/pkg-descr
new file mode 100644
index 000000000000..2eaa67bd3afb
--- /dev/null
+++ b/www/mod_auth_ldap/pkg-descr
@@ -0,0 +1,4 @@
+This module allows Apache to authenticate a location against an
+entry, or entries, in an LDAP database.
+
+WWW: http://www.muquit.com/muquit/software/mod_auth_ldap/mod_auth_ldap2.html