aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorfeld <feld@FreeBSD.org>2017-08-03 08:58:59 +0800
committerfeld <feld@FreeBSD.org>2017-08-03 08:58:59 +0800
commit21eb1d031356e46c6f8c4379774bbabc9ed42113 (patch)
tree2226746587c2f5fed767b26f101dd329630291f7 /www
parent6c665b1e8bd6453150e9da18d1f5e7541b2ecb0d (diff)
downloadfreebsd-ports-gnome-21eb1d031356e46c6f8c4379774bbabc9ed42113.tar.gz
freebsd-ports-gnome-21eb1d031356e46c6f8c4379774bbabc9ed42113.tar.zst
freebsd-ports-gnome-21eb1d031356e46c6f8c4379774bbabc9ed42113.zip
www/py-django: Add missing runtime dependency
pytz is now a required dependency for Django 1.11 and is strongly recommended in older releases. Django 1.11: https://github.com/django/django/commit/414ad25b090a63eaaf297b1164c8f7d814a710a2 Older releases: docs/topics/i18n/timezones.txt "3. Should I install pytz? Yes. Django has a policy of not requiring external dependencies, and for this reason pytz_ is optional. However, it's much safer to install it." Reviewed by: lwhsu MFH: 2017Q3 Differential Revision: https://reviews.freebsd.org/D11835
Diffstat (limited to 'www')
-rw-r--r--www/py-django110/Makefile4
-rw-r--r--www/py-django111/Makefile3
-rw-r--r--www/py-django18/Makefile4
-rw-r--r--www/py-django19/Makefile4
4 files changed, 12 insertions, 3 deletions
diff --git a/www/py-django110/Makefile b/www/py-django110/Makefile
index 15566a8f2f11..7c38ce49d41d 100644
--- a/www/py-django110/Makefile
+++ b/www/py-django110/Makefile
@@ -3,7 +3,7 @@
PORTNAME= django
PORTVERSION= 1.10.7
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www python
MASTER_SITES= CHEESESHOP \
https://www.djangoproject.com/m/releases/${PORTVERSION}/
@@ -18,6 +18,8 @@ COMMENT= High-level Python Web Framework
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytz>0:devel/py-pytz
+
NO_ARCH= yes
USES= cpe python shebangfix
USE_PYTHON= autoplist distutils
diff --git a/www/py-django111/Makefile b/www/py-django111/Makefile
index d8f0355e36e0..c96c58d9aea5 100644
--- a/www/py-django111/Makefile
+++ b/www/py-django111/Makefile
@@ -3,6 +3,7 @@
PORTNAME= django
PORTVERSION= 1.11.4
+PORTREVISION= 1
CATEGORIES= www python
MASTER_SITES= CHEESESHOP \
https://www.djangoproject.com/m/releases/${PORTVERSION}/
@@ -17,6 +18,8 @@ COMMENT= High-level Python Web Framework
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytz>0:devel/py-pytz
+
NO_ARCH= yes
USES= cpe python shebangfix
USE_PYTHON= autoplist distutils
diff --git a/www/py-django18/Makefile b/www/py-django18/Makefile
index 213581b26141..d47d58d894c3 100644
--- a/www/py-django18/Makefile
+++ b/www/py-django18/Makefile
@@ -3,7 +3,7 @@
PORTNAME= django
PORTVERSION= 1.8.18
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www python
MASTER_SITES= CHEESESHOP \
https://www.djangoproject.com/m/releases/${PORTVERSION:R}/
@@ -18,6 +18,8 @@ COMMENT= High-level Python Web Framework (1.8.x LTS)
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytz>0:devel/py-pytz
+
NO_ARCH= yes
USES= cpe python shebangfix
USE_PYTHON= autoplist distutils
diff --git a/www/py-django19/Makefile b/www/py-django19/Makefile
index f9a694f39400..a33d803b4708 100644
--- a/www/py-django19/Makefile
+++ b/www/py-django19/Makefile
@@ -3,7 +3,7 @@
PORTNAME= django
PORTVERSION= 1.9.13
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www python
MASTER_SITES= CHEESESHOP \
https://www.djangoproject.com/m/releases/${PORTVERSION:R}/
@@ -18,6 +18,8 @@ COMMENT= High-level Python Web Framework
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytz>0:devel/py-pytz
+
DEPRECATED= Unsupported upstream
EXPIRATION_DATE=2017-09-01