aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2015-04-29 08:46:11 +0800
committerosa <osa@FreeBSD.org>2015-04-29 08:46:11 +0800
commit28f714a48c99af09675bddb941990813ee007f64 (patch)
tree5d6f04c1778b32a201ea418caab28eea30fd3471 /www
parentf9b1d3d39b3484f732283208b46db9156bdd3bff (diff)
downloadfreebsd-ports-gnome-28f714a48c99af09675bddb941990813ee007f64.tar.gz
freebsd-ports-gnome-28f714a48c99af09675bddb941990813ee007f64.tar.zst
freebsd-ports-gnome-28f714a48c99af09675bddb941990813ee007f64.zip
Enable check for passenger third-party module compiled in nginx.
Diffstat (limited to 'www')
-rw-r--r--www/rubygem-passenger/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/www/rubygem-passenger/Makefile b/www/rubygem-passenger/Makefile
index 3381ffa896af..5b26fcbb7782 100644
--- a/www/rubygem-passenger/Makefile
+++ b/www/rubygem-passenger/Makefile
@@ -36,11 +36,18 @@ USE_APACHE= 22+
.if ${PORT_OPTIONS:MNGINX}
NGINXVERSION!= ${PKG_INFO} -qO www/nginx-devel 2>/dev/null; ${ECHO_CMD}
+NGXPASSENGER!= nginx -V 2>&1 | sed 's/.*passenger-\(.*\)\/ext.*/\1/g' | tail -1
.if empty(NGINXVERSION)
BUILD_DEPENDS+= nginx:${PORTSDIR}/www/nginx
.else
BUILD_DEPENDS+= nginx:${PORTSDIR}/www/nginx-devel
.endif
+.if empty(NGXPASSENGER)
+IGNORE= rebuild nginx with latest passenger module
+.endif
+.if (${NGXPASSENGER} != ${PORTVERSION})
+IGNORE= rebuild nginx with third-party ${PORTVERSION} module, current verion is ${NGXPASSENGER}
+.endif
.endif
LIB_DEPENDS+= libeio.so:${PORTSDIR}/devel/libeio \