aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorrene <rene@FreeBSD.org>2012-12-24 18:50:25 +0800
committerrene <rene@FreeBSD.org>2012-12-24 18:50:25 +0800
commit305c35af1ea627a4b5feacb6350530b5fed8746a (patch)
tree6804ea40d5f116bed7de248331e83c6dc3eb1309 /www
parent853aa51fd5ee191c96f229954156ed517a44045a (diff)
downloadfreebsd-ports-gnome-305c35af1ea627a4b5feacb6350530b5fed8746a.tar.gz
freebsd-ports-gnome-305c35af1ea627a4b5feacb6350530b5fed8746a.tar.zst
freebsd-ports-gnome-305c35af1ea627a4b5feacb6350530b5fed8746a.zip
Sanitize printing of optionally non-installed files.
Inspired by: crees
Diffstat (limited to 'www')
-rw-r--r--www/py-ws4py/Makefile32
-rw-r--r--www/py-ws4py/files/pkg-message.in5
2 files changed, 13 insertions, 24 deletions
diff --git a/www/py-ws4py/Makefile b/www/py-ws4py/Makefile
index 9a2bb33704c1..c71de3727a62 100644
--- a/www/py-ws4py/Makefile
+++ b/www/py-ws4py/Makefile
@@ -13,8 +13,6 @@ COMMENT= WebSocket package for Python
LICENSE= BSD
-SUB_FILES= pkg-message
-
USE_PYTHON= yes
USE_PYDISTUTILS= easy_install
@@ -33,30 +31,14 @@ TORNADO_FILES= ws4py/client/tornadoclient.py
.if ${PORT_OPTIONS:MCHERRYPY}
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}cherrypy>=3.2.2:${PORTSDIR}/www/py-cherrypy
-SUB_LIST+= MSG_NO_CHERRYPY=
-.else
-SUB_LIST+= MSG_NO_CHERRYPY="${CHERRYPY_FILES}"
.endif
.if ${PORT_OPTIONS:MGEVENT}
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}gevent>=0.13.6:${PORTSDIR}/devel/py-gevent
-SUB_LIST+= MSG_NO_GEVENT=
-.else
-SUB_LIST+= MSG_NO_GEVENT="${GEVENT_FILES}"
.endif
.if ${PORT_OPTIONS:MTORNADO}
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}tornado>=2.0:${PORTSDIR}/www/py-tornado
-SUB_LIST+= MSG_NO_TORNADO=
-.else
-SUB_LIST+= MSG_NO_TORNADO="${TORNADO_FILES}"
-.endif
-
-.if ! ${PORT_OPTIONS:MCHERRYPY} || ! ${PORT_OPTIONS:MGEVENT} || \
- ! ${PORT_OPTIONS:MTORNADO}
-SUB_LIST+= NOTE="Note that the following files are omitted from the package:"
-.else
-SUB_LIST+= NOTE=
.endif
# Do not install files which will not work
@@ -78,6 +60,18 @@ post-patch:
.endif
post-install:
- @${CAT} ${PKGMESSAGE}
+.if ! ${PORT_OPTIONS:MCHERRYPY} || ! ${PORT_OPTIONS:MGEVENT} || ! ${PORT_OPTIONS:MTORNADO}
+ @${ECHO_MSG}
+ @${ECHO_MSG} "Note that the following files are not installed:"
+.endif
+.if ! ${PORT_OPTIONS:MCHERRYPY}
+ @${ECHO_MSG} ${CHERRYPY_FILES}
+.endif
+.if ! ${PORT_OPTIONS:MGEVENT}
+ @${ECHO_MSG} ${GEVENT_FILES}
+.endif
+.if ! ${PORT_OPTIONS:MTORNADO}
+ @${ECHO_MSG} ${TORNADO_FILES}
+.endif
.include <bsd.port.mk>
diff --git a/www/py-ws4py/files/pkg-message.in b/www/py-ws4py/files/pkg-message.in
deleted file mode 100644
index 3751f6dd264a..000000000000
--- a/www/py-ws4py/files/pkg-message.in
+++ /dev/null
@@ -1,5 +0,0 @@
-%%NOTE%%
-
-%%MSG_NO_CHERRYPY%%
-%%MSG_NO_GEVENT%%
-%%MSG_NO_TORNADO%%