aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorfeld <feld@FreeBSD.org>2016-05-16 10:01:28 +0800
committerfeld <feld@FreeBSD.org>2016-05-16 10:01:28 +0800
commit335e502b2156eb04cee0664c21e6753db3498c3d (patch)
tree199497411dee35cd782de448e685f7f767496818 /www
parent9f0cb8233fc9e376595f40479e5c0b61843bc9e5 (diff)
downloadfreebsd-ports-gnome-335e502b2156eb04cee0664c21e6753db3498c3d.tar.gz
freebsd-ports-gnome-335e502b2156eb04cee0664c21e6753db3498c3d.tar.zst
freebsd-ports-gnome-335e502b2156eb04cee0664c21e6753db3498c3d.zip
Small add-on for the python requests http library. Makes use of python
3.2's concurrent.futures or the backport for prior versions of python. WWW: https://github.com/ross/requests-futures
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/py-requests-futures/Makefile28
-rw-r--r--www/py-requests-futures/distinfo2
-rw-r--r--www/py-requests-futures/pkg-descr4
4 files changed, 35 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index f2999ea9958f..a5c3f237f4fc 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1758,6 +1758,7 @@
SUBDIR += py-recaptcha
SUBDIR += py-requestbuilder
SUBDIR += py-requests
+ SUBDIR += py-requests-futures
SUBDIR += py-requests-oauth-hook
SUBDIR += py-requests-oauthlib
SUBDIR += py-requests-toolbelt
diff --git a/www/py-requests-futures/Makefile b/www/py-requests-futures/Makefile
new file mode 100644
index 000000000000..0a510e57f48c
--- /dev/null
+++ b/www/py-requests-futures/Makefile
@@ -0,0 +1,28 @@
+# Created by: Mark Felder <feld@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= requests-futures
+PORTVERSION= 0.9.7
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= feld@FreeBSD.org
+COMMENT= HTTP library written in Python for human beings
+
+LICENSE= APACHE20
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>0:www/py-requests
+
+NO_ARCH= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_VER} == "2.7"
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}futures>0:devel/py-futures
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/py-requests-futures/distinfo b/www/py-requests-futures/distinfo
new file mode 100644
index 000000000000..c2c0f73af7fc
--- /dev/null
+++ b/www/py-requests-futures/distinfo
@@ -0,0 +1,2 @@
+SHA256 (requests-futures-0.9.7.tar.gz) = a9ca2c3480b6fac29ec5de59c146742e2ab2b60f8c68581766094edb52ea7bad
+SIZE (requests-futures-0.9.7.tar.gz) = 5571
diff --git a/www/py-requests-futures/pkg-descr b/www/py-requests-futures/pkg-descr
new file mode 100644
index 000000000000..f607cb5ac8ba
--- /dev/null
+++ b/www/py-requests-futures/pkg-descr
@@ -0,0 +1,4 @@
+Small add-on for the python requests http library. Makes use of python
+3.2's concurrent.futures or the backport for prior versions of python.
+
+WWW: https://github.com/ross/requests-futures