aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-07-19 19:04:13 +0800
committermat <mat@FreeBSD.org>2016-07-19 19:04:13 +0800
commit363acdd313a37f491e4b2d6b9a807df489cfc5d9 (patch)
treebe6eebf3e77ddf9fcf383081091d8b8b336dd71c /www
parent64a47229a8791073130cac02039b944cc8102750 (diff)
downloadfreebsd-ports-gnome-363acdd313a37f491e4b2d6b9a807df489cfc5d9.tar.gz
freebsd-ports-gnome-363acdd313a37f491e4b2d6b9a807df489cfc5d9.tar.zst
freebsd-ports-gnome-363acdd313a37f491e4b2d6b9a807df489cfc5d9.zip
When there is a do-install target, do not use a post-install target, do
everything at once. Sometime, rename post-install into a options helper target. I did not fix ports that were such a mess that I could not figure out what they really wanted to do. I also did not change ports that had some version of an auto-plist code in post-install, for the same reason. With hat: portmgr Sponsored by: Absolight
Diffstat (limited to 'www')
-rw-r--r--www/apache-forrest/Makefile6
-rw-r--r--www/bins/Makefile1
-rw-r--r--www/cplanet/Makefile2
-rw-r--r--www/css-mode.el/Makefile2
-rw-r--r--www/edbrowse/Makefile2
-rw-r--r--www/flood/Makefile1
-rw-r--r--www/gitlab/Makefile1
-rw-r--r--www/google-appengine/Makefile1
-rw-r--r--www/jdresolve/Makefile2
-rw-r--r--www/jetty9/Makefile1
-rw-r--r--www/jmeter/Makefile7
-rw-r--r--www/mhonarc/Makefile1
-rw-r--r--www/monast/Makefile1
-rw-r--r--www/nanoblogger-extra/Makefile6
-rw-r--r--www/nanoblogger/Makefile2
-rw-r--r--www/nextcloud/Makefile2
-rw-r--r--www/owncloud/Makefile2
-rw-r--r--www/redmine/Makefile4
-rw-r--r--www/sahi/Makefile1
-rw-r--r--www/serf/Makefile2
-rw-r--r--www/shellinabox/Makefile2
-rw-r--r--www/tclwebtest/Makefile2
-rw-r--r--www/thundercache/Makefile1
-rw-r--r--www/tt-rss/Makefile1
-rw-r--r--www/uchiwa/Makefile1
-rw-r--r--www/web2ldap/Makefile2
-rw-r--r--www/webalizer/Makefile2
-rw-r--r--www/webinject/Makefile6
28 files changed, 19 insertions, 45 deletions
diff --git a/www/apache-forrest/Makefile b/www/apache-forrest/Makefile
index 06c1c2042acb..6859df346e0b 100644
--- a/www/apache-forrest/Makefile
+++ b/www/apache-forrest/Makefile
@@ -48,11 +48,7 @@ do-install:
@${INSTALL_SCRIPT} ${WRKSRC}/bin/forrest ${STAGEDIR}${DATADIR}/bin/forrest
@${INSTALL_SCRIPT} ${WRKSRC}/tools/ant/bin/ant ${STAGEDIR}${DATADIR}/tools/ant/bin/ant
@${LN} -sf ../${DATADIR_REL}/bin/forrest ${STAGEDIR}${PREFIX}/bin/forrest
-
-post-install:
@cd ${STAGEDIR}${PLUGINSDIR}; \
- ${SETENV} FORREST_HOME=${STAGEDIR}${DATADIR} ${ANT} ${ANT_TARGET}; \
- ${SED} -e "/%%DATADIR%%/s//${DATADIR:S/\//\\\//g}/g" \
- -e "/%%PORTVERSION%%/s//${PORTVERSION}/g" ${PKGMESSAGE};
+ ${SETENV} FORREST_HOME=${STAGEDIR}${DATADIR} ${ANT} ${ANT_TARGET}
.include <bsd.port.mk>
diff --git a/www/bins/Makefile b/www/bins/Makefile
index 548df991a0fb..365de223fc30 100644
--- a/www/bins/Makefile
+++ b/www/bins/Makefile
@@ -53,7 +53,6 @@ post-patch::
do-install:
@${SETENV} LOCALE=${PREFIX}/share/locale DESTDIR=${STAGEDIR} PREFIX=${PREFIX} RC=${PREFIX}/share/bins ${WRKSRC}/install.sh
-post-install:
.for file in ${BINS_SCRIPTS}
${INSTALL_SCRIPT} ${WRKSRC}/${file} ${STAGEDIR}${PREFIX}/bin
.endfor
diff --git a/www/cplanet/Makefile b/www/cplanet/Makefile
index 1e48d853dacd..a9c164b6c538 100644
--- a/www/cplanet/Makefile
+++ b/www/cplanet/Makefile
@@ -21,7 +21,7 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}/${MANPREFIX}/man/man1
-post-install:
+post-install-EXAMPLES-on:
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/samples/cplanet-atom.cs \
${WRKSRC}/samples/cplanet-opml.cs \
diff --git a/www/css-mode.el/Makefile b/www/css-mode.el/Makefile
index 97336c3bf3dd..89c529f2001a 100644
--- a/www/css-mode.el/Makefile
+++ b/www/css-mode.el/Makefile
@@ -37,7 +37,7 @@ do-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/${XELISP_SUBDIR}
${INSTALL_DATA} ${_DISTDIR}/${DISTNAME} ${STAGEDIR}${PREFIX}/${XELISP_SUBDIR}
-post-install:
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${_DISTDIR}/doco.html ${STAGEDIR}${DOCSDIR}/css-mode-doc.html
diff --git a/www/edbrowse/Makefile b/www/edbrowse/Makefile
index 38c2b405ba7e..a904581c8290 100644
--- a/www/edbrowse/Makefile
+++ b/www/edbrowse/Makefile
@@ -30,7 +30,7 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/edbrowse ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKBASE}/doc/man-edbrowse-debian.1 ${STAGEDIR}${MAN1PREFIX}/man/man1/edbrowse.1
-post-install:
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_MAN} ${WRKBASE}/CHANGES ${STAGEDIR}${DOCSDIR}
${INSTALL_MAN} ${WRKBASE}/COPYING ${STAGEDIR}${DOCSDIR}
diff --git a/www/flood/Makefile b/www/flood/Makefile
index 3bf9ab90cd17..380cfece95f8 100644
--- a/www/flood/Makefile
+++ b/www/flood/Makefile
@@ -30,7 +30,6 @@ OPTIONS_DEFINE= DOCS
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/flood ${STAGEDIR}${PREFIX}/bin/flood
-post-install:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
.for f in ${EX_SCRIPTS}
@${INSTALL_SCRIPT} ${WRKSRC}/examples/$f ${STAGEDIR}${EXAMPLESDIR}
diff --git a/www/gitlab/Makefile b/www/gitlab/Makefile
index 540d0262a42d..6f0806951dcd 100644
--- a/www/gitlab/Makefile
+++ b/www/gitlab/Makefile
@@ -176,7 +176,6 @@ do-install:
${MV} ${WRKSRC}/config/initializers/rack_attack.rb.example ${WRKSRC}/config/initializers/rack_attack.rb.sample
${CP} ${WRKSRC}/config/database.yml.postgresql ${WRKSRC}/config/database.yml.sample
-post-install:
${MKDIR} ${STAGEDIR}/home/git/repositories
${MKDIR} ${STAGEDIR}${PREFIX}/www/${PORTNAME}/public/assets
${MKDIR} ${STAGEDIR}${PREFIX}/www/${PORTNAME}/tmp/cache
diff --git a/www/google-appengine/Makefile b/www/google-appengine/Makefile
index 29ef37f76190..c3996cdcbe6f 100644
--- a/www/google-appengine/Makefile
+++ b/www/google-appengine/Makefile
@@ -63,7 +63,6 @@ do-install:
done)
${INSTALL_DATA} ${WRKSRC}/VERSION ${STAGEDIR}${DATADIR}
-post-install:
(cd ${STAGEDIR}${DATADIR} && \
${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py -d ${DATADIR} -f ${GAEDATADIR:Nphp} -q)
diff --git a/www/jdresolve/Makefile b/www/jdresolve/Makefile
index 9b861d701c7e..7c52bd94a9f2 100644
--- a/www/jdresolve/Makefile
+++ b/www/jdresolve/Makefile
@@ -29,7 +29,7 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/${file}.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
.endfor
-post-install:
+post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${PREFIX}/share/doc/jdresolve
.for i in ${DOC1}
${INSTALL_DATA} ${WRKSRC}/${i} ${STAGEDIR}${PREFIX}/share/doc/jdresolve
diff --git a/www/jetty9/Makefile b/www/jetty9/Makefile
index 0d0ba31e45f3..389651067fa0 100644
--- a/www/jetty9/Makefile
+++ b/www/jetty9/Makefile
@@ -64,7 +64,6 @@ do-install:
${MKDIR} ${STAGEDIR}${WWWDIR}/demo-base/logs
${INSTALL_SCRIPT} ${STAGEDIR}${PREFIX}/${PORTNAME}/bin/${PORTNAME}.sh ${STAGEDIR}${PREFIX}/sbin
-post-install:
${MKDIR} ${STAGEDIR}${ETCDIR}
${INSTALL_DATA} ${WRKDIR}/${PORTNAME}.sample ${STAGEDIR}${ETCDIR}/
diff --git a/www/jmeter/Makefile b/www/jmeter/Makefile
index 45554cf1dfb7..6349f88f3703 100644
--- a/www/jmeter/Makefile
+++ b/www/jmeter/Makefile
@@ -66,6 +66,9 @@ do-configure:
.endfor
${PRINTF} '\n' >> ${WRKSRC}/bin/system.properties
+# For some reason, it is not enough for these three to simply be listed in
+# jmeter.properties file. JMeter refuses to start, unless they are found in lib/
+BOOTSTRAP_JARS= avalon-framework xstream commons-io
do-install:
cd ${WRKSRC} \
&& ${FIND} ${DATAFILES} -type d -exec ${MKDIR} ${STAGEDIR}/${DATADIR}/{} \;
@@ -77,10 +80,6 @@ do-install:
&& ${FIND} ${PORTDOCS} -type f -exec ${INSTALL_DATA} {} ${STAGEDIR}${DOCSDIR}/{} \;
${INSTALL_SCRIPT} ${WRKDIR}/jmeter.sh ${STAGEDIR}${PREFIX}/bin/jmeter
-# For some reason, it is not enough for these three to simply be listed in
-# jmeter.properties file. JMeter refuses to start, unless they are found in lib/
-BOOTSTRAP_JARS= avalon-framework xstream commons-io
-post-install:
@${LN} -s ${BOOTSTRAP_JARS:C|.*|${JAVAJARDIR}/&.jar|} ${STAGEDIR}${DATADIR}/lib/
.include <bsd.port.post.mk>
diff --git a/www/mhonarc/Makefile b/www/mhonarc/Makefile
index a36d7ddf291b..bc57ef95bfbc 100644
--- a/www/mhonarc/Makefile
+++ b/www/mhonarc/Makefile
@@ -36,7 +36,6 @@ INSTALL_ARGS+= -nodoc
do-install:
cd ${WRKSRC} && ${PERL5} install.me ${INSTALL_ARGS}
-post-install:
.for file in mha-dbedit mha-dbrecover mha-decode mhonarc
${REINPLACE_CMD} -E -e 's,${STAGEDIR},,g' ${STAGEDIR}/${PREFIX}/bin/${file}
${RM} ${STAGEDIR}/${PREFIX}/bin/${file}.bak
diff --git a/www/monast/Makefile b/www/monast/Makefile
index 58bd1a105b30..c73364c8e5c1 100644
--- a/www/monast/Makefile
+++ b/www/monast/Makefile
@@ -34,7 +34,6 @@ do-install:
.endfor
(cd ${WRKSRC}/lib/ && ${COPYTREE_SHARE} \* ${STAGEDIR}${WWWDIR}/lib)
-post-install:
${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py -d ${PYTHONPREFIX_SITELIBDIR} -f ${STAGEDIR}${PREFIX}/monast
${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py -d ${PYTHONPREFIX_SITELIBDIR} -f ${STAGEDIR}${PREFIX}/monast
diff --git a/www/nanoblogger-extra/Makefile b/www/nanoblogger-extra/Makefile
index eb42d47256a9..f3cae13dcc50 100644
--- a/www/nanoblogger-extra/Makefile
+++ b/www/nanoblogger-extra/Makefile
@@ -3,6 +3,7 @@
PORTNAME= nanoblogger-extra
PORTVERSION= 3.4.2
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://nanoblogger.sourceforge.net/downloads/
@@ -18,7 +19,7 @@ DATADIR= ${PREFIX}/share/nanoblogger
NO_BUILD= yes
-OPTIONS_DEFINE= DOCS
+OPTIONS_DEFINE= DOCS EXAMPLES
do-install:
.for data in default lang plugins
@@ -26,7 +27,7 @@ do-install:
${COPYTREE_SHARE} \* ${STAGEDIR}${DATADIR}/${data} "! -empty" )
.endfor
-post-install:
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for doc in COPYING ChangeLog README
@${INSTALL_DATA} ${WRKSRC}/${doc} ${STAGEDIR}${DOCSDIR}
@@ -34,6 +35,7 @@ post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}/html
@${INSTALL_DATA} ${WRKSRC}/docs/*.html ${STAGEDIR}${DOCSDIR}/html
+post-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
@${INSTALL_DATA} ${WRKSRC}/docs/examples/nanoblogger.bash_completion ${STAGEDIR}${EXAMPLESDIR}
diff --git a/www/nanoblogger/Makefile b/www/nanoblogger/Makefile
index 16e1a60a4931..63f6bec59e04 100644
--- a/www/nanoblogger/Makefile
+++ b/www/nanoblogger/Makefile
@@ -39,7 +39,7 @@ do-install:
.endfor
@${CP} ${WRKSRC}/welcome-to-nb.txt ${STAGEDIR}${DATADIR}
-post-install:
+post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
.for doc in COPYING ChangeLog README TODO copyright
@${INSTALL_DATA} ${WRKSRC}/${doc} ${STAGEDIR}${DOCSDIR}
diff --git a/www/nextcloud/Makefile b/www/nextcloud/Makefile
index ebe87352ca59..e437cc769c8e 100644
--- a/www/nextcloud/Makefile
+++ b/www/nextcloud/Makefile
@@ -55,8 +55,6 @@ WITH_OPENSSL_PORT= yes
do-install:
@${MKDIR} -m 0755 ${STAGEDIR}${WWWDIR}
@cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR}
-
-post-install:
@${MKDIR} ${STAGEDIR}${WWWDIR}/data
.include <bsd.port.mk>
diff --git a/www/owncloud/Makefile b/www/owncloud/Makefile
index aa58160a8831..091ea94fa2bc 100644
--- a/www/owncloud/Makefile
+++ b/www/owncloud/Makefile
@@ -56,8 +56,6 @@ WITH_OPENSSL_PORT= yes
do-install:
@${MKDIR} -m 0755 ${STAGEDIR}${WWWDIR}
@cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR}
-
-post-install:
@${MKDIR} ${STAGEDIR}${WWWDIR}/data
.include <bsd.port.mk>
diff --git a/www/redmine/Makefile b/www/redmine/Makefile
index 181e9f0e0c35..1ab454b0d79c 100644
--- a/www/redmine/Makefile
+++ b/www/redmine/Makefile
@@ -80,6 +80,7 @@ do-install:
${MKDIR} ${STAGEDIR}${WWWDIR}/tmp/pids
${MKDIR} ${STAGEDIR}${WWWDIR}/bundler.d
cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR}
+ ${TOUCH} ${STAGEDIR}${WWWDIR}/Gemfile.lock
do-install-MYSQL-on:
${CP} ${FILESDIR}/mysql.rb ${STAGEDIR}${WWWDIR}/bundler.d
@@ -102,7 +103,4 @@ do-install-RMAGIC-on:
do-install-THIN-on:
${CP} ${FILESDIR}/thin.rb ${STAGEDIR}${WWWDIR}/bundler.d
-post-install:
- ${TOUCH} ${STAGEDIR}${WWWDIR}/Gemfile.lock
-
.include <bsd.port.mk>
diff --git a/www/sahi/Makefile b/www/sahi/Makefile
index 7d45117fd870..d478f6236b4e 100644
--- a/www/sahi/Makefile
+++ b/www/sahi/Makefile
@@ -69,7 +69,6 @@ do-install:
@${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}.sh ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
@cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}
-post-install:
@${CP} ${STAGEDIR}${DATADIR}/config/browser_types/linux.xml ${STAGEDIR}${DATADIR}/userdata/config/browser_types.xml
.for d in bin userdata/bin
@${CHMOD} ${BINMODE} ${STAGEDIR}${DATADIR}/${d}/*
diff --git a/www/serf/Makefile b/www/serf/Makefile
index cdada4419e56..398d3c866cbe 100644
--- a/www/serf/Makefile
+++ b/www/serf/Makefile
@@ -58,7 +58,7 @@ post-patch:
-e '/^Libs.private/s|$$| -L${OPENSSLLIB} -lssl -lcrypto|' \
${WRKSRC}/build/serf.pc.in
-post-install:
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/design-guide.txt ${STAGEDIR}${DOCSDIR}
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libserf-1.so
diff --git a/www/shellinabox/Makefile b/www/shellinabox/Makefile
index 14e861d8b30d..cb7a82377b8d 100644
--- a/www/shellinabox/Makefile
+++ b/www/shellinabox/Makefile
@@ -45,8 +45,6 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/shellinaboxd ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/shellinaboxd.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
-
-post-install:
@${MKDIR} ${STAGEDIR}${ETCDIR}
.include <bsd.port.mk>
diff --git a/www/tclwebtest/Makefile b/www/tclwebtest/Makefile
index 57fbb79f38ae..7694605f36dc 100644
--- a/www/tclwebtest/Makefile
+++ b/www/tclwebtest/Makefile
@@ -35,7 +35,7 @@ do-install:
${CP} -R ${WRKSRC}/openacs4tests ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_SCRIPT} ${WRKSRC}/tclwebtest ${STAGEDIR}${PREFIX}/bin/tclwebtest
-post-install:
+post-install-DOCS-on:
@${ECHO} "Installing docs"
@${MKDIR} ${STAGEDIR}${DOCSDIR}/doc
${TAR} -C ${WRKSRC} -c -f - ChangeLog README TODO index.html generate_docs.test | ${TAR} -C ${STAGEDIR}${DOCSDIR} -x -f -
diff --git a/www/thundercache/Makefile b/www/thundercache/Makefile
index d946319d6c02..b400cc19ca9d 100644
--- a/www/thundercache/Makefile
+++ b/www/thundercache/Makefile
@@ -93,7 +93,6 @@ do-install:
@${INSTALL_SCRIPT} ${WRKDIR}/log.sh ${STAGEDIR}${PREFIX}/thunder/sbin/
@${MKDIR} -m 755 ${STAGEDIR}/var/run/thunder
-post-install:
@(${CHMOD} +x ${WRKDIR}/test-deps.sh ; \
if ! ${WRKDIR}/test-deps.sh > /dev/null 2>&1 ; then \
${ECHO_MSG} "**** FATAL **** " ; \
diff --git a/www/tt-rss/Makefile b/www/tt-rss/Makefile
index f8681922b02a..4961d22297d7 100644
--- a/www/tt-rss/Makefile
+++ b/www/tt-rss/Makefile
@@ -88,7 +88,6 @@ do-install:
${TOUCH} ${STAGEDIR}${WWWDIR}/icons/.empty
${INSTALL_DATA} ${WRKDIR}/httpd-tt-rss.conf ${STAGEDIR}${DATADIR}
-post-install:
${MV} ${STAGEDIR}${WWWDIR}/config.php-dist ${STAGEDIR}${WWWDIR}/config.php.sample
.include <bsd.port.mk>
diff --git a/www/uchiwa/Makefile b/www/uchiwa/Makefile
index 0c7f8352209f..1acac669ac76 100644
--- a/www/uchiwa/Makefile
+++ b/www/uchiwa/Makefile
@@ -97,7 +97,6 @@ do-install:
${STAGEDIR}${UCHIWA_SHAREDIR} \
${STAGEDIR}${UCHIWA_RCDIR}
-post-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/uchiwa ${STAGEDIR}${PREFIX}/bin/uchiwa
${INSTALL_DATA} ${WRKSRC}/src/github.com/${GH_ACCOUNT}/${PORTNAME}/config.json.example ${STAGEDIR}${PREFIX}/etc/uchiwa/config.json.sample
(cd ${WRKSRC}/src/github.com/${GH_ACCOUNT}/${PORTNAME}/public && ${COPYTREE_SHARE} . ${STAGEDIR}${UCHIWA_SHAREDIR})
diff --git a/www/web2ldap/Makefile b/www/web2ldap/Makefile
index 40a316803a7e..057072c6aceb 100644
--- a/www/web2ldap/Makefile
+++ b/www/web2ldap/Makefile
@@ -48,7 +48,7 @@ do-install:
${FIND} * -type d | ${GREP} -vE "^htdocs" | ${CPIO} -p ${STAGEDIR}${DATADIR}; \
${FIND} * -type f | ${GREP} -vE "^htdocs" | ${CPIO} -pd ${STAGEDIR}${DATADIR})
-post-install:
+post-install-DOCS-on:
@${ECHO_MSG} "==> Installing document files..."
@${MKDIR} ${STAGEDIR}${DOCSDIR}
@(cd ${WRKSRC}; \
diff --git a/www/webalizer/Makefile b/www/webalizer/Makefile
index 509bf3dd6f06..1116df81389f 100644
--- a/www/webalizer/Makefile
+++ b/www/webalizer/Makefile
@@ -176,8 +176,6 @@ do-install:
${STAGEDIR}${PREFIX}/bin/${PKGNAMEPREFIX}webazolver
${INSTALL_DATA} ${WRKSRC}/sample.conf \
${STAGEDIR}${PREFIX}/etc/${PKGNAMEPREFIX}webalizer.conf-dist ;
-
-post-install:
.for i in ${LMAN1}
${INSTALL_MAN} ${WRKSRC}/${i:S/^${PKGNAMEPREFIX}//} ${STAGEDIR}${PREFIX}/man/man1/${i}
.endfor
diff --git a/www/webinject/Makefile b/www/webinject/Makefile
index defe671c9abc..56bc38f4c46e 100644
--- a/www/webinject/Makefile
+++ b/www/webinject/Makefile
@@ -30,14 +30,12 @@ PLIST_FILES= bin/webinject.pl \
${DATADIR:S,^${PREFIX}/,,}/config.xml \
${DATADIR:S,^${PREFIX}/,,}/testcases.xml
+PORTDOCS= LICENSE README
+
do-install:
@${MKDIR} ${STAGEDIR}${DATADIR}
@cd ${WRKSRC} && ${INSTALL_DATA} *.xml ${STAGEDIR}${DATADIR}
@cd ${WRKSRC} && ${INSTALL_SCRIPT} webinject.pl ${STAGEDIR}${PREFIX}/bin
-
-PORTDOCS= LICENSE README
-
-post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
@${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}