aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2014-09-05 02:26:11 +0800
committeradamw <adamw@FreeBSD.org>2014-09-05 02:26:11 +0800
commit38d157f7244017836721500d3748f9919e2445cd (patch)
treeecb3e37a783cba84aefae12925aa46e79dff4273 /www
parent95283afa8a0f79c09ada4eb2fbea08d46ee5855e (diff)
downloadfreebsd-ports-gnome-38d157f7244017836721500d3748f9919e2445cd.tar.gz
freebsd-ports-gnome-38d157f7244017836721500d3748f9919e2445cd.tar.zst
freebsd-ports-gnome-38d157f7244017836721500d3748f9919e2445cd.zip
Update to 1.2.7. Make the port significantly less clever.
While here, remove PKGNAMESUFFIX and CONFLICTS in preparation for removing www/webcalendar, which has been obsoleted for for a very long time.
Diffstat (limited to 'www')
-rw-r--r--www/webcalendar-devel/Makefile142
-rw-r--r--www/webcalendar-devel/distinfo4
-rw-r--r--www/webcalendar-devel/files/pkg-message.in13
-rw-r--r--www/webcalendar-devel/pkg-descr25
-rw-r--r--www/webcalendar-devel/pkg-plist10
5 files changed, 79 insertions, 115 deletions
diff --git a/www/webcalendar-devel/Makefile b/www/webcalendar-devel/Makefile
index e5587718d9b3..b5c50937f383 100644
--- a/www/webcalendar-devel/Makefile
+++ b/www/webcalendar-devel/Makefile
@@ -1,155 +1,89 @@
# $FreeBSD$
PORTNAME= WebCalendar
-PORTVERSION= 1.2.5
+PORTVERSION= 1.2.7
CATEGORIES= www
-MASTER_SITES= SF/${PORTNAME:tl}/${PORTNAME:tl}%201.2/${PORTVERSION}
-PKGNAMESUFFIX= -devel
-DISTNAME= ${PORTNAME:S/-devel//g}-${PORTVERSION}
-PORTSCOUT= limit:^1\.2\. skipb:1
+MASTER_SITES= SF/${PORTNAME:tl}/${PORTNAME:tl}%201.2/${PORTVERSION}/
MAINTAINER= ports@FreeBSD.org
COMMENT= Web-based calendar application
+LICENSE= GPLv2
+
+PORTSCOUT= limit:^1\.2\. skipb:1
+USES= uidfix
USE_PHP= pcre session
WANT_PHP_WEB= yes
NO_BUILD= yes
-CONFLICTS= WebCalendar-[0-9]*
-LICENSE= GPLv2
-
-WRKSRC= ${WRKDIR}/${DISTNAME}
WWWDIR= ${PREFIX}/www/${PORTNAME:tl}
+DOCSDIR= ${PREFIX}/share/doc/${PORTNAME:tl}
+DEFAULT_VERSIONS= PHP=5
+WITH_PHP_CGI?= /cgi-bin/php
+SUB_LIST+= PHPCGI=${WITH_PHP_CGI}
+PLIST_SUB+= WWWOWN=${WWWOWN} WWWGRP=${WWWGRP}
-OPTIONS_DEFINE= APACHE LDAP GRADIENTBG REMINDERS PALM DOCS
+PORTDOCS= WebCalendar-SysAdmin.html \
+ newwin.gif
+
+OPTIONS_DEFINE= APACHE LDAP GRADIENTBG REMINDERS PALM DOCS
OPTIONS_DEFAULT= MYSQL REMINDERS
-OPTIONS_MULTI= DB
+OPTIONS_MULTI= DB
OPTIONS_MULTI_DB= MYSQL PGSQL SQLITE MSSQL DBASE ODBC ORACLE
+OPTIONS_SUB= yes
GRADIENTBG_DESC= Gradient background image support
REMINDERS_DESC= Email reminder support
PALM_DESC= Palm export support
-.include <bsd.port.pre.mk>
+APACHE_USE= APACHE_RUN=22+
+DBASE_USE= PHP=dbase
+GRADIENTBG_USE= PHP=gd
+LDAP_USE= PHP=ldap
+MSSQL_USE= PHP=mssql
+MYSQL_USE= PHP=mysql
+ODBC_USE= PHP=odbc
+ORACLE_USE= PHP=oracle
+PALM_RUN_DEPENDS= pilot-xfer:${PORTSDIR}/palm/pilot-link
+PGSQL_USE= PHP=pgsql
+SQLITE_USE= PHP=sqlite3
-DOCSDIR= ${PREFIX}/share/doc/${PORTNAME:tl}
-PORTDOCS= WebCalendar-SysAdmin.html \
- newwin.gif
+.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MAPACHE}
-USE_APACHE_RUN= 22+
-
-PLIST_SUB+= NOAPACHE="" CONFDIR=${CONFDIR_REL}
+PLIST_SUB+= CONFDIR=${CONFDIR_REL}
CONFDIR= ${PREFIX}/${CONFDIR_REL}
CONFDIR_REL= ${APACHEETCDIR}/Includes
SUB_FILES= pkg-message
-.else
-PLIST_SUB+= NOAPACHE="@comment "
.endif
-WITH_PHP_CGI?= /cgi-bin/php
-
.if ${PHP_SAPI:Mcgi} == "cgi" && ${PHP_SAPI:Mmod} == ""
CGI_EXT= -cgi
.else
CGI_EXT=
.endif
-
-DEFAULT_PHP_VER=5
-
-SUB_LIST+= PHPCGI=${WITH_PHP_CGI}
-
-.if ${PORT_OPTIONS:MMYSQL}
-USE_PHP+= mysql
-.endif
-
-.if ${PORT_OPTIONS:MPGSQL}
-USE_PHP+= pgsql
-.endif
-
-.if ${PORT_OPTIONS:MSQLITE}
-USE_PHP+= sqlite3
-.endif
-
-.if ${PORT_OPTIONS:MMSSQL}
-USE_PHP+= mssql
-.endif
-
-.if ${PORT_OPTIONS:MDBASE}
-USE_PHP+= dbase
-.endif
-
-.if ${PORT_OPTIONS:MODBC}
-USE_PHP+= odbc
-.endif
-
-.if ${PORT_OPTIONS:MORACLE}
-USE_PHP+= oracle
-.endif
-
-.if ${PORT_OPTIONS:MLDAP}
-USE_PHP+= ldap
-.endif
-
-.if ${PORT_OPTIONS:MGRADIENTBG}
-USE_PHP+= gd
-.endif
+CONF= webcalendar${CGI_EXT}.conf
+SUB_FILES+= ${CONF}
+PLIST_SUB+= CONFFILE=${CONF}
.if ${PORT_OPTIONS:MREMINDERS}
WANT_PHP_CLI= yes
.endif
-.if ${PORT_OPTIONS:MPALM}
-RUN_DEPENDS+= ${LOCALBASE}/bin/pilot-xfer:${PORTSDIR}/palm/pilot-link
-.endif
-
.if ${PORT_OPTIONS:MDOCS}
SUB_LIST+= HASHMARK=
.else
SUB_LIST+= HASHMARK=\#
.endif
-CONF= webcalendar${CGI_EXT}.conf
-SUB_FILES+= ${CONF}
-
do-install:
@${MKDIR} ${STAGEDIR}${WWWDIR}
- @cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR}
- @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${STAGEDIR}${WWWDIR}
- @${ECHO_CMD} '@exec ${CHOWN} -R ${WWWOWN}:${WWWGRP} \
- ${WWWDIR:S|^${PREFIX}/|%D/|}' >> ${TMPPLIST}
- @${FIND} ${STAGEDIR}${WWWDIR} -type f -print0 | ${XARGS} -0 ${CHMOD} 644
- @${ECHO_CMD} '@exec ${FIND} ${WWWDIR} -type f -print0 | \
- ${XARGS} -0 ${CHMOD} 644' >> ${TMPPLIST}
- @${FIND} ${STAGEDIR}${WWWDIR} -type d -print0 | ${XARGS} -0 ${CHMOD} 755
- @${ECHO_CMD} '@exec ${FIND} ${WWWDIR} -type d -print0 | \
- ${XARGS} -0 ${CHMOD} 755' >> ${TMPPLIST}
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR})
post-install:
-.if ${PORT_OPTIONS:MAPACHE}
- @${MKDIR} ${STAGEDIR}${CONFDIR}
- @if [ -d "${STAGEDIR}${CONFDIR}" ]; then \
- ${CP} ${WRKDIR}/${CONF} ${STAGEDIR}${CONFDIR}/webcalendar.conf; \
- else \
- ${ECHO_MSG} "" ; \
- ${ECHO_MSG} "Please check your Apache 2.x installation -" ; \
- ${ECHO_MSG} "${CONFDIR} doesn't exist," ; \
- ${ECHO_MSG} "so I cannot install webcalendar.conf there!" ; \
- ${ECHO_MSG} "" ; \
- ${FALSE} ; \
- fi
-.endif
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKDIR}/${CONF} ${STAGEDIR}${EXAMPLESDIR}
+
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- @cd ${WRKSRC}/docs && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
-.if ${CGI_EXT} == "-cgi"
- @${ECHO_MSG} ""
- @${ECHO_MSG} "Your WebCalendar installation was configured to use the PHP CGI binary."
- @${ECHO_MSG} "The PHP CGI binary is expected to be referenced by the URL:"
- @${ECHO_MSG} ""
- @${ECHO_MSG} " ${WITH_PHP_CGI}"
- @${ECHO_MSG} ""
- @${ECHO_MSG} "If this is incorrect, reinstall the port with the WITH_ PHP_CGI knob"
- @${ECHO_MSG} "set to the correct URL."
- @${ECHO_MSG} "*********************************************************************"
-.endif
+ (cd ${WRKSRC}/docs && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR})
.include <bsd.port.post.mk>
diff --git a/www/webcalendar-devel/distinfo b/www/webcalendar-devel/distinfo
index 9170620d5a3d..c0f1f458b745 100644
--- a/www/webcalendar-devel/distinfo
+++ b/www/webcalendar-devel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (WebCalendar-1.2.5.tar.gz) = d32eed9851ac9079e153a6952f3b4c717f22eba08d719c3498b65f9303441cbe
-SIZE (WebCalendar-1.2.5.tar.gz) = 1372021
+SHA256 (WebCalendar-1.2.7.tar.gz) = 99f01ef8b2c665b8599c14ad6908e4bf5755736f894741430cdbf600b4c4d890
+SIZE (WebCalendar-1.2.7.tar.gz) = 1386070
diff --git a/www/webcalendar-devel/files/pkg-message.in b/www/webcalendar-devel/files/pkg-message.in
index 2df6ae03b6e2..ef2e7b0a7c1a 100644
--- a/www/webcalendar-devel/files/pkg-message.in
+++ b/www/webcalendar-devel/files/pkg-message.in
@@ -2,12 +2,19 @@
*********************************************************************
You have just installed the WebCalendar application.
-Note that you should restart your Apache web server to ensure that
-the WebCalendar configuration file is loaded.
+There is a sample Apache configuration file in
+ %%EXAMPLESDIR%%
-Next, to configure WebCalendar, please visit:
+To configure WebCalendar, please visit:
http://localhost/webcalendar/
and you will be guided through the installation process.
+
+If you installed the CGI binary, you should reference it by the URL:
+
+ %%PHPCGI%%
+
+You can change this by setting WITH_PHP_CGI and recompiling the port.
+
*********************************************************************
diff --git a/www/webcalendar-devel/pkg-descr b/www/webcalendar-devel/pkg-descr
index bbb4ec7834b2..bcad1bd4b1c7 100644
--- a/www/webcalendar-devel/pkg-descr
+++ b/www/webcalendar-devel/pkg-descr
@@ -1,6 +1,21 @@
-This is a port of the WebCalendar application. WebCalendar is an
-Open Source web-based calendar/scheduling system written in PHP.
-WebCalendar has been under development since 2000 and continues to
-evolve.
+ WebCalendar is a PHP-based calendar application that can be configured
+as a single-user calendar, a multi-user calendar for groups of users, or
+as an event calendar viewable by visitors. MySQL, PostgreSQL, Oracle,
+DB2, Interbase, MS SQL Server, or ODBC is required.
-WWW: http://www.k5n.us/webcalendar.php
+WebCalendar can be setup in a variety of ways, such as...
+
+ * A schedule management system for a single person
+
+ * A schedule management system for a group of people, allowing one or
+ more assistants to manage the calendar of another user
+
+ * An events schedule that anyone can view, allowing visitors to submit
+ new events
+
+ * A calendar server that can be viewed with iCalendar-compliant calendar
+ applications like Mozilla Sunbird, Apple iCal or GNOME Evolution or
+ RSS-enabled applications like Firefox, Thunderbird, RSSOwl, FeedDemon,
+ or BlogExpress.
+
+WWW: http://www.k5n.us/webcalendar.php
diff --git a/www/webcalendar-devel/pkg-plist b/www/webcalendar-devel/pkg-plist
index 53dfa5294047..a228aa2fb7ba 100644
--- a/www/webcalendar-devel/pkg-plist
+++ b/www/webcalendar-devel/pkg-plist
@@ -1,4 +1,6 @@
-%%NOAPACHE%%%%CONFDIR%%/webcalendar.conf
+@mode 644
+@owner %%WWWOWN%%
+@group %%WWWGRP%%
%%WWWDIR%%/AUTHORS
%%WWWDIR%%/GPL.html
%%WWWDIR%%/NEWS
@@ -396,6 +398,7 @@
%%WWWDIR%%/week_details.php
%%WWWDIR%%/week_ssi.php
%%WWWDIR%%/year.php
+@mode 755
@dirrm %%WWWDIR%%/translations
@dirrm %%WWWDIR%%/tools
@dirrm %%WWWDIR%%/themes
@@ -423,3 +426,8 @@
@dirrm %%WWWDIR%%/icons
@dirrm %%WWWDIR%%/docs
@dirrmtry %%WWWDIR%%
+@mode
+@owner
+@group
+%%EXAMPLESDIR%%/%%CONFFILE%%
+@dirrm %%EXAMPLESDIR%%