aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2017-04-24 04:13:36 +0800
committertcberner <tcberner@FreeBSD.org>2017-04-24 04:13:36 +0800
commit3cd42464f66f288250f06fea1a4e45088827fca0 (patch)
treefc7fd2367c590e7d552283561e615e41bd547789 /www
parent3ab959ced0ea51f2291cadf852d9f9c07ae3d1ff (diff)
downloadfreebsd-ports-gnome-3cd42464f66f288250f06fea1a4e45088827fca0.tar.gz
freebsd-ports-gnome-3cd42464f66f288250f06fea1a4e45088827fca0.tar.zst
freebsd-ports-gnome-3cd42464f66f288250f06fea1a4e45088827fca0.zip
www/otter-browser: Add upstream patch for hunspell detection.
Approved by: rakuco (mentor) Differential Revision: https://reviews.freebsd.org/D10467
Diffstat (limited to 'www')
-rw-r--r--www/otter-browser/Makefile2
-rw-r--r--www/otter-browser/files/patch-git_8b593422
2 files changed, 23 insertions, 1 deletions
diff --git a/www/otter-browser/Makefile b/www/otter-browser/Makefile
index ec68c20943e5..0721f2bb492f 100644
--- a/www/otter-browser/Makefile
+++ b/www/otter-browser/Makefile
@@ -3,7 +3,7 @@
PORTNAME= otter-browser
PORTVERSION= 0.9.12
DISTVERSIONPREFIX= v
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www
MAINTAINER= kde@FreeBSD.org
diff --git a/www/otter-browser/files/patch-git_8b5934 b/www/otter-browser/files/patch-git_8b5934
new file mode 100644
index 000000000000..7047de1ed6b8
--- /dev/null
+++ b/www/otter-browser/files/patch-git_8b5934
@@ -0,0 +1,22 @@
+From 8b5934e3aff890b8111d72eff258c6c922985ade Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20Dutkiewicz?= <emdeck@gmail.com>
+Date: Fri, 10 Feb 2017 19:39:33 +0100
+Subject: [PATCH] Look for Hunspell 1.6
+
+---
+ cmake/FindHunspell.cmake | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/cmake/FindHunspell.cmake b/cmake/FindHunspell.cmake
+index 8aeaf8d..de0dfdd 100644
+--- cmake/FindHunspell.cmake
++++ cmake/FindHunspell.cmake
+@@ -12,7 +12,7 @@ IF (HUNSPELL_INCLUDE_DIR AND HUNSPELL_LIBRARIES)
+ ENDIF (HUNSPELL_INCLUDE_DIR AND HUNSPELL_LIBRARIES)
+
+ FIND_PATH(HUNSPELL_INCLUDE_DIR hunspell/hunspell.hxx)
+-FIND_LIBRARY(HUNSPELL_LIBRARIES NAMES hunspell-1.5 hunspell-1.4 hunspell-1.3 hunspell)
++FIND_LIBRARY(HUNSPELL_LIBRARIES NAMES hunspell-1.6 hunspell-1.5 hunspell-1.4 hunspell-1.3 hunspell)
+
+ # handle the QUIETLY and REQUIRED arguments and set HUNSPELL_FOUND to TRUE if
+ # all listed variables are TRUE