aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2010-01-31 08:49:50 +0800
committermiwi <miwi@FreeBSD.org>2010-01-31 08:49:50 +0800
commit3d591828e6e6ab1ebf400f2b550a36c27ee02ebc (patch)
tree13748009c246f9a08324ba5cb85badcc021b41d5 /www
parentc7af84c9ce89d4fc1bb4959d33f1942548891c02 (diff)
downloadfreebsd-ports-gnome-3d591828e6e6ab1ebf400f2b550a36c27ee02ebc.tar.gz
freebsd-ports-gnome-3d591828e6e6ab1ebf400f2b550a36c27ee02ebc.tar.zst
freebsd-ports-gnome-3d591828e6e6ab1ebf400f2b550a36c27ee02ebc.zip
- Added Apache and Lighttpd options
- Lighttpd support added - PORTREVISION bumped PR: 143301 Submitted by: Bernhard Froehlich <decke@bluelife.at> (maintainer)
Diffstat (limited to 'www')
-rw-r--r--www/mythplugin-mythweb/Makefile20
-rw-r--r--www/mythplugin-mythweb/files/pkg-message.in6
-rw-r--r--www/mythweb/Makefile20
-rw-r--r--www/mythweb/files/pkg-message.in6
4 files changed, 46 insertions, 6 deletions
diff --git a/www/mythplugin-mythweb/Makefile b/www/mythplugin-mythweb/Makefile
index fabe22e32a2f..1049774cab69 100644
--- a/www/mythplugin-mythweb/Makefile
+++ b/www/mythplugin-mythweb/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mythweb
PORTVERSION= 0.22
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://ftp.osuosl.org/pub/mythtv/ \
http://ftp.oregonstate.edu/pub/mythtv/
@@ -19,18 +20,33 @@ RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD
NO_BUILD= yes
USE_BZIP2= yes
-USE_APACHE= 2.2+
USE_PHP= spl session mysql pcre posix json
SUB_FILES= pkg-message
+REINPLACE_ARGS= -i ""
+
+OPTIONS= APACHE "Enable Apache Support" on \
+ LIGHTTPD "Enable Lighttpd Support" off
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_APACHE)
+USE_APACHE= 2.2+
+.endif
+
+.if defined(WITH_LIGHTTPD)
+RUN_DEPENDS+= lighttpd:${PORTSDIR}/www/lighttpd
+.endif
post-patch:
@${REINPLACE_CMD} -e 's|/var/www/html|${WWWDIR}|' \
${WRKSRC}/mythweb/mythweb.conf.apache
+ @${REINPLACE_CMD} -e 's|/usr/bin/php-cgi|${LOCALBASE}/bin/php-cgi|' \
+ ${WRKSRC}/mythweb/mythweb.conf.lighttpd
do-install:
${MKDIR} ${WWWDIR}
${MKDIR} ${WWWDIR}/data
- (cd ${WRKSRC}/mythweb/ && ${COPYTREE_SHARE} "*" ${WWWDIR} "! -name *.bak")
+ (cd ${WRKSRC}/mythweb/ && ${COPYTREE_SHARE} "*" ${WWWDIR})
${CHOWN} -R ${WWWOWN}:${WWWGRP} ${WWWDIR}
${CHMOD} -R 775 ${WWWDIR}/data
diff --git a/www/mythplugin-mythweb/files/pkg-message.in b/www/mythplugin-mythweb/files/pkg-message.in
index f15c3f24b389..fe62f67af23b 100644
--- a/www/mythplugin-mythweb/files/pkg-message.in
+++ b/www/mythplugin-mythweb/files/pkg-message.in
@@ -4,4 +4,8 @@ mythweb has been installed into:
You need to configure mythweb now according to the instructions in
- %%WWWDIR%%/INSTALL \ No newline at end of file
+ %%WWWDIR%%/INSTALL
+
+For lighttpd you should have a look at the MythTV Wiki
+
+ http://www.mythtv.org/wiki/MythWeb_on_Lighttpd \ No newline at end of file
diff --git a/www/mythweb/Makefile b/www/mythweb/Makefile
index fabe22e32a2f..1049774cab69 100644
--- a/www/mythweb/Makefile
+++ b/www/mythweb/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mythweb
PORTVERSION= 0.22
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://ftp.osuosl.org/pub/mythtv/ \
http://ftp.oregonstate.edu/pub/mythtv/
@@ -19,18 +20,33 @@ RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD
NO_BUILD= yes
USE_BZIP2= yes
-USE_APACHE= 2.2+
USE_PHP= spl session mysql pcre posix json
SUB_FILES= pkg-message
+REINPLACE_ARGS= -i ""
+
+OPTIONS= APACHE "Enable Apache Support" on \
+ LIGHTTPD "Enable Lighttpd Support" off
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_APACHE)
+USE_APACHE= 2.2+
+.endif
+
+.if defined(WITH_LIGHTTPD)
+RUN_DEPENDS+= lighttpd:${PORTSDIR}/www/lighttpd
+.endif
post-patch:
@${REINPLACE_CMD} -e 's|/var/www/html|${WWWDIR}|' \
${WRKSRC}/mythweb/mythweb.conf.apache
+ @${REINPLACE_CMD} -e 's|/usr/bin/php-cgi|${LOCALBASE}/bin/php-cgi|' \
+ ${WRKSRC}/mythweb/mythweb.conf.lighttpd
do-install:
${MKDIR} ${WWWDIR}
${MKDIR} ${WWWDIR}/data
- (cd ${WRKSRC}/mythweb/ && ${COPYTREE_SHARE} "*" ${WWWDIR} "! -name *.bak")
+ (cd ${WRKSRC}/mythweb/ && ${COPYTREE_SHARE} "*" ${WWWDIR})
${CHOWN} -R ${WWWOWN}:${WWWGRP} ${WWWDIR}
${CHMOD} -R 775 ${WWWDIR}/data
diff --git a/www/mythweb/files/pkg-message.in b/www/mythweb/files/pkg-message.in
index f15c3f24b389..fe62f67af23b 100644
--- a/www/mythweb/files/pkg-message.in
+++ b/www/mythweb/files/pkg-message.in
@@ -4,4 +4,8 @@ mythweb has been installed into:
You need to configure mythweb now according to the instructions in
- %%WWWDIR%%/INSTALL \ No newline at end of file
+ %%WWWDIR%%/INSTALL
+
+For lighttpd you should have a look at the MythTV Wiki
+
+ http://www.mythtv.org/wiki/MythWeb_on_Lighttpd \ No newline at end of file