aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorshaun <shaun@FreeBSD.org>2017-04-12 10:28:39 +0800
committershaun <shaun@FreeBSD.org>2017-04-12 10:28:39 +0800
commit40eb3bf209016e50b5ad24563e916b3d1891334c (patch)
treebaeb1355081412bb5a6449d884a774285e6a15d0 /www
parent0ba72aeeab52b373853bcb5323d6edc7690111a3 (diff)
downloadfreebsd-ports-gnome-40eb3bf209016e50b5ad24563e916b3d1891334c.tar.gz
freebsd-ports-gnome-40eb3bf209016e50b5ad24563e916b3d1891334c.tar.zst
freebsd-ports-gnome-40eb3bf209016e50b5ad24563e916b3d1891334c.zip
New port: HTTP/2 State-Machine based protocol implementation.
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/py-h2/Makefile22
-rw-r--r--www/py-h2/distinfo3
-rw-r--r--www/py-h2/pkg-descr6
4 files changed, 32 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 9b5aa748f707..5646f7df1941 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1677,6 +1677,7 @@
SUBDIR += py-graphite-web
SUBDIR += py-grequests
SUBDIR += py-gunicorn
+ SUBDIR += py-h2
SUBDIR += py-horizon
SUBDIR += py-html
SUBDIR += py-html5lib
diff --git a/www/py-h2/Makefile b/www/py-h2/Makefile
new file mode 100644
index 000000000000..39a84baab9f9
--- /dev/null
+++ b/www/py-h2/Makefile
@@ -0,0 +1,22 @@
+# Created by: Shaun Amott <shaun@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= h2
+PORTVERSION= 3.0.1
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= shaun@FreeBSD.org
+COMMENT= HTTP/2 State-Machine based protocol implementation
+
+LICENSE= MIT
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}hyperframe>=5.0.0:www/py-hyperframe \
+ ${PYTHON_PKGNAMEPREFIX}hpack>=2.3:www/py-hpack
+
+USES?= python
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/www/py-h2/distinfo b/www/py-h2/distinfo
new file mode 100644
index 000000000000..e8b35ef00740
--- /dev/null
+++ b/www/py-h2/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1491953058
+SHA256 (h2-3.0.1.tar.gz) = b2962f883fa392a23cbfcc4ad03c335bcc661be0cf9627657b589f0df2206e64
+SIZE (h2-3.0.1.tar.gz) = 2208816
diff --git a/www/py-h2/pkg-descr b/www/py-h2/pkg-descr
new file mode 100644
index 000000000000..cf9ebe069c42
--- /dev/null
+++ b/www/py-h2/pkg-descr
@@ -0,0 +1,6 @@
+This is a pure-Python implementation of a HTTP/2 protocol stack. It's
+written from the ground up to be embeddable in whatever program you
+choose to use, ensuring that you can speak HTTP/2 regardless of your
+programming paradigm.
+
+WWW: http://hyper.rtfd.org/