aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2014-09-27 14:27:10 +0800
committerswills <swills@FreeBSD.org>2014-09-27 14:27:10 +0800
commit425f3e161e222f9b4aa2ef81ae4b87f7687d7859 (patch)
treefb116c8d3eb5fa1f73aa5b43cee49fecf4aca4d0 /www
parent0c5245bb9fd8256ef7277947967f030757e95865 (diff)
downloadfreebsd-ports-gnome-425f3e161e222f9b4aa2ef81ae4b87f7687d7859.tar.gz
freebsd-ports-gnome-425f3e161e222f9b4aa2ef81ae4b87f7687d7859.tar.zst
freebsd-ports-gnome-425f3e161e222f9b4aa2ef81ae4b87f7687d7859.zip
www/rubygem-gollum-lib: create port
A simple, Git-powered wiki with a sweet API and local frontend. WWW: http://github.com/gollum/gollum-lib Submitted by: xmj
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/rubygem-gollum-lib/Makefile25
-rw-r--r--www/rubygem-gollum-lib/distinfo2
-rw-r--r--www/rubygem-gollum-lib/pkg-descr3
4 files changed, 31 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index abc5d11b35d9..c99e1e9a1a74 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1769,6 +1769,7 @@
SUBDIR += rubygem-geminabox
SUBDIR += rubygem-gitlab-gollum-lib
SUBDIR += rubygem-gitlab-grack
+ SUBDIR += rubygem-gollum-lib
SUBDIR += rubygem-gon
SUBDIR += rubygem-haml
SUBDIR += rubygem-haml-coderay
diff --git a/www/rubygem-gollum-lib/Makefile b/www/rubygem-gollum-lib/Makefile
new file mode 100644
index 000000000000..5946219d0e9b
--- /dev/null
+++ b/www/rubygem-gollum-lib/Makefile
@@ -0,0 +1,25 @@
+# Created by: Johannes Meixner <xmj@chaot.net>
+# $FreeBSD$
+
+PORTNAME= gollum-lib
+PORTVERSION= 3.0.0
+CATEGORIES= www rubygems
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Simple, Git-powered wiki with a sweet API and local frontend
+
+LICENSE= MIT
+
+RUN_DEPENDS= rubygem-github-markup>=1.1.0:${PORTSDIR}/textproc/rubygem-github-markup \
+ rubygem-gitlab-grit>=2.6.5:${PORTSDIR}/textproc/rubygem-gitlab-grit \
+ rubygem-nokogiri>=1.6.1:${PORTSDIR}/textproc/rubygem-nokogiri \
+ rubygem-rouge>=1.3.3:${PORTSDIR}/textproc/rubygem-rouge \
+ rubygem-sanitize>=2.1.0:${PORTSDIR}/textproc/rubygem-sanitize \
+ rubygem-stringex>=2.5.1:${PORTSDIR}/devel/rubygem-stringex
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/www/rubygem-gollum-lib/distinfo b/www/rubygem-gollum-lib/distinfo
new file mode 100644
index 000000000000..efa1aa813e1d
--- /dev/null
+++ b/www/rubygem-gollum-lib/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/gollum-lib-3.0.0.gem) = 7a0896cae6d443e42b19e1353f1f900684b63109844cfdb52c48d40f2824e7a1
+SIZE (rubygem/gollum-lib-3.0.0.gem) = 43008
diff --git a/www/rubygem-gollum-lib/pkg-descr b/www/rubygem-gollum-lib/pkg-descr
new file mode 100644
index 000000000000..900ddda22636
--- /dev/null
+++ b/www/rubygem-gollum-lib/pkg-descr
@@ -0,0 +1,3 @@
+A simple, Git-powered wiki with a sweet API and local frontend.
+
+WWW: http://github.com/gollum/gollum-lib