aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormbr <mbr@FreeBSD.org>2002-01-19 20:12:14 +0800
committermbr <mbr@FreeBSD.org>2002-01-19 20:12:14 +0800
commit43486a11274cc2d0ed4de156a29bdd7e81803dab (patch)
tree43f1f2934026a8661ca7e798fd829d06c9083f1a /www
parent9db8185df0178fc5fa6b7d4ad6760d0cdaa3dbc6 (diff)
downloadfreebsd-ports-gnome-43486a11274cc2d0ed4de156a29bdd7e81803dab.tar.gz
freebsd-ports-gnome-43486a11274cc2d0ed4de156a29bdd7e81803dab.tar.zst
freebsd-ports-gnome-43486a11274cc2d0ed4de156a29bdd7e81803dab.zip
Do not overwrite config values with virtual server settings
Approved by: demon
Diffstat (limited to 'www')
-rw-r--r--www/mod_frontpage/files/patch-aa34
1 files changed, 32 insertions, 2 deletions
diff --git a/www/mod_frontpage/files/patch-aa b/www/mod_frontpage/files/patch-aa
index 499466005a49..078da0d4642d 100644
--- a/www/mod_frontpage/files/patch-aa
+++ b/www/mod_frontpage/files/patch-aa
@@ -1,5 +1,5 @@
---- DSO/Makefile.PL.orig Tue Jul 24 23:01:08 2001
-+++ DSO/Makefile.PL Tue Jul 24 23:02:58 2001
+--- DSO/Makefile.PL.orig Tue Mar 20 13:38:00 2001
++++ DSO/Makefile.PL Fri Jan 18 13:58:44 2002
@@ -4,26 +4,7 @@
# You can use it according to the Apache licence
# Please send modifications to: <jmdault@mandrakesoft.com> so other
@@ -28,6 +28,36 @@
print "\nLet's see if it's a valid httpd...";
$_=`$thechoice -v`;
if (/Server version:/) { print " YES!\n";
+@@ -56,23 +37,23 @@
+ open(FILE,"$httpdconf") or die "Can't find $httpdconf!\n";
+ print "Reading httpd.conf...\n";
+ while(<FILE>) {
+- if (/^User (\w*)/) {
++ if (!$user && /^User (\w*)/) {
+ $user=$1;
+ }
+- if (/^Group (\w*)/) {
++ if (!$group && /^Group (\w*)/) {
+ $group=$1;
+ }
+- if (/^UserDir (\w*)/) {
++ if (!$userdir && /^UserDir (\w*)/) {
+ $userdir=$1;
+ }
+- if (/^ServerRoot (\S*)/) {
++ if (!serverroot && /^ServerRoot (\S*)/) {
+ $serverroot=$1;
+ }
+- if (/^ErrorLog (\S*)/) {
++ if (!$errorlog && /^ErrorLog (\S*)/) {
+ $errorlog=$1;
+ $errorlog=~ s/error_log/fpexec_log/;
+ }
+- if (/^DocumentRoot (\S*)/) {
++ if (!$documentroot && /^DocumentRoot (\S*)/) {
+ $documentroot=$1;
+ }
+ }
@@ -91,12 +72,10 @@
}
print "DocumentRoot: $documentroot\n";