aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2011-07-05 01:46:12 +0800
committerswills <swills@FreeBSD.org>2011-07-05 01:46:12 +0800
commit4590f93703cffdb21144e0bcdffee1e318b6b5d1 (patch)
tree12128d966c4353f14b667aef4bca4d4f66061324 /www
parentecff26c2f706f755a5e964a3cac1953e282e07f0 (diff)
downloadfreebsd-ports-gnome-4590f93703cffdb21144e0bcdffee1e318b6b5d1.tar.gz
freebsd-ports-gnome-4590f93703cffdb21144e0bcdffee1e318b6b5d1.tar.zst
freebsd-ports-gnome-4590f93703cffdb21144e0bcdffee1e318b6b5d1.zip
- Mark as broken with Ruby 1.9
Approved by: portmgr
Diffstat (limited to 'www')
-rw-r--r--www/mod_ruby/Makefile4
-rw-r--r--www/ruby-http-access/Makefile6
-rw-r--r--www/ruby-nora/Makefile6
3 files changed, 14 insertions, 2 deletions
diff --git a/www/mod_ruby/Makefile b/www/mod_ruby/Makefile
index ba505b2519f1..b234aed86062 100644
--- a/www/mod_ruby/Makefile
+++ b/www/mod_ruby/Makefile
@@ -36,6 +36,10 @@ DOCS_JA= README.ja doc/default.css doc/*.ja.*
.include <bsd.port.pre.mk>
+.if ${RUBY_VER} == 1.9
+BROKEN= does not build with ruby 1.9
+.endif
+
.if ${APACHE_VERSION} > 20
CONFIGURE_ARGS+= --with-apr-includes="`${LOCALBASE}/bin/apr-1-config --includedir`"
.endif
diff --git a/www/ruby-http-access/Makefile b/www/ruby-http-access/Makefile
index 5aaff8f5c022..59fac58a5fe8 100644
--- a/www/ruby-http-access/Makefile
+++ b/www/ruby-http-access/Makefile
@@ -29,4 +29,8 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/README.txt ${RUBY_MODDOCDIR}/
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.if ${RUBY_VER} == 1.9
+BROKEN= does not build with ruby 1.9
+.endif
+.include <bsd.port.post.mk>
diff --git a/www/ruby-nora/Makefile b/www/ruby-nora/Makefile
index 7c718ae78de4..bedb143b94b8 100644
--- a/www/ruby-nora/Makefile
+++ b/www/ruby-nora/Makefile
@@ -29,4 +29,8 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/README.ja ${RUBY_MODDOCDIR}/ja/
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.if ${RUBY_VER} == 1.9
+BROKEN= does not build with ruby 1.9
+.endif
+.include <bsd.port.post.mk>