aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorgblach <gblach@FreeBSD.org>2018-03-14 00:52:53 +0800
committergblach <gblach@FreeBSD.org>2018-03-14 00:52:53 +0800
commit46f312944af902e9e321da7a2782daa1af9e8e32 (patch)
treea9a1eb66c3291621db7f5ebe3d3a7ee2108d6e89 /www
parentf462b353038dfd02cb4841342ff9ae120c6ed318 (diff)
downloadfreebsd-ports-gnome-46f312944af902e9e321da7a2782daa1af9e8e32.tar.gz
freebsd-ports-gnome-46f312944af902e9e321da7a2782daa1af9e8e32.tar.zst
freebsd-ports-gnome-46f312944af902e9e321da7a2782daa1af9e8e32.zip
- Add www/py-tornado4 port
- Set conflicts between py-tornado and py-tornado4
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/py-tornado/Makefile2
-rw-r--r--www/py-tornado4/Makefile38
-rw-r--r--www/py-tornado4/distinfo3
-rw-r--r--www/py-tornado4/files/patch-setup.py12
-rw-r--r--www/py-tornado4/pkg-descr15
6 files changed, 71 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 9ba1ab622a8b..e04bb7200fde 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1865,6 +1865,7 @@
SUBDIR += py-textile
SUBDIR += py-tmdb3
SUBDIR += py-tornado
+ SUBDIR += py-tornado4
SUBDIR += py-trello
SUBDIR += py-treq
SUBDIR += py-turbogears2
diff --git a/www/py-tornado/Makefile b/www/py-tornado/Makefile
index b8ff4b7a1281..73295b7e97e6 100644
--- a/www/py-tornado/Makefile
+++ b/www/py-tornado/Makefile
@@ -12,6 +12,8 @@ COMMENT= Python Web Server from FriendFeed
LICENSE= APACHE20
+CONFLICTS= py[0-9]*-tornado4-*
+
USES= python
USE_PYTHON= autoplist distutils
diff --git a/www/py-tornado4/Makefile b/www/py-tornado4/Makefile
new file mode 100644
index 000000000000..98293fd98b7f
--- /dev/null
+++ b/www/py-tornado4/Makefile
@@ -0,0 +1,38 @@
+# Created by: Guixing Bai <khsing.cn@gmail.com>
+# $FreeBSD$
+
+PORTNAME= tornado
+PORTVERSION= 4.5.3
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+PKGNAMESUFFIX= 4
+
+MAINTAINER= gblach@FreeBSD.org
+COMMENT= Python Web Server from FriendFeed
+
+LICENSE= APACHE20
+
+CONFLICTS= py[0-9]*-tornado-*
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 3400
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}singledispatch>0:devel/py-singledispatch@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}certifi>0:security/py-certifi@${FLAVOR}
+.endif
+
+.if ${PYTHON_REL} < 3500
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}backports_abc>=0.4:devel/py-backports_abc@${FLAVOR}
+.endif
+
+post-build:
+ @${FIND} ${WRKSRC}/build -name speedups.so -exec ${STRIP_CMD} {} \;
+
+regression-test: build
+ @cd ${WRKSRC} && ${PYTHON_CMD} -m tornado.test.runtests
+
+.include <bsd.port.post.mk>
diff --git a/www/py-tornado4/distinfo b/www/py-tornado4/distinfo
new file mode 100644
index 000000000000..60c00546773a
--- /dev/null
+++ b/www/py-tornado4/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1520958958
+SHA256 (tornado-4.5.3.tar.gz) = 6d14e47eab0e15799cf3cdcc86b0b98279da68522caace2bd7ce644287685f0a
+SIZE (tornado-4.5.3.tar.gz) = 484221
diff --git a/www/py-tornado4/files/patch-setup.py b/www/py-tornado4/files/patch-setup.py
new file mode 100644
index 000000000000..dc22450431ac
--- /dev/null
+++ b/www/py-tornado4/files/patch-setup.py
@@ -0,0 +1,12 @@
+--- setup.py.orig 2015-11-06 20:08:26 UTC
++++ setup.py
+@@ -147,9 +147,6 @@ setup(
+ # in the sdist tarball)
+ "tornado.test": [
+ "README",
+- "csv_translations/fr_FR.csv",
+- "gettext_translations/fr_FR/LC_MESSAGES/tornado_test.mo",
+- "gettext_translations/fr_FR/LC_MESSAGES/tornado_test.po",
+ "options_test.cfg",
+ "static/robots.txt",
+ "static/sample.xml",
diff --git a/www/py-tornado4/pkg-descr b/www/py-tornado4/pkg-descr
new file mode 100644
index 000000000000..d70dfd3d4036
--- /dev/null
+++ b/www/py-tornado4/pkg-descr
@@ -0,0 +1,15 @@
+Tornado is an open source version of the scalable, non-blocking web server and
+tools that power FriendFeed. The FriendFeed application is written using a web
+framework that looks a bit like web.py or Google's webapp, but with additional
+tools and optimizations to take advantage of the underlying non-blocking
+infrastructure.
+
+The framework is distinct from most mainstream web server frameworks (and
+certainly most Python frameworks) because it is non-blocking and reasonably
+fast. Because it is non-blocking and uses epoll or kqueue, it can handle
+thousands of simultaneous standing connections, which means it is ideal for
+real-time web services. We built the web server specifically to handle
+FriendFeed's real-time features - every active user of FriendFeed maintains an
+open connection to the FriendFeed servers.
+
+WWW: http://www.tornadoweb.org/