aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2012-01-18 12:31:26 +0800
committerpgollucci <pgollucci@FreeBSD.org>2012-01-18 12:31:26 +0800
commit56e5225cc2f293132893a032c413c39fac5205c3 (patch)
tree1ab8ffff6af6014b93ff7562927e98fd794efa9c /www
parent2a313a046159e33ef414972b21c6f32460792e22 (diff)
downloadfreebsd-ports-gnome-56e5225cc2f293132893a032c413c39fac5205c3.tar.gz
freebsd-ports-gnome-56e5225cc2f293132893a032c413c39fac5205c3.tar.zst
freebsd-ports-gnome-56e5225cc2f293132893a032c413c39fac5205c3.zip
- Pull upstream patch 2613 so as not to conflict with mod_deflate [1]
(http://article.gmane.org/gmane.comp.web.fastcgi) - Enable module by default [2] PR: ports/156251 [2] ports/163199 [1] Submitted by: Denny Lin <dennylin93@hs.ntnu.edu.tw> [1] Gea-Suan Lin <gslin@gslin.org> [2] With Hat: apache@
Diffstat (limited to 'www')
-rw-r--r--www/mod_fastcgi/Makefile5
-rw-r--r--www/mod_fastcgi/files/patch-mod_fastcgi.c14
2 files changed, 18 insertions, 1 deletions
diff --git a/www/mod_fastcgi/Makefile b/www/mod_fastcgi/Makefile
index 3bf7e740aa93..1c81c873cbce 100644
--- a/www/mod_fastcgi/Makefile
+++ b/www/mod_fastcgi/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mod_fastcgi
PORTVERSION= 2.4.6
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www
MASTER_SITES= http://www.fastcgi.com/dist/
@@ -23,6 +23,9 @@ AP_GENPLIST= yes
SRC_FILE= *.c
PORTDOCS= LICENSE.TERMS mod_fastcgi.html
+do-install:
+ @${APXS} -i -a -n ${SHORTMODNAME} ${WRKSRC}/${MODULENAME}.${AP_BUILDEXT}
+
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
diff --git a/www/mod_fastcgi/files/patch-mod_fastcgi.c b/www/mod_fastcgi/files/patch-mod_fastcgi.c
new file mode 100644
index 000000000000..4491acc6820f
--- /dev/null
+++ b/www/mod_fastcgi/files/patch-mod_fastcgi.c
@@ -0,0 +1,14 @@
+--- mod_fastcgi.c.orig 2011-12-12 15:37:24.211384000 +0800
++++ mod_fastcgi.c 2011-12-12 15:37:50.565004000 +0800
+@@ -754,6 +754,11 @@
+ continue;
+ }
+
++ if (strcasecmp(name, "Content-Length") == 0) {
++ ap_set_content_length(r, strtol(value, NULL, 10));
++ continue;
++ }
++
+ /* If the script wants them merged, it can do it */
+ ap_table_add(r->err_headers_out, name, value);
+ continue;