aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorflo <flo@FreeBSD.org>2011-10-18 23:51:34 +0800
committerflo <flo@FreeBSD.org>2011-10-18 23:51:34 +0800
commit59b42392e474590020d34bbd85b13dd4534d6bbe (patch)
tree1a44e882ec88ec34be5c26572690b8aac56878de /www
parentbb8009eb523d3fc5949a0ec4cada9c733237f168 (diff)
downloadfreebsd-ports-gnome-59b42392e474590020d34bbd85b13dd4534d6bbe.tar.gz
freebsd-ports-gnome-59b42392e474590020d34bbd85b13dd4534d6bbe.tar.zst
freebsd-ports-gnome-59b42392e474590020d34bbd85b13dd4534d6bbe.zip
- Add support for www/rt40
- Add license - Pet portlint PR: ports/160954 Submitted by: Matthew Seaman <m.seaman@infracaninophile.co.uk> (maintainer)
Diffstat (limited to 'www')
-rw-r--r--www/p5-RT-Extension-LDAPImport/Makefile22
1 files changed, 16 insertions, 6 deletions
diff --git a/www/p5-RT-Extension-LDAPImport/Makefile b/www/p5-RT-Extension-LDAPImport/Makefile
index 32ba6097fe48..4f7e2313a8d1 100644
--- a/www/p5-RT-Extension-LDAPImport/Makefile
+++ b/www/p5-RT-Extension-LDAPImport/Makefile
@@ -19,17 +19,27 @@ LICENSE= ART10 GPLv1
BUILD_DEPENDS= ${SITE_PERL}/Net/LDAP.pm:${PORTSDIR}/net/p5-perl-ldap \
${SITE_PERL}/Class/Accessor.pm:${PORTSDIR}/devel/p5-Class-Accessor
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
-RTHOME?= share/rt38
-RT_PM_DIR= ${SITE_PERL}
-BUILD_DEPENDS+= ${RT_PM_DIR}/RT.pm:${PORTSDIR}/www/rt38
+OPTIONS= RT38 "Install for rt-3.8.x (default rt-4.0.x)" off
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_RT38)
+RT_VER= 38
+.else
+RT_VER= 40
+.endif
+
+BUILD_DEPENDS+= ${SITE_PERL}/RT.pm:${PORTSDIR}/www/rt${RT_VER}
+RUN_DEPENDS+= ${SITE_PERL}/RT.pm:${PORTSDIR}/www/rt${RT_VER}
+
MAN3PREFIX= ${PREFIX}
MAN3= RT::Extension::LDAPImport.3
-PLIST_SUB+= RTHOME=${RTHOME}
+PLIST_SUB+= RTHOME=share/rt${RT_VER}
# Note: You can install using an arbitrary $PREFIX but only if it
# matches the $PREFIX used to install www/rt3{6,8}. Hence ignore
@@ -37,7 +47,7 @@ PLIST_SUB+= RTHOME=${RTHOME}
do-configure:
@cd ${CONFIGURE_WRKSRC} && \
unset PREFIX && \
- ${SETENV} ${CONFIGURE_ENV} ${PERL5} -I${RT_PM_DIR} ./${CONFIGURE_SCRIPT} && \
+ ${SETENV} ${CONFIGURE_ENV} ${PERL5} -I${SITE_PERL} ./${CONFIGURE_SCRIPT} && \
${PERL5} -pi -e 's/ doc_(perl|site|\$$\(INSTALLDIRS\))_install$$//' Makefile
.include <bsd.port.mk>