aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorohauer <ohauer@FreeBSD.org>2014-05-31 04:45:07 +0800
committerohauer <ohauer@FreeBSD.org>2014-05-31 04:45:07 +0800
commit62863c8beab8551604f5a3b3754d33afc1d496a3 (patch)
tree85ac88a738c05a19101afd474f37cfa68b55b590 /www
parent9e06275f06cfa7ccc0eec3e4e5b7878dcb0e3882 (diff)
downloadfreebsd-ports-gnome-62863c8beab8551604f5a3b3754d33afc1d496a3.tar.gz
freebsd-ports-gnome-62863c8beab8551604f5a3b3754d33afc1d496a3.tar.zst
freebsd-ports-gnome-62863c8beab8551604f5a3b3754d33afc1d496a3.zip
- add stage support
- update master site - add WWW
Diffstat (limited to 'www')
-rw-r--r--www/mod_cband/Makefile19
-rw-r--r--www/mod_cband/files/patch-Makefile.in12
-rw-r--r--www/mod_cband/pkg-descr2
3 files changed, 21 insertions, 12 deletions
diff --git a/www/mod_cband/Makefile b/www/mod_cband/Makefile
index ff1380cf4e17..b776edc13215 100644
--- a/www/mod_cband/Makefile
+++ b/www/mod_cband/Makefile
@@ -5,15 +5,14 @@ PORTNAME= mod_cband
PORTVERSION= 0.9.7.5
PORTREVISION= 3
CATEGORIES= www
-MASTER_SITES= http://www.sfr-fresh.com/unix/privat/
+MASTER_SITES= http://fossies.org/linux/www/apache_httpd_modules/
PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
DISTNAME= ${PORTNAME:C/_/-/}-${PORTVERSION}
EXTRACT_SUFX= .tgz
DIST_SUBDIR= apache2
MAINTAINER= apache@FreeBSD.org
-COMMENT= A per-virtualhost bandwidth limiter module for Apache 2
-
+COMMENT= Per-virtualhost bandwidth limiter module for Apache 2
USE_APACHE= 22
GNU_CONFIGURE= yes
@@ -21,14 +20,10 @@ CONFIGURE_ARGS= --with-apxs=${APXS}
ALL_TARGET= #
PORTDOCS= libpatricia.copyright documentation.txt faq.txt
-NO_STAGE= yes
post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/libpatricia.copyright ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/doc/documentation.txt ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/doc/faq.txt ${DOCSDIR}
-.else
- @${DO_NADA}
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/libpatricia.copyright ${STAGEDIR}${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/doc/documentation.txt ${STAGEDIR}${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/doc/faq.txt ${STAGEDIR}${DOCSDIR}
+
.include <bsd.port.mk>
diff --git a/www/mod_cband/files/patch-Makefile.in b/www/mod_cband/files/patch-Makefile.in
new file mode 100644
index 000000000000..717ca49e2b1e
--- /dev/null
+++ b/www/mod_cband/files/patch-Makefile.in
@@ -0,0 +1,12 @@
+--- ./Makefile.in.orig 2013-12-15 19:48:51.000000000 +0100
++++ ./Makefile.in 2013-12-15 19:49:40.000000000 +0100
+@@ -33,7 +33,8 @@
+ @echo
+
+ install: $(OBJ)
+- $(APXS) $(APXS_OPTS) -i -a -n cband src/mod_cband.la
++ /bin/mkdir -p $(DESTDIR)$$($(APXS) -q LIBEXECDIR)
++ $(APXS) $(APXS_OPTS) -i -S LIBEXECDIR=$(DESTDIR)$$($(APXS) -q LIBEXECDIR) -n cband src/mod_cband.la
+
+ clean:
+ rm -f src/.libs/*
diff --git a/www/mod_cband/pkg-descr b/www/mod_cband/pkg-descr
index 44d8abce0476..371421ad529e 100644
--- a/www/mod_cband/pkg-descr
+++ b/www/mod_cband/pkg-descr
@@ -2,3 +2,5 @@ mod_cband is an Apache 2 module provided to solve the problem of
limiting virtualhosts bandwidth usage. When the configured
virtualhost's transfer limit is exceeded, mod_cband will redirect all
further requests to a location specified in the configuration file.
+
+WWW: http://dembol.org/blog/mod_cband/