aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2011-09-21 16:18:54 +0800
committerwen <wen@FreeBSD.org>2011-09-21 16:18:54 +0800
commit6433e07e863ab36e701758f8b9e1c1a86915974e (patch)
tree268cc689105e9f8f0f485cb69d2ddfc5370c28fe /www
parent5d6b15772d925b7a8884419203df655f107b853a (diff)
downloadfreebsd-ports-gnome-6433e07e863ab36e701758f8b9e1c1a86915974e.tar.gz
freebsd-ports-gnome-6433e07e863ab36e701758f8b9e1c1a86915974e.tar.zst
freebsd-ports-gnome-6433e07e863ab36e701758f8b9e1c1a86915974e.zip
- Depend on simplejson confitionally
PR: ports/160857 Submitted by: Ruslan Mahmatkhanov <cvs-src@yandex.ru>
Diffstat (limited to 'www')
-rw-r--r--www/py-WebError/Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/www/py-WebError/Makefile b/www/py-WebError/Makefile
index fe9a4db4250e..2c1a47a36492 100644
--- a/www/py-WebError/Makefile
+++ b/www/py-WebError/Makefile
@@ -7,6 +7,7 @@
PORTNAME= WebError
PORTVERSION= 0.10.3
+PORTREVISION= 1
CATEGORIES= www python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -14,13 +15,20 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= wen@FreeBSD.org
COMMENT= Web Error handling and exception catching
+LICENSE= MIT
+
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Paste>=1.7:${PORTSDIR}/www/py-paste \
${PYTHON_PKGNAMEPREFIX}pygments>=1.0:${PORTSDIR}/textproc/py-pygments \
${PYTHON_PKGNAMEPREFIX}Tempita>=0.3:${PORTSDIR}/textproc/py-Tempita \
- ${PYTHON_PKGNAMEPREFIX}webob>=0.9.6.1:${PORTSDIR}/www/py-webob \
- ${PYTHON_PKGNAMEPREFIX}simplejson>=2.0.8:${PORTSDIR}/devel/py-simplejson
+ ${PYTHON_PKGNAMEPREFIX}webob>=0.9.6.1:${PORTSDIR}/www/py-webob
USE_PYTHON= 2.5+
USE_PYDISTUTILS= easy_install
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 260
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}simplejson>=2.0.8:${PORTSDIR}/devel/py-simplejson
+.endif
+
+.include <bsd.port.post.mk>