aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2017-04-27 20:14:37 +0800
committermat <mat@FreeBSD.org>2017-04-27 20:14:37 +0800
commit64d057a0680206d86938ee3b0a22a8bd3f5e6e55 (patch)
tree8d23c50179e379168dc29b05aa2ec3d88dfb97af /www
parent8fe943f30c5624108625a00842bd7f2e18228ba2 (diff)
downloadfreebsd-ports-gnome-64d057a0680206d86938ee3b0a22a8bd3f5e6e55.tar.gz
freebsd-ports-gnome-64d057a0680206d86938ee3b0a22a8bd3f5e6e55.tar.zst
freebsd-ports-gnome-64d057a0680206d86938ee3b0a22a8bd3f5e6e55.zip
Mark those as not building with openssl-devel.
Sponsored by: Absolight
Diffstat (limited to 'www')
-rw-r--r--www/nginx/Makefile2
-rw-r--r--www/tengine/Makefile3
2 files changed, 5 insertions, 0 deletions
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index 152a8d36b932..aac6d7273ef0 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -1162,6 +1162,8 @@ GROUPS?=${WWWGRP}
.if defined(NGINX_OPENSSL)
USES+= ssl
+BROKEN_SSL= openssl-devel
+BROKEN_SSL_REASON_openssl-devel= undefined reference to SSLeay_version
.endif
pre-everything::
diff --git a/www/tengine/Makefile b/www/tengine/Makefile
index 3933e8446f8d..82aa1b3d38f6 100644
--- a/www/tengine/Makefile
+++ b/www/tengine/Makefile
@@ -25,6 +25,9 @@ LIB_DEPENDS+= libluajit-5.1.so:lang/luajit \
libgd.so:graphics/gd \
libGeoIP.so:net/GeoIP
+BROKEN_SSL= openssl-devel
+BROKEN_SSL_REASON_openssl-devel= incomplete definition of type struct evp_pkey_st
+
NO_OPTIONS_SORT= yes
OPTIONS_DEFINE= \
DEBUG \