aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-10-11 22:27:23 +0800
committermiwi <miwi@FreeBSD.org>2008-10-11 22:27:23 +0800
commit65c65d2410c397082a311c125b7ddaa29a30bff9 (patch)
tree62a9c3a1b2380e934ba951c6ce38e80480321acb /www
parentaa3150c4b8bef03c74652cf1f8f9b99cc095a0d7 (diff)
downloadfreebsd-ports-gnome-65c65d2410c397082a311c125b7ddaa29a30bff9.tar.gz
freebsd-ports-gnome-65c65d2410c397082a311c125b7ddaa29a30bff9.tar.zst
freebsd-ports-gnome-65c65d2410c397082a311c125b7ddaa29a30bff9.zip
`multisort' is a small program designed to take multiple httpd
logfiles in the Common Log Format and merge them into a single log, sorted by date, sent to standard output. This is useful if you're running a single website on multiple hosts and using round-robin DNS to do load distribution. With multisort, you can take the various logfiles from each server and merge them into a single file for analysis. WWW: http://www.xach.com/multisort/ PR: ports/127906 Submitted by: Dennis Herrmann <adox at mcx2.org>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/multisort/Makefile19
-rw-r--r--www/multisort/distinfo3
-rw-r--r--www/multisort/files/patch-Makefile18
-rw-r--r--www/multisort/pkg-descr10
5 files changed, 51 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index fb7b28ed6cdd..708809a36b3e 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -506,6 +506,7 @@
SUBDIR += mozilla
SUBDIR += mozplugger
SUBDIR += mplayer-plugin
+ SUBDIR += multisort
SUBDIR += myfaces
SUBDIR += myghty
SUBDIR += mysar
diff --git a/www/multisort/Makefile b/www/multisort/Makefile
new file mode 100644
index 000000000000..a1a55ff550ba
--- /dev/null
+++ b/www/multisort/Makefile
@@ -0,0 +1,19 @@
+# New ports collection makefile for: multisort
+# Date created: 06 Oct 2008
+# Whom: Dennis Herrmann <adox@mcx2.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= multisort
+PORTVERSION= 1.1
+CATEGORIES= www
+MASTER_SITES= http://www.xach.com/multisort/ \
+ http://mirror.mcx2.org/
+
+MAINTAINER= adox@mcx2.org
+COMMENT= A small program to take multiple httpd logfiles into one
+
+PLIST_FILES= bin/multisort
+
+.include <bsd.port.mk>
diff --git a/www/multisort/distinfo b/www/multisort/distinfo
new file mode 100644
index 000000000000..42fb9dc56606
--- /dev/null
+++ b/www/multisort/distinfo
@@ -0,0 +1,3 @@
+MD5 (multisort-1.1.tar.gz) = c47f7622773022119e1ea21d2b211bd3
+SHA256 (multisort-1.1.tar.gz) = 50cc0e84738f1c9b4b587e4d13564c233be20c693fd2154f2e8a293f3d5bc17d
+SIZE (multisort-1.1.tar.gz) = 3520
diff --git a/www/multisort/files/patch-Makefile b/www/multisort/files/patch-Makefile
new file mode 100644
index 000000000000..a5bc0682c10d
--- /dev/null
+++ b/www/multisort/files/patch-Makefile
@@ -0,0 +1,18 @@
+--- Makefile.orig 1999-10-28 21:04:24.000000000 +0200
++++ Makefile 2008-10-07 18:48:41.000000000 +0200
+@@ -1,9 +1,10 @@
+-#
+-# $Id: Makefile,v 1.1 1999/01/14 19:05:35 xach Exp $
+-#
+-
++PREFIX?= /usr/local
+ CC = gcc
+ CFLAGS = -Wall -g -O2
+
+-multisort: multisort.c
++all:
+ $(CC) $(CFLAGS) -o multisort multisort.c
++
++install:
++ @mkdir -p ${DESTDIR}${PREFIX}/bin
++ install -m 755 multisort ${PREFIX}/bin
diff --git a/www/multisort/pkg-descr b/www/multisort/pkg-descr
new file mode 100644
index 000000000000..1c16ffc5350c
--- /dev/null
+++ b/www/multisort/pkg-descr
@@ -0,0 +1,10 @@
+`multisort' is a small program designed to take multiple httpd
+logfiles in the Common Log Format and merge them into a single log,
+sorted by date, sent to standard output.
+
+This is useful if you're running a single website on multiple hosts
+and using round-robin DNS to do load distribution. With multisort, you
+can take the various logfiles from each server and merge them into a
+single file for analysis.
+
+WWW: http://www.xach.com/multisort/