aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorjrm <jrm@FreeBSD.org>2017-04-11 04:58:24 +0800
committerjrm <jrm@FreeBSD.org>2017-04-11 04:58:24 +0800
commit6779533c52419a0ba952fbf46d4be6e5c92427da (patch)
tree042313b697575c7f82cfbdcd478d4f612f02598d /www
parent413eefa6fb11e686e2bbd460a9a6b75c2e1ea455 (diff)
downloadfreebsd-ports-gnome-6779533c52419a0ba952fbf46d4be6e5c92427da.tar.gz
freebsd-ports-gnome-6779533c52419a0ba952fbf46d4be6e5c92427da.tar.zst
freebsd-ports-gnome-6779533c52419a0ba952fbf46d4be6e5c92427da.zip
New port, www/rubygem-goldfinger: Webfinger utility for Ruby
Adding this because it is a dependency for the upcoming www/mastodon port. Approved by: swills (mentor, implicit)
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/rubygem-goldfinger/Makefile23
-rw-r--r--www/rubygem-goldfinger/distinfo3
-rw-r--r--www/rubygem-goldfinger/pkg-descr6
4 files changed, 33 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index f58a807c3d8e..45e5bd3e8c38 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1966,6 +1966,7 @@
SUBDIR += rubygem-gitlab-gollum-lib
SUBDIR += rubygem-gitlab-grack
SUBDIR += rubygem-gitlab-turbolinks-classic
+ SUBDIR += rubygem-goldfinger
SUBDIR += rubygem-gollum
SUBDIR += rubygem-gollum-grit_adapter
SUBDIR += rubygem-gollum-lib
diff --git a/www/rubygem-goldfinger/Makefile b/www/rubygem-goldfinger/Makefile
new file mode 100644
index 000000000000..1898c5d40c17
--- /dev/null
+++ b/www/rubygem-goldfinger/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= goldfinger
+PORTVERSION= 1.1.2
+CATEGORIES= www rubygems
+MASTER_SITES= RG
+
+MAINTAINER= jrm@FreeBSD.org
+COMMENT= Webfinger utility for Ruby
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= rubygem-addressable>=2.4:www/rubygem-addressable \
+ rubygem-http>=2.0:www/rubygem-http \
+ rubygem-nokogiri>=1.6:textproc/rubygem-nokogiri
+
+NO_ARCH= yes
+
+USE_RUBY= yes
+USES= gem
+
+.include <bsd.port.mk>
diff --git a/www/rubygem-goldfinger/distinfo b/www/rubygem-goldfinger/distinfo
new file mode 100644
index 000000000000..5dd9e991ce66
--- /dev/null
+++ b/www/rubygem-goldfinger/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1491857390
+SHA256 (rubygem/goldfinger-1.1.2.gem) = 4ca90319a9915ae3317143e0b6ad5b11e71a66f4a16d3c8876106f683c89ac2f
+SIZE (rubygem/goldfinger-1.1.2.gem) = 8192
diff --git a/www/rubygem-goldfinger/pkg-descr b/www/rubygem-goldfinger/pkg-descr
new file mode 100644
index 000000000000..340f5dfb7d67
--- /dev/null
+++ b/www/rubygem-goldfinger/pkg-descr
@@ -0,0 +1,6 @@
+Goldfinger is a Webfinger client for Ruby. It supports application/xrd+xml and
+application/jrd+json responses. It raises Goldfinger::NotFoundError on failure
+to fetch the Webfinger or XRD data, or Goldfinger::SSLError if something is
+wrong with the HTTPS connection.
+
+WWW: https://github.com/Gargron/goldfinger/