aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2009-06-01 02:26:51 +0800
committerpgollucci <pgollucci@FreeBSD.org>2009-06-01 02:26:51 +0800
commit67d4786aa2eec60faac5f8b4fd06cae08f26f2b1 (patch)
tree8574eed58c3d7c2ed6d98af9571efff631ec1256 /www
parentf9bf4b347b2eb878c524502c53256a69bafcf0f4 (diff)
downloadfreebsd-ports-gnome-67d4786aa2eec60faac5f8b4fd06cae08f26f2b1.tar.gz
freebsd-ports-gnome-67d4786aa2eec60faac5f8b4fd06cae08f26f2b1.tar.zst
freebsd-ports-gnome-67d4786aa2eec60faac5f8b4fd06cae08f26f2b1.zip
- Convert to USE_APACHE, remove apache from _DEPENDS-
- Use WWWOWN, WWWGRP - APACHEDIR comes from USE_APACHE - Use %%var%% in pkg-plist - Bump PORTREVISION PR: ports/134601 Approved by: maintainer timeout (2 weeks) Submitted by: me
Diffstat (limited to 'www')
-rw-r--r--www/photo_gallery/Makefile16
-rw-r--r--www/photo_gallery/pkg-plist10
2 files changed, 12 insertions, 14 deletions
diff --git a/www/photo_gallery/Makefile b/www/photo_gallery/Makefile
index 24becc11dc76..1640b7a59760 100644
--- a/www/photo_gallery/Makefile
+++ b/www/photo_gallery/Makefile
@@ -6,6 +6,7 @@
PORTNAME= photo_gallery
PORTVERSION= 1.5
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://www.capybara.org/~dfraser/photo_gallery/
DISTNAME= ${PORTNAME}_${PORTVERSION}
@@ -15,20 +16,17 @@ MAINTAINER= bob@bomar.us
COMMENT= Simple web based photo gallery
RUN_DEPENDS= anytopnm:${PORTSDIR}/graphics/netpbm\
- ${LOCALBASE}/etc/apache/httpd.conf:${PORTSDIR}/www/apache13\
${SITE_PERL}/CGI.pm:${PORTSDIR}/www/p5-CGI.pm \
${SITE_PERL}/Image/Info.pm:${PORTSDIR}/graphics/p5-Image-Info\
${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI
-WEBOWN?= www
-WEBGRP?= www
-APACHEDIR= ${LOCALBASE}/www/data
-INSTALLDIR= ${APACHEDIR}/photo
-NO_BUILD= yes
+USE_APACHE= 1.3
USE_PERL5= yes
+NO_BUILD= yes
do-install:
- ${MKDIR} ${INSTALLDIR}
- cd ${WRKSRC}; ${FIND} . \
- | ${CPIO} -pdm -R ${WEBOWN}:${WEBGRP} ${INSTALLDIR}
+ ${MKDIR} ${WWWDIR}/
+ @cd ${WRKSRC}; ${FIND} . \
+ | ${CPIO} -pdm -R ${WWWOWN}:${WWWGRP} ${WWWDIR}
+
.include <bsd.port.mk>
diff --git a/www/photo_gallery/pkg-plist b/www/photo_gallery/pkg-plist
index 9471b41846b5..3a27e01e7690 100644
--- a/www/photo_gallery/pkg-plist
+++ b/www/photo_gallery/pkg-plist
@@ -1,5 +1,5 @@
-www/data/photo/index.cgi
-www/data/photo/readme.html
-www/data/photo/.header.html
-www/data/photo/.footer.html
-@dirrm www/data/photo
+%%WWWDIR%%/index.cgi
+%%WWWDIR%%/readme.html
+%%WWWDIR%%/.header.html
+%%WWWDIR%%/.footer.html
+@dirrm %%WWWDIR%%