aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-06-26 21:49:41 +0800
committerpav <pav@FreeBSD.org>2006-06-26 21:49:41 +0800
commit68f92e1955e35a2c831ff12637bc4313d755881e (patch)
tree25d589d34f20e514e8da10c310328013a3c0084c /www
parent677a16afc0e6484d8bd6c4f120e7a018855f9005 (diff)
downloadfreebsd-ports-gnome-68f92e1955e35a2c831ff12637bc4313d755881e.tar.gz
freebsd-ports-gnome-68f92e1955e35a2c831ff12637bc4313d755881e.tar.zst
freebsd-ports-gnome-68f92e1955e35a2c831ff12637bc4313d755881e.zip
- Update to 5.0.2.4803 which fixes the vulnerability
- Add note about EoL June 30, 2006 - Fix support on FreeBSD/amd64 PR: ports/99325 Submitted by: Scot W. Hetzel <swhetzel@gmail.com> (maintainer)
Diffstat (limited to 'www')
-rw-r--r--www/frontpage/Makefile43
-rw-r--r--www/frontpage/Makefile.fp.common33
-rw-r--r--www/frontpage/distinfo20
-rw-r--r--www/frontpage/files/fp_install.alpha11
-rw-r--r--www/frontpage/files/fp_install.bsdi11
-rw-r--r--www/frontpage/files/fp_install.sparc11
-rw-r--r--www/frontpage/pkg-plist4
7 files changed, 70 insertions, 63 deletions
diff --git a/www/frontpage/Makefile b/www/frontpage/Makefile
index 9610bb47c2c6..ad73fb9dacb2 100644
--- a/www/frontpage/Makefile
+++ b/www/frontpage/Makefile
@@ -6,21 +6,14 @@
#
PORTNAME= frontpage
-PORTVERSION= 5.0.2.2635
-PORTREVISION= 2
+PORTVERSION= 5.0.2.4803
CATEGORIES= www
MASTER_SITES= # Needs to be manually fetched from http://www.rtr.com
-
DISTFILES= ${FRONTPAGE}
-DIST_SUBDIR= fp${PORTVERSION:S/.//g}
MAINTAINER= swhetzel@gmail.com
COMMENT= Microsoft Frontpage 2002 Extensions
-FORBIDDEN= http://vuxml.FreeBSD.org/c0171f59-ea8a-11da-be02-000c6ec775d9.html
-
-ONLY_FOR_ARCHS= i386 ia64 amd64 alpha sparc
-
EXTRACT_ONLY=
NO_WRKSUBDIR= yes
NO_BUILD= yes
@@ -31,15 +24,21 @@ USE_PERL5_RUN= yes
USE_RC_SUBR= yes
RC_SCRIPTS= frontpage:0010
RC_SCRIPT_PREFIX= ${RC_SCRIPTS:S/${RC_SCRIPTS:C/:[^:]+$//}//:S/://}
-RC_SCRIPT= ${RC_SCRIPTS:C/:[^:]+$//}.sh
+RC_SCRIPT= ${RC_SCRIPTS:C/:[^:]+$//}
-SUB_FILES= ${RC_SCRIPT}
+SUB_FILES= ${RC_SCRIPT}.sh
SUB_LIST+= RC_SUBR=${RC_SUBR} PERL5=${PERL} FP_VER=${FP_VER}
.include <bsd.port.pre.mk>
.include "${.CURDIR}/Makefile.fp.common"
-FP_DIR= frontpage/version${FP_VER}
+.if (${OSVERSION} >= 700007 || ( ${OSVERSION} < 700000 && ${OSVERSION} >= 600101 ))
+RCD_SCRIPT= ${RC_SCRIPT}
+.else
+RCD_SCRIPT= ${RC_SCRIPT_PREFIX}.${RC_SCRIPT}.sh
+.endif
+PLIST_SUB+= RCD_SCRIPT=${RCD_SCRIPT}
+
FP_INSTALL= ${FP_DIR}/fp_install.sh
FP_SETPERM= ${FP_DIR}/set_default_perms.sh
FP_DOCS= readme.htm readme_apache_dso.txt LICENSE.TXT
@@ -47,15 +46,24 @@ FP_DOCS= readme.htm readme_apache_dso.txt LICENSE.TXT
EXTRACT_FILES= ${FP_INSTALL} ${FP_SETPERM}
.if ${ARCH} == alpha
-EXTRA_PATCHES= fp_install.alpha
+FP_MACHINE= alpha
.elif ${ARCH} == sparc64
-EXTRA_PATCHES= fp_install.sparc
+FP_MACHINE= solaris
.elif defined(WANT_BSDI_EXTENSIONS)
-EXTRA_PATCHES= fp_install.bsdi
+FP_MACHINE= bsdi
.elif ${ARCH} == i386
.if ${OSVERSION} >= 500000
LIB_DEPENDS+= c.4:${PORTSDIR}/misc/compat4x
+FP_MACHINE= freebsd
+.endif
+.elif ${ARCH} == amd64
+.if ${OSVERSION} >= 500000
+LIB_DEPENDS+= c.4:${PORTSDIR}/misc/compat4x
+.endif
+.if ${OSVERSION} >= 600000
+LIB_DEPENDS+= crypt.2:${PORTSDIR}/misc/compat5x
.endif
+FP_MACHINE= freebsd
.endif
do-extract:
@@ -69,7 +77,8 @@ do-extract:
post-patch:
.if !defined(PATCH_DEBUG)
- @${REINPLACE_CMD} -e 's:PREFIX:${PREFIX}:g' \
+ @${REINPLACE_CMD} -E -e 's:PREFIX:${PREFIX}:g' \
+ -e 's:(machine=\")freebsd\":\1${FP_MACHINE}\":g' \
-e 's:DOCSDIR:${DOCSDIR}:g' ${WRKDIR}/${FP_INSTALL}
.endif
@@ -91,8 +100,8 @@ do-install:
.endfor
post-install:
- ${INSTALL_SCRIPT} ${WRKDIR}/${RC_SCRIPT} \
- ${PREFIX}/etc/rc.d/${RC_SCRIPT_PREFIX}.${RC_SCRIPT}
+ ${INSTALL_SCRIPT} ${WRKDIR}/${RC_SCRIPT}.sh \
+ ${PREFIX}/etc/rc.d/${RCD_SCRIPT}
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/www/frontpage/Makefile.fp.common b/www/frontpage/Makefile.fp.common
index 5bc1b7e137c6..166e93daa1b6 100644
--- a/www/frontpage/Makefile.fp.common
+++ b/www/frontpage/Makefile.fp.common
@@ -5,8 +5,13 @@
# $FreeBSD$
#
+DIST_SUBDIR= fp${PORTVERSION:S/.//g}
+
+ONLY_FOR_ARCH= i386 amd64 alpha sparc64 ia64
+
FP_VER= ${PORTVERSION:C|^([0-9]+)\.([0-9]+).*|\1.\2|}
PLIST_SUB+= FP_VER=${FP_VER}
+FP_DIR= frontpage/version${FP_VER}
.if defined(ALL_FP)
FRONTPAGE= fp${FP_VER:S/.//}.alpha${EXTRACT_SUFX} \
@@ -24,7 +29,14 @@ FRONTPAGE= fp${FP_VER:S/.//}.bsdi${EXTRACT_SUFX}
FRONTPAGE= fp${FP_VER:S/.//}.freebsd${EXTRACT_SUFX}
.endif
-.elif ${ARCH}== ia64 || ${ARCH} == amd64
+.elif ${ARCH} == amd64
+.if ${OSVERSION} < 500000
+IGNORE= "The Frontpage extensions require FreeBSD-${ARCH} 5.0 or better"
+.endif
+FRONTPAGE= fp${FP_VER:S/.//}.freebsd${EXTRACT_SUFX}
+LDCONFIG= /sbin/ldconfig -32
+
+.elif ${ARCH} == ia64 || ${ARCH} == amd64
.if ${OSVERSION} < 500000
IGNORE= "The Frontpage Extensions require FreeBSD-${ARCH} 5.0 or better"
.endif
@@ -38,8 +50,8 @@ FRONTPAGE= fp${FP_VER:S/.//}.alpha${EXTRACT_SUFX}
FRONTPAGE= fp${FP_VER:S/.//}.solaris${EXTRACT_SUFX}
.endif
-.if ${ARCH} == amd64 || ${ARCH} == ia64 || ${ARCH} == sparc64
-IGNORE= "The Frontpage Extensions haven't been tested on this ${ARCH}. If the Frontpage Extensions work on your ${ARCH}, please submit a pr to remove this warning from ${PORTSDIR}/www/frontpage/Makefile.fp.common for your ${ARCH}"
+.if ${ARCH} == ia64 || ${ARCH} == sparc64
+IGNORE= "The Frontpage Extensions haven't been tested on this ${ARCH}. If the Frontpage Extensions work on your ${ARCH}, please submit a PR to remove this warning from ${PORTSDIR}/www/frontpage/Makefile.fp.common for your ${ARCH}"
.endif
.for fpdist in ${FRONTPAGE}
@@ -50,3 +62,18 @@ IGNORE="You must manualy fetch ${fpdist} from http://www.rtr.com. Place the fil
NO_CDROM= "Redistribution is not permitted"
RESTRICTED= ${NO_CDROM}
+
+TODAY!= /bin/date -u "+%Y%m%d"
+
+.if ${TODAY} < 20060701
+
+pre-everything::
+ @${ECHO_CMD} "Microsoft Frontpage Extenions will reach their End-of-Life on June 30, 2006."
+ @${ECHO_CMD}
+ @${ECHO_CMD} "You should use alternative methods with Microsoft Frontpage (FTP, WebDAV, ...) to edit websites."
+ @${ECHO_CMD}
+ @sleep 5
+
+.else
+DEPRECATED= Microsoft Frontpage Extensions have reached their End-of-Life
+.endif
diff --git a/www/frontpage/distinfo b/www/frontpage/distinfo
index 0377a8a7e4a4..69c8cab6a928 100644
--- a/www/frontpage/distinfo
+++ b/www/frontpage/distinfo
@@ -1,8 +1,12 @@
-MD5 (fp5022635/fp50.alpha.tar.gz) = 63c26a9ff0b97b44692fd5717b892dc0
-SIZE (fp5022635/fp50.alpha.tar.gz) = 13245239
-MD5 (fp5022635/fp50.bsdi.tar.gz) = e1640a3d5eb06fbfe77827c68c387f64
-SIZE (fp5022635/fp50.bsdi.tar.gz) = 10484068
-MD5 (fp5022635/fp50.freebsd.tar.gz) = 15bb2e119f1c2c91a5f4855a0b8ca836
-SIZE (fp5022635/fp50.freebsd.tar.gz) = 10205076
-MD5 (fp5022635/fp50.solaris.tar.gz) = 98ef852e1db27ced23e7f5971146a4dd
-SIZE (fp5022635/fp50.solaris.tar.gz) = 11510762
+MD5 (fp5024803/fp50.alpha.tar.gz) = 14f7f18e18d36f1208524f88d53167fb
+SHA256 (fp5024803/fp50.alpha.tar.gz) = 6a9d2a1ae55a8ef260e59d98b8cf26ebf38f11123211c748647851526f1bd60b
+SIZE (fp5024803/fp50.alpha.tar.gz) = 13245946
+MD5 (fp5024803/fp50.bsdi.tar.gz) = ea789f27549835f41d7e54d7c73d98ce
+SHA256 (fp5024803/fp50.bsdi.tar.gz) = 002dd07212c060998742fe5fd781ecbd4226bab461c6704d451c378a548ad5e0
+SIZE (fp5024803/fp50.bsdi.tar.gz) = 10523532
+MD5 (fp5024803/fp50.freebsd.tar.gz) = f6754c6e25f252fe19b7dff047eecf39
+SHA256 (fp5024803/fp50.freebsd.tar.gz) = 97f8ec0368079c35a40a7f0afbe2e117bbc1c69a4774299c39490b0006015281
+SIZE (fp5024803/fp50.freebsd.tar.gz) = 10729480
+MD5 (fp5024803/fp50.solaris.tar.gz) = 7b7d8bc138459bb05185cf1f807d9f9c
+SHA256 (fp5024803/fp50.solaris.tar.gz) = f202e26434465fcec3e838b78fca40389d0d3f21b6ffa626bd533cc3f73c7b4f
+SIZE (fp5024803/fp50.solaris.tar.gz) = 11511771
diff --git a/www/frontpage/files/fp_install.alpha b/www/frontpage/files/fp_install.alpha
deleted file mode 100644
index bedbbca2841f..000000000000
--- a/www/frontpage/files/fp_install.alpha
+++ /dev/null
@@ -1,11 +0,0 @@
---- frontpage/version5.0/fp_install.sh.orig Tue Jul 15 16:58:01 2003
-+++ frontpage/version5.0/fp_install.sh Tue Jul 15 17:20:23 2003
-@@ -171,7 +171,7 @@
- SunOS*5.*sun4*) machine="solaris" ;;
- SunOS*5.*i386*) machine="solarisx86" ;;
- BSD/OS*) machine="bsdi" ;;
-- FreeBSD*) machine="freebsd"
-+ FreeBSD*) machine="alpha"
- DEFAULTAPXS="PREFIX/sbin/apxs"
- ;;
- *) echo "ERROR: Unsupported platform! Uname is $system."
diff --git a/www/frontpage/files/fp_install.bsdi b/www/frontpage/files/fp_install.bsdi
deleted file mode 100644
index 2970c462c439..000000000000
--- a/www/frontpage/files/fp_install.bsdi
+++ /dev/null
@@ -1,11 +0,0 @@
---- frontpage/version5.0/fp_install.sh.orig Tue Jul 15 16:58:01 2003
-+++ frontpage/version5.0/fp_install.sh Tue Jul 15 17:20:23 2003
-@@ -171,7 +171,7 @@
- SunOS*5.*sun4*) machine="solaris" ;;
- SunOS*5.*i386*) machine="solarisx86" ;;
- BSD/OS*) machine="bsdi" ;;
-- FreeBSD*) machine="freebsd"
-+ FreeBSD*) machine="bsdi"
- DEFAULTAPXS="PREFIX/sbin/apxs"
- ;;
- *) echo "ERROR: Unsupported platform! Uname is $system."
diff --git a/www/frontpage/files/fp_install.sparc b/www/frontpage/files/fp_install.sparc
deleted file mode 100644
index f0160e3360fc..000000000000
--- a/www/frontpage/files/fp_install.sparc
+++ /dev/null
@@ -1,11 +0,0 @@
---- frontpage/version5.0/fp_install.sh.orig Tue Jul 15 16:58:01 2003
-+++ frontpage/version5.0/fp_install.sh Tue Jul 15 17:20:23 2003
-@@ -171,7 +171,7 @@
- SunOS*5.*sun4*) machine="solaris" ;;
- SunOS*5.*i386*) machine="solarisx86" ;;
- BSD/OS*) machine="bsdi" ;;
-- FreeBSD*) machine="freebsd"
-+ FreeBSD*) machine="solaris"
- DEFAULTAPXS="PREFIX/sbin/apxs"
- ;;
- *) echo "ERROR: Unsupported platform! Uname is $system."
diff --git a/www/frontpage/pkg-plist b/www/frontpage/pkg-plist
index 7714232a8bc5..835e2b1754e1 100644
--- a/www/frontpage/pkg-plist
+++ b/www/frontpage/pkg-plist
@@ -1,5 +1,5 @@
-@unexec %D/etc/rc.d/0010.frontpage.sh forcestop 2>/dev/null || true
-etc/rc.d/0010.frontpage.sh
+@unexec %D/etc/rc.d/%%RCD_SCRIPT%% forcestop 2>/dev/null || true
+etc/rc.d/%%RCD_SCRIPT%%
frontpage/version%%FP_VER%%/admin/1033/addacct.htm
frontpage/version%%FP_VER%%/admin/1033/addrole.htm
frontpage/version%%FP_VER%%/admin/1033/adduser.htm