aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorperky <perky@FreeBSD.org>2004-06-25 16:58:59 +0800
committerperky <perky@FreeBSD.org>2004-06-25 16:58:59 +0800
commit6eb0978d3c0eb332a7980d6c68a9001f8d704ff9 (patch)
treef30e34401d999260d9f2b54f4c8fb399901b9116 /www
parent54fc40172f9a314b3c5f4f9e7ddd9ca4b00e3749 (diff)
downloadfreebsd-ports-gnome-6eb0978d3c0eb332a7980d6c68a9001f8d704ff9.tar.gz
freebsd-ports-gnome-6eb0978d3c0eb332a7980d6c68a9001f8d704ff9.tar.zst
freebsd-ports-gnome-6eb0978d3c0eb332a7980d6c68a9001f8d704ff9.zip
Add new port for py-htmltestcase 0.2.0,
HTML Unittest module for Python. PR: 68308 Submitted by: "Choe, Cheng-Dae" <whitekid@netian.com>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/py-htmltestcase/Makefile24
-rw-r--r--www/py-htmltestcase/distinfo2
-rw-r--r--www/py-htmltestcase/pkg-descr3
-rw-r--r--www/py-htmltestcase/pkg-plist6
5 files changed, 36 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 565eb660971a..7409ba4002c3 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -538,6 +538,7 @@
SUBDIR += py-albatross
SUBDIR += py-clientform
SUBDIR += py-fcgi
+ SUBDIR += py-htmltestcase
SUBDIR += py-mt
SUBDIR += py-scgi
SUBDIR += py-websvcs
diff --git a/www/py-htmltestcase/Makefile b/www/py-htmltestcase/Makefile
new file mode 100644
index 000000000000..e59d51e766ac
--- /dev/null
+++ b/www/py-htmltestcase/Makefile
@@ -0,0 +1,24 @@
+# Ports collection makefile for: py-htmltestcase
+# Date created: 24 June 2004
+# Whom: "Choe, Cheng-Dae" <whitekid@netian.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= htmltestcase
+PORTVERSION= 0.2.0
+CATEGORIES= www python
+MASTER_SITES= http://chriscurvey.com:8080/curveyConsulting/HtmlUnit/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= HtmlTestCase-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A python html unit testing
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/ClientCookie/__init__.py:${PORTSDIR}/devel/py-clientcookie\
+ ${PYTHON_SITELIBDIR}/ClientForm.py:${PORTSDIR}/www/py-clientform
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+.include <bsd.port.mk>
diff --git a/www/py-htmltestcase/distinfo b/www/py-htmltestcase/distinfo
new file mode 100644
index 000000000000..90ca7ec1e533
--- /dev/null
+++ b/www/py-htmltestcase/distinfo
@@ -0,0 +1,2 @@
+MD5 (HtmlTestCase-0.2.0.tar.gz) = 3cbb471efdd151740cb6af9df8efe6a9
+SIZE (HtmlTestCase-0.2.0.tar.gz) = 13743
diff --git a/www/py-htmltestcase/pkg-descr b/www/py-htmltestcase/pkg-descr
new file mode 100644
index 000000000000..621adb42da3e
--- /dev/null
+++ b/www/py-htmltestcase/pkg-descr
@@ -0,0 +1,3 @@
+HtmlTestCase is a html unit testing for python
+
+WWW: http://chriscurvey.com:8080/curveyConsulting/HtmlUnit/
diff --git a/www/py-htmltestcase/pkg-plist b/www/py-htmltestcase/pkg-plist
new file mode 100644
index 000000000000..30d579302b57
--- /dev/null
+++ b/www/py-htmltestcase/pkg-plist
@@ -0,0 +1,6 @@
+%%PYTHON_SITELIBDIR%%/HtmlTestCase.py
+%%PYTHON_SITELIBDIR%%/HtmlTestCase.pyc
+%%PYTHON_SITELIBDIR%%/HtmlTestCase.pyo
+%%PYTHON_SITELIBDIR%%/HttpTestCase.py
+%%PYTHON_SITELIBDIR%%/HttpTestCase.pyc
+%%PYTHON_SITELIBDIR%%/HttpTestCase.pyo