aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorflo <flo@FreeBSD.org>2011-08-30 23:35:11 +0800
committerflo <flo@FreeBSD.org>2011-08-30 23:35:11 +0800
commit6f627176864b0177abcd9f243e2ee1b6547a1aeb (patch)
treeb5f66dac7b1f6cdb6c28622cc56c15457ca27b6a /www
parent01a50aa4de06db5b044dca2327ed903407ab2959 (diff)
downloadfreebsd-ports-gnome-6f627176864b0177abcd9f243e2ee1b6547a1aeb.tar.gz
freebsd-ports-gnome-6f627176864b0177abcd9f243e2ee1b6547a1aeb.tar.zst
freebsd-ports-gnome-6f627176864b0177abcd9f243e2ee1b6547a1aeb.zip
- update to 2.3.1
- use officcial fix from bugzilla to prevent enigmail hang In collaboration with: ale
Diffstat (limited to 'www')
-rw-r--r--www/seamonkey/Makefile3
-rw-r--r--www/seamonkey/distinfo4
-rw-r--r--www/seamonkey/files/patch-bug68102660
-rw-r--r--www/seamonkey/files/patch-mozilla_toolkit_xre_glxtest.cpp25
4 files changed, 63 insertions, 29 deletions
diff --git a/www/seamonkey/Makefile b/www/seamonkey/Makefile
index e643948f238a..4800ce984ca1 100644
--- a/www/seamonkey/Makefile
+++ b/www/seamonkey/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= seamonkey
-DISTVERSION= 2.3
-PORTREVISION= 3
+DISTVERSION= 2.3.1
CATEGORIES?= www ipv6
MASTER_SITES= ${MASTER_SITE_MOZILLA_EXTENDED}
MASTER_SITE_SUBDIR= seamonkey/releases/${DISTVERSION}/source
diff --git a/www/seamonkey/distinfo b/www/seamonkey/distinfo
index a3af756bafbd..02ac01ab4503 100644
--- a/www/seamonkey/distinfo
+++ b/www/seamonkey/distinfo
@@ -1,2 +1,2 @@
-SHA256 (seamonkey-2.3.source.tar.bz2) = a709ac32c166448da4c9558ca17809ddbfa87f7e0e2a0638387ae080fb6758a4
-SIZE (seamonkey-2.3.source.tar.bz2) = 87002565
+SHA256 (seamonkey-2.3.1.source.tar.bz2) = 902256dab16843b66905009b60e84cd2de425223198864256020c1a195bbd061
+SIZE (seamonkey-2.3.1.source.tar.bz2) = 86960754
diff --git a/www/seamonkey/files/patch-bug681026 b/www/seamonkey/files/patch-bug681026
new file mode 100644
index 000000000000..35caa969565c
--- /dev/null
+++ b/www/seamonkey/files/patch-bug681026
@@ -0,0 +1,60 @@
+--- mozilla.orig/widget/public/nsIGfxInfo.idl 2011-08-30 11:08:14.000000000 +0200
++++ mozilla/widget/public/nsIGfxInfo.idl 2011-08-30 11:08:18.000000000 +0200
+@@ -131,5 +131,8 @@
+ * underlying GL impl that's used to implement WebGL.
+ */
+ DOMString getWebGLParameter(in DOMString aParam);
++
++ // only useful on X11
++ [notxpcom] void GetData();
+ };
+
+diff -ru mozilla.orig/widget/src/xpwidgets/GfxInfoBase.h mozilla/widget/src/xpwidgets/GfxInfoBase.h
+--- mozilla.orig/widget/src/xpwidgets/GfxInfoBase.h 2011-08-30 11:07:31.000000000 +0200
++++ mozilla/widget/src/xpwidgets/GfxInfoBase.h 2011-08-30 11:09:45.000000000 +0200
+@@ -84,6 +84,9 @@
+ // Ideally, Init() would be void-return, but the rules of
+ // NS_GENERIC_FACTORY_CONSTRUCTOR_INIT require it be nsresult return.
+ virtual nsresult Init();
++
++ // only useful on X11
++ virtual void GetData() {}
+
+ protected:
+
+diff -ru mozilla.orig/widget/src/xpwidgets/GfxInfoX11.h mozilla/widget/src/xpwidgets/GfxInfoX11.h
+--- mozilla.orig/widget/src/xpwidgets/GfxInfoX11.h 2011-08-30 11:07:31.000000000 +0200
++++ mozilla/widget/src/xpwidgets/GfxInfoX11.h 2011-08-30 11:13:49.000000000 +0200
+@@ -67,6 +67,8 @@
+ using GfxInfoBase::GetWebGLParameter;
+
+ virtual nsresult Init();
++
++ virtual void GetData();
+
+ protected:
+
+@@ -81,7 +83,6 @@
+ int mMajorVersion, mMinorVersion;
+
+ void AddCrashReportAnnotations();
+- void GetData();
+ };
+
+ } // namespace widget
+diff -ru mozilla.orig/widget/src/xpwidgets/nsBaseWidget.cpp mozilla/widget/src/xpwidgets/nsBaseWidget.cpp
+--- mozilla.orig/widget/src/xpwidgets/nsBaseWidget.cpp 2011-08-30 11:07:31.000000000 +0200
++++ mozilla/widget/src/xpwidgets/nsBaseWidget.cpp 2011-08-30 11:11:47.000000000 +0200
+@@ -836,6 +836,12 @@
+
+ nsCOMPtr<nsIGfxInfo> gfxInfo = do_GetService("@mozilla.org/gfx/info;1");
+ if (gfxInfo) {
++ // bug 655578: on X11 at least, we must always call GetData (even if we don't need that information)
++ // as that's what causes GfxInfo initialization which kills the zombie 'glxtest' process.
++ // initially we relied on the fact that GetFeatureStatus calls GetData for us, but bug 681026 showed
++ // that assumption to be unsafe.
++ gfxInfo->GetData();
++
+ PRInt32 status;
+ if (NS_SUCCEEDED(gfxInfo->GetFeatureStatus(nsIGfxInfo::FEATURE_OPENGL_LAYERS, &status))) {
+ if (status != nsIGfxInfo::FEATURE_NO_INFO) {
diff --git a/www/seamonkey/files/patch-mozilla_toolkit_xre_glxtest.cpp b/www/seamonkey/files/patch-mozilla_toolkit_xre_glxtest.cpp
index f338b4bdedb5..e69de29bb2d1 100644
--- a/www/seamonkey/files/patch-mozilla_toolkit_xre_glxtest.cpp
+++ b/www/seamonkey/files/patch-mozilla_toolkit_xre_glxtest.cpp
@@ -1,25 +0,0 @@
---- mozilla/toolkit/xre/glxtest.cpp.orig 2011-08-19 18:57:10.604870746 +0300
-+++ mozilla/toolkit/xre/glxtest.cpp 2011-08-19 18:59:43.620447963 +0300
-@@ -51,6 +51,8 @@
- // which runs the glxtest() static function. This creates a X connection, a GLX context, calls glGetString, and writes that
- // to the 'write' end of the pipe.
-
-+#include <sys/types.h>
-+#include <sys/wait.h>
- #include <cstdio>
- #include <cstdlib>
- #include <unistd.h>
-@@ -224,6 +226,7 @@
- void fire_glxtest_process()
- {
- int pfd[2];
-+ int status;
- if (pipe(pfd) == -1) {
- perror("pipe");
- exit(EXIT_FAILURE);
-@@ -244,4 +247,5 @@
- close(pfd[1]);
- mozilla::widget::glxtest_pipe = pfd[0];
- mozilla::widget::glxtest_pid = pid;
-+ waitpid(pid, &status, 0);
- }