aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2017-11-30 14:53:07 +0800
committeryuri <yuri@FreeBSD.org>2017-11-30 14:53:07 +0800
commit7506f5e2624ba7a1de112fadecbb736a20e96d22 (patch)
tree32323ad53cd907887ed690b586eb24da19e9e365 /www
parent8352f41adf69e1d8560cc998f3cc9d35ec3ca464 (diff)
downloadfreebsd-ports-gnome-7506f5e2624ba7a1de112fadecbb736a20e96d22.tar.gz
freebsd-ports-gnome-7506f5e2624ba7a1de112fadecbb736a20e96d22.tar.zst
freebsd-ports-gnome-7506f5e2624ba7a1de112fadecbb736a20e96d22.zip
New port: www/py-ddgr: Command line tool for performing DuckDuckGo web searches
PR: 223976 Submitted by: jsmith@resonatingmedia.com Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D13299
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/py-ddgr/Makefile34
-rw-r--r--www/py-ddgr/distinfo3
-rw-r--r--www/py-ddgr/files/patch-Makefile11
-rw-r--r--www/py-ddgr/pkg-descr7
5 files changed, 56 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index c6771803878a..9060524462c9 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1556,6 +1556,7 @@
SUBDIR += py-cssmin
SUBDIR += py-cssselect
SUBDIR += py-cssutils
+ SUBDIR += py-ddgr
SUBDIR += py-django
SUBDIR += py-django-allauth
SUBDIR += py-django-annotations
diff --git a/www/py-ddgr/Makefile b/www/py-ddgr/Makefile
new file mode 100644
index 000000000000..768aa36204dc
--- /dev/null
+++ b/www/py-ddgr/Makefile
@@ -0,0 +1,34 @@
+# $FreeBSD$
+
+PORTNAME= ddgr
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.1
+CATEGORIES= www
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= jsmith@resonatingmedia.com
+COMMENT= Command line tool for performing DuckDuckGo web searches
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=2.4.3:www/py3-requests
+
+USES= python:3.3+ shebangfix
+USE_GITHUB= yes
+GH_ACCOUNT= jarun
+USE_PYTHON= concurrent requests
+NO_BUILD= yes
+NO_ARCH= yes
+SHEBANG_FILES= ${PORTNAME}
+python_OLD_CMD= "/usr/bin/env python3" # see bug#223980
+
+MAKE_ARGS= DOCDIR=${STAGEDIR}${DOCSDIR} FREEBSD_PYTHON_VER=${PYTHON_VER}
+
+OPTIONS_DEFINE= DOCS
+
+PLIST_FILES= bin/ddgr \
+ share/man/man1/ddgr-${PYTHON_VER}.1.gz
+PORTDOCS= README.md
+
+.include <bsd.port.mk>
diff --git a/www/py-ddgr/distinfo b/www/py-ddgr/distinfo
new file mode 100644
index 000000000000..de77de7c636d
--- /dev/null
+++ b/www/py-ddgr/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1511990479
+SHA256 (jarun-ddgr-v1.1_GH0.tar.gz) = 6fbf7a638e3e4c0db57ef4a86f253b5810e5755b88727444b17d4528e3a4f5d8
+SIZE (jarun-ddgr-v1.1_GH0.tar.gz) = 38553
diff --git a/www/py-ddgr/files/patch-Makefile b/www/py-ddgr/files/patch-Makefile
new file mode 100644
index 000000000000..f5b6586d799d
--- /dev/null
+++ b/www/py-ddgr/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.orig 2017-11-29 12:33:58 UTC
++++ Makefile
+@@ -13,7 +13,7 @@ install:
+ install -m755 -d $(DOCDIR)
+ gzip -c ddgr.1 > ddgr.1.gz
+ install -m755 ddgr $(BINDIR)
+- install -m644 ddgr.1.gz $(MANDIR)
++ install -m644 ddgr.1.gz $(MANDIR)/ddgr-${FREEBSD_PYTHON_VER}.1.gz
+ install -m644 README.md $(DOCDIR)
+ rm -f ddgr.1.gz
+
diff --git a/www/py-ddgr/pkg-descr b/www/py-ddgr/pkg-descr
new file mode 100644
index 000000000000..88ea14d5aaf1
--- /dev/null
+++ b/www/py-ddgr/pkg-descr
@@ -0,0 +1,7 @@
+ddgr is a cmdline utility to search DuckDuckGo from the terminal.
+Unlike the web interface, you can specify the number of search results
+you would like to see per page. It's more convenient than skimming
+through 30-odd search results per page. The default interface is
+carefully designed to use minimum space without sacrificing readability.
+
+WWW: https://github.com/jarun/ddgr