aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2014-05-24 22:11:57 +0800
committersunpoet <sunpoet@FreeBSD.org>2014-05-24 22:11:57 +0800
commit759ec3362c51656d5d85f2b468e281fdddba9389 (patch)
treeb75db8f50fae8a14c9d6f7c9ef8b600a5274a6cb /www
parentbc90f485bd5cf5557706071dd3ac36eb17b79e7b (diff)
downloadfreebsd-ports-gnome-759ec3362c51656d5d85f2b468e281fdddba9389.tar.gz
freebsd-ports-gnome-759ec3362c51656d5d85f2b468e281fdddba9389.tar.zst
freebsd-ports-gnome-759ec3362c51656d5d85f2b468e281fdddba9389.zip
- Update to 1.4.10
- Use GMAKE to build npm Changes: https://github.com/isaacs/npm/commits/master PR: ports/189843 (based on) Submitted by: adamw
Diffstat (limited to 'www')
-rw-r--r--www/npm/Makefile7
-rw-r--r--www/npm/distinfo4
-rw-r--r--www/npm/pkg-plist30
3 files changed, 36 insertions, 5 deletions
diff --git a/www/npm/Makefile b/www/npm/Makefile
index 6532884c1b67..90127a86368a 100644
--- a/www/npm/Makefile
+++ b/www/npm/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= npm
-PORTVERSION= 1.4.6
+PORTVERSION= 1.4.10
CATEGORIES= www
MASTER_SITES= LOCAL/sunpoet
@@ -57,10 +57,11 @@ maketar: do-clean
@${FETCH_BINARY} ${FETCH_ARGS:C/A//} -o ${MS_WRKSRC}/${MS_DISTNAME}.tar.gz ${GITHUB_TARBALL}
@${MKDIR} ${MS_WRKSRC}/${MS_DISTNAME}/
@${TAR} -xf ${MS_WRKSRC}/${MS_DISTNAME}.tar.gz -C ${MS_WRKSRC}/${MS_DISTNAME}/ --strip-components 1
+ @${REINPLACE_CMD} -e 's|ronn|marked|g' ${MS_WRKSRC}/${MS_DISTNAME}/Makefile ${MS_WRKSRC}/${MS_DISTNAME}/scripts/doc-build.sh
@${REINPLACE_CMD} -e '/manRoot/ s|, "share"||' ${MS_WRKSRC}/${MS_DISTNAME}/lib/build.js ${MS_WRKSRC}/${MS_DISTNAME}/lib/unbuild.js
- @${REINPLACE_CMD} -e '1 s|#!/bin/bash|#!${LOCALBASE}/bin/bash|; s|perl -pi|perl -p|' ${MS_WRKSRC}/${MS_DISTNAME}/scripts/doc-build.sh
+ @${REINPLACE_CMD} -e '1 s|#!/bin/bash|#!${LOCALBASE}/bin/bash|; s|make|gmake|; s|perl -pi|perl -p|' ${MS_WRKSRC}/${MS_DISTNAME}/scripts/doc-build.sh
@${GREP} -lr share/man ${MS_WRKSRC}/${MS_DISTNAME}/doc/ ${MS_WRKSRC}/${MS_DISTNAME}/scripts/ | ${XARGS} -I % ${REINPLACE_CMD} 's|share/man|man|g' %
- @cd ${MS_WRKSRC}/${MS_DISTNAME}/ && ${MAKE_CMD}
+ @cd ${MS_WRKSRC}/${MS_DISTNAME}/ && ${GMAKE}
@${FIND} ${MS_WRKSRC}/${MS_DISTNAME}/ -type d -exec ${CHMOD} 755 '{}' \;
@${FIND} ${MS_WRKSRC}/${MS_DISTNAME}/ -type f -exec ${CHMOD} 644 '{}' \;
@${FIND} ${MS_WRKSRC}/${MS_DISTNAME}/ -type f -name '*.sh' -exec ${CHMOD} 755 '{}' \;
diff --git a/www/npm/distinfo b/www/npm/distinfo
index 27cea737297b..608fce8e9cf1 100644
--- a/www/npm/distinfo
+++ b/www/npm/distinfo
@@ -1,2 +1,2 @@
-SHA256 (npm-1.4.6.tar.xz) = df5c621f2c51d9e5cc7f210165d1e837f4addc2892c5b0e6ed4350b04bd82cfa
-SIZE (npm-1.4.6.tar.xz) = 1783848
+SHA256 (npm-1.4.10.tar.xz) = 1cf28e2becac171778661ac842c2db4db7793ff5eef7f0829d2515f37ad22aa5
+SIZE (npm-1.4.10.tar.xz) = 1749460
diff --git a/www/npm/pkg-plist b/www/npm/pkg-plist
index bec81e732105..c518ec053ea3 100644
--- a/www/npm/pkg-plist
+++ b/www/npm/pkg-plist
@@ -1,6 +1,7 @@
bin/npm
etc/man.d/npm.conf
lib/node_modules/npm/.npmignore
+lib/node_modules/npm/.travis.yml
lib/node_modules/npm/AUTHORS
lib/node_modules/npm/CONTRIBUTING.md
lib/node_modules/npm/LICENSE
@@ -885,6 +886,7 @@ lib/node_modules/npm/node_modules/read-package-json/node_modules/normalize-packa
lib/node_modules/npm/node_modules/read-package-json/node_modules/normalize-package-data/lib/core_module_names.json
lib/node_modules/npm/node_modules/read-package-json/node_modules/normalize-package-data/lib/extract_description.js
lib/node_modules/npm/node_modules/read-package-json/node_modules/normalize-package-data/lib/fixer.js
+lib/node_modules/npm/node_modules/read-package-json/node_modules/normalize-package-data/lib/make_warning.js
lib/node_modules/npm/node_modules/read-package-json/node_modules/normalize-package-data/lib/normalize.js
lib/node_modules/npm/node_modules/read-package-json/node_modules/normalize-package-data/lib/safe_format.js
lib/node_modules/npm/node_modules/read-package-json/node_modules/normalize-package-data/lib/typos.json
@@ -1315,6 +1317,7 @@ lib/node_modules/npm/node_modules/text-table/test/center.js
lib/node_modules/npm/node_modules/text-table/test/dotalign.js
lib/node_modules/npm/node_modules/text-table/test/doubledot.js
lib/node_modules/npm/node_modules/text-table/test/table.js
+lib/node_modules/npm/node_modules/uid-number/LICENCE
lib/node_modules/npm/node_modules/uid-number/LICENSE
lib/node_modules/npm/node_modules/uid-number/README.md
lib/node_modules/npm/node_modules/uid-number/get-uid-gid.js
@@ -1411,7 +1414,10 @@ lib/node_modules/npm/test/packages/npm-test-test-package/package.json
lib/node_modules/npm/test/packages/npm-test-url-dep/README
lib/node_modules/npm/test/packages/npm-test-url-dep/package.json
lib/node_modules/npm/test/run.js
+lib/node_modules/npm/test/tap/00-check-mock-dep.js
lib/node_modules/npm/test/tap/404-parent.js
+lib/node_modules/npm/test/tap/cache-add-unpublished.js
+lib/node_modules/npm/test/tap/cache-shasum.js
lib/node_modules/npm/test/tap/circular-dep.js
lib/node_modules/npm/test/tap/circular-dep/minimist/package.json
lib/node_modules/npm/test/tap/config-meta.js
@@ -1430,12 +1436,24 @@ lib/node_modules/npm/test/tap/ignore-shrinkwrap/npm-shrinkwrap.json
lib/node_modules/npm/test/tap/ignore-shrinkwrap/package.json
lib/node_modules/npm/test/tap/install-at-locally.js
lib/node_modules/npm/test/tap/install-at-locally/package@1.2.3/package.json
+lib/node_modules/npm/test/tap/install-cli-unicode.js
+lib/node_modules/npm/test/tap/install-cli/README.md
+lib/node_modules/npm/test/tap/install-cli/index.js
+lib/node_modules/npm/test/tap/install-cli/package.json
lib/node_modules/npm/test/tap/install-save-exact.js
lib/node_modules/npm/test/tap/install-save-exact/README.md
lib/node_modules/npm/test/tap/install-save-exact/index.js
lib/node_modules/npm/test/tap/install-save-exact/package.json
+lib/node_modules/npm/test/tap/install-save-prefix.js
+lib/node_modules/npm/test/tap/install-save-prefix/README.md
+lib/node_modules/npm/test/tap/install-save-prefix/index.js
+lib/node_modules/npm/test/tap/install-save-prefix/package.json
+lib/node_modules/npm/test/tap/invalid-cmd-exit-code.js
lib/node_modules/npm/test/tap/lifecycle-signal.js
lib/node_modules/npm/test/tap/lifecycle-signal/package.json
+lib/node_modules/npm/test/tap/lifecycle.js
+lib/node_modules/npm/test/tap/ls-depth-cli.js
+lib/node_modules/npm/test/tap/ls-depth/package.json
lib/node_modules/npm/test/tap/ls-no-results.js
lib/node_modules/npm/test/tap/noargs-install-config-save.js
lib/node_modules/npm/test/tap/npm-api-not-loaded-error.js
@@ -1459,9 +1477,12 @@ lib/node_modules/npm/test/tap/outdated/index.js
lib/node_modules/npm/test/tap/outdated/package.json
lib/node_modules/npm/test/tap/package-with-peer-dep/package.json
lib/node_modules/npm/test/tap/peer-deps-invalid.js
+lib/node_modules/npm/test/tap/peer-deps-invalid/file-fail.js
+lib/node_modules/npm/test/tap/peer-deps-invalid/file-ok.js
lib/node_modules/npm/test/tap/peer-deps-invalid/package.json
lib/node_modules/npm/test/tap/peer-deps-without-package-json.js
lib/node_modules/npm/test/tap/peer-deps-without-package-json/.gitkeep
+lib/node_modules/npm/test/tap/peer-deps-without-package-json/file-js.js
lib/node_modules/npm/test/tap/peer-deps.js
lib/node_modules/npm/test/tap/peer-deps/desired-ls-results.json
lib/node_modules/npm/test/tap/peer-deps/package.json
@@ -1469,6 +1490,7 @@ lib/node_modules/npm/test/tap/prepublish.js
lib/node_modules/npm/test/tap/prune.js
lib/node_modules/npm/test/tap/prune/package.json
lib/node_modules/npm/test/tap/publish-config.js
+lib/node_modules/npm/test/tap/referer.js
lib/node_modules/npm/test/tap/repo.js
lib/node_modules/npm/test/tap/scripts-whitespace-windows.js
lib/node_modules/npm/test/tap/scripts-whitespace-windows/README.md
@@ -1480,22 +1502,27 @@ lib/node_modules/npm/test/tap/semver-doc.js
lib/node_modules/npm/test/tap/shrinkwrap-dev-dependency.js
lib/node_modules/npm/test/tap/shrinkwrap-dev-dependency/desired-shrinkwrap-results.json
lib/node_modules/npm/test/tap/shrinkwrap-dev-dependency/package.json
+lib/node_modules/npm/test/tap/shrinkwrap-empty-deps.js
+lib/node_modules/npm/test/tap/shrinkwrap-empty-deps/package.json
lib/node_modules/npm/test/tap/shrinkwrap-shared-dev-dependency.js
lib/node_modules/npm/test/tap/shrinkwrap-shared-dev-dependency/desired-shrinkwrap-results.json
lib/node_modules/npm/test/tap/shrinkwrap-shared-dev-dependency/package.json
lib/node_modules/npm/test/tap/sorted-package-json.js
lib/node_modules/npm/test/tap/startstop.js
lib/node_modules/npm/test/tap/startstop/package.json
+lib/node_modules/npm/test/tap/test-run-ls.js
lib/node_modules/npm/test/tap/uninstall-package.js
lib/node_modules/npm/test/tap/uninstall-package/package.json
lib/node_modules/npm/test/tap/url-dependencies.js
lib/node_modules/npm/test/tap/url-dependencies/package.json
lib/node_modules/npm/test/tap/version-no-tags.js
lib/node_modules/npm/test/update-test.sh
+lib/node_modules/npm/wercker.yml
@dirrm lib/node_modules/npm/test/tap/url-dependencies
@dirrm lib/node_modules/npm/test/tap/uninstall-package
@dirrm lib/node_modules/npm/test/tap/startstop
@dirrm lib/node_modules/npm/test/tap/shrinkwrap-shared-dev-dependency
+@dirrm lib/node_modules/npm/test/tap/shrinkwrap-empty-deps
@dirrm lib/node_modules/npm/test/tap/shrinkwrap-dev-dependency
@dirrm lib/node_modules/npm/test/tap/scripts-whitespace-windows/dep/bin
@dirrm lib/node_modules/npm/test/tap/scripts-whitespace-windows/dep
@@ -1510,8 +1537,11 @@ lib/node_modules/npm/test/update-test.sh
@dirrm lib/node_modules/npm/test/tap/outdated-git
@dirrm lib/node_modules/npm/test/tap/outdated-depth
@dirrm lib/node_modules/npm/test/tap/outdated
+@dirrm lib/node_modules/npm/test/tap/ls-depth
@dirrm lib/node_modules/npm/test/tap/lifecycle-signal
+@dirrm lib/node_modules/npm/test/tap/install-save-prefix
@dirrm lib/node_modules/npm/test/tap/install-save-exact
+@dirrm lib/node_modules/npm/test/tap/install-cli
@dirrm lib/node_modules/npm/test/tap/install-at-locally/package@1.2.3
@dirrm lib/node_modules/npm/test/tap/install-at-locally
@dirrm lib/node_modules/npm/test/tap/ignore-shrinkwrap