aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2017-01-09 04:42:57 +0800
committersunpoet <sunpoet@FreeBSD.org>2017-01-09 04:42:57 +0800
commit78946a705d176b2c5854bc57f29eb5b1a37904b5 (patch)
tree0c932b5f8ba2efe806432befac6640ab65921431 /www
parent327694a755f433f2d317d2e30cb1cf697d19f81d (diff)
downloadfreebsd-ports-gnome-78946a705d176b2c5854bc57f29eb5b1a37904b5.tar.gz
freebsd-ports-gnome-78946a705d176b2c5854bc57f29eb5b1a37904b5.tar.zst
freebsd-ports-gnome-78946a705d176b2c5854bc57f29eb5b1a37904b5.zip
Update to 0.0.20140710
- Change MASTER_SITES to GitHub - Add LICENSE_FILE Changes: https://github.com/alobbs/libhpack/commits/master
Diffstat (limited to 'www')
-rw-r--r--www/libhpack/Makefile25
-rw-r--r--www/libhpack/distinfo9
-rw-r--r--www/libhpack/files/patch-CMakeLists.txt10
-rw-r--r--www/libhpack/files/patch-libchula-test-util_test.c13
-rw-r--r--www/libhpack/files/patch-libhpack-CMakeLists.txt11
-rw-r--r--www/libhpack/pkg-plist15
6 files changed, 70 insertions, 13 deletions
diff --git a/www/libhpack/Makefile b/www/libhpack/Makefile
index 6fb7676d20bb..7caa0dc6ae28 100644
--- a/www/libhpack/Makefile
+++ b/www/libhpack/Makefile
@@ -2,25 +2,42 @@
# $FreeBSD$
PORTNAME= libhpack
-PORTVERSION= 0.0.20140329
+PORTVERSION= 0.0.20140710
CATEGORIES= www
-MASTER_SITES= LOCAL/sunpoet
+MASTER_SITES= GH:libhpack \
+ https://raw.github.com/http2/http2-spec/master/:ec_xml
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:libhpack \
+ draft-ietf-httpbis-header-compression.xml:ec_xml
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Implementation of HPACK (Header compression for HTTP/2.0)
LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libcheck.so:devel/libcheck
CMAKE_ARGS= -DBUILD_DOCS=OFF \
-DBUILD_TESTS=OFF \
-DENABLE_GCOV=OFF \
+ -DLINUX=ON \
-DUSE_VALGRIND=OFF
+MAKE_JOBS_UNSAFE= yes
USE_LDCONFIG= yes
-USES= cmake pkgconfig python:2,build shebangfix tar:xz
+USES= cmake pathfix pkgconfig python:2,build shebangfix
-SHEBANG_FILES= gen-config.py libhpack/huffman-gen.py
+GH_ACCOUNT= alobbs
+GH_TAGNAME= b0ade19
+USE_GITHUB= yes
+
+SHEBANG_FILES= gen-config.py \
+ libhpack/huffman-gen.py \
+ tools/auto-ret.py \
+ CI/src-check.py
+
+post-extract:
+ @${CP} ${DISTDIR}/draft-ietf-httpbis-header-compression.xml ${WRKSRC}/libhpack/
post-patch:
@${REINPLACE_CMD} -e 's|STATIC|SHARED|' ${WRKSRC}/libchula/CMakeLists.txt ${WRKSRC}/libhpack/CMakeLists.txt
diff --git a/www/libhpack/distinfo b/www/libhpack/distinfo
index 83152c51ad6e..f362d6d79cd3 100644
--- a/www/libhpack/distinfo
+++ b/www/libhpack/distinfo
@@ -1,2 +1,7 @@
-SHA256 (libhpack-0.0.20140329.tar.xz) = e357a06cf783bd2f4a537bf2acb163aacc39d82e5f5ab1d3910f3b71b9148f49
-SIZE (libhpack-0.0.20140329.tar.xz) = 666520
+TIMESTAMP = 1483892979
+SHA256 (alobbs-libhpack-0.0.20140710-b0ade19_GH0.tar.gz) = a48edb42809d1d195602feb3d899b595cd600446870086217dae03b31c9bef7d
+SIZE (alobbs-libhpack-0.0.20140710-b0ade19_GH0.tar.gz) = 231445
+SHA256 (draft-ietf-httpbis-header-compression.xml) = 5451d3af357557b4852ec8ba45ef838ca16adb38e8b023d6a6e1173028fefac2
+SIZE (draft-ietf-httpbis-header-compression.xml) = 152574
+SHA256 (alobbs-libhpack-0.0.20140710-b0ade19_GH0.tar.gz) = a48edb42809d1d195602feb3d899b595cd600446870086217dae03b31c9bef7d
+SIZE (alobbs-libhpack-0.0.20140710-b0ade19_GH0.tar.gz) = 231445
diff --git a/www/libhpack/files/patch-CMakeLists.txt b/www/libhpack/files/patch-CMakeLists.txt
index a65aee1fadb9..6985707575b4 100644
--- a/www/libhpack/files/patch-CMakeLists.txt
+++ b/www/libhpack/files/patch-CMakeLists.txt
@@ -1,11 +1,11 @@
---- CMakeLists.txt.orig 2014-02-06 23:24:37.000000000 +0800
-+++ CMakeLists.txt 2014-02-07 00:29:15.339541948 +0800
-@@ -19,6 +19,8 @@
+--- CMakeLists.txt.orig 2014-07-09 21:59:50 UTC
++++ CMakeLists.txt
+@@ -19,6 +19,8 @@ math(EXPR hpack_SOVERSION_PATCH "${hpack
set(hpack_VERSION ${hpack_SOVERSION_MAJOR}.${hpack_SOVERSION_MINOR}.${hpack_SOVERSION_PATCH})
set(hpack_SOVERSION ${hpack_SOVERSION_MAJOR})
+set(chula_VERSION ${hpack_VERSION})
+set(chula_SOVERSION ${hpack_SOVERSION})
- # Options
- option(BUILD_TESTS "Build the test suite" ON)
+ # Standard replacements
+ set(prefix ${CMAKE_INSTALL_PREFIX})
diff --git a/www/libhpack/files/patch-libchula-test-util_test.c b/www/libhpack/files/patch-libchula-test-util_test.c
new file mode 100644
index 000000000000..69213756e07b
--- /dev/null
+++ b/www/libhpack/files/patch-libchula-test-util_test.c
@@ -0,0 +1,13 @@
+--- libchula/test/util_test.c.orig 2014-07-09 21:59:50 UTC
++++ libchula/test/util_test.c
+@@ -40,6 +40,10 @@
+ # include <syslog.h>
+ #endif
+
++#ifdef HAVE_NETINET_IN_H
++# include <netinet/in.h>
++#endif
++
+ #ifdef HAVE_ARPA_INET_H
+ # include <arpa/inet.h>
+ #endif
diff --git a/www/libhpack/files/patch-libhpack-CMakeLists.txt b/www/libhpack/files/patch-libhpack-CMakeLists.txt
new file mode 100644
index 000000000000..64f4ed6118a2
--- /dev/null
+++ b/www/libhpack/files/patch-libhpack-CMakeLists.txt
@@ -0,0 +1,11 @@
+--- libhpack/CMakeLists.txt.orig 2014-07-09 21:59:50 UTC
++++ libhpack/CMakeLists.txt
+@@ -27,7 +27,7 @@ set_target_properties (
+ add_custom_command (
+ OUTPUT ${CMAKE_CURRENT_SOURCE_DIR}/huffman_tables.c
+ COMMAND ${CMAKE_CURRENT_SOURCE_DIR}/huffman-gen.py
+- ARGS -v -o ${CMAKE_CURRENT_SOURCE_DIR}/huffman_tables.c
++ ARGS -v -i draft-ietf-httpbis-header-compression.xml -o ${CMAKE_CURRENT_SOURCE_DIR}/huffman_tables.c
+ COMMENT "Generating the huffman_tables.c file..."
+ )
+
diff --git a/www/libhpack/pkg-plist b/www/libhpack/pkg-plist
index 890461474d02..bc09866361c6 100644
--- a/www/libhpack/pkg-plist
+++ b/www/libhpack/pkg-plist
@@ -1,26 +1,37 @@
+include/libchula-qa/libchula-qa.h
+include/libchula-qa/mem_mgr.h
+include/libchula-qa/testing_macros-internal.h
include/libchula/avl.h
include/libchula/avl_generic.h
include/libchula/buffer.h
+include/libchula/chula-ret.h
include/libchula/common-internal.h
include/libchula/common.h
include/libchula/crc32.h
+include/libchula/cstrings.h
include/libchula/debug.h
+include/libchula/libchula.h
include/libchula/list.h
+include/libchula/log.h
+include/libchula/logger_fd.h
include/libchula/macros.h
include/libchula/md5.h
-include/libchula/missing_sysfuncs.h
include/libchula/sha1.h
include/libchula/sha512.h
-include/libchula/testing_macros.h
include/libchula/util.h
+include/libhpack/bitmap_set.h
+include/libhpack/header_encoder.h
include/libhpack/header_field.h
include/libhpack/header_parser.h
include/libhpack/header_store.h
include/libhpack/header_table.h
+include/libhpack/hpack-ret.h
include/libhpack/huffman.h
include/libhpack/huffman_tables.h
include/libhpack/integer.h
+include/libhpack/libhpack.h
include/libhpack/macros.h
+lib/libchula-qa.a
lib/libchula.so
lib/libchula.so.1
lib/libchula.so.1.0.0