aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2017-08-20 16:45:48 +0800
committertcberner <tcberner@FreeBSD.org>2017-08-20 16:45:48 +0800
commit794485cc042ed4377176f75bc3ed278aa90b663e (patch)
tree72a013fe458d822649c7e0f334f62ff40f3ff08a /www
parent471b0bc481691819a2b11aa52190d607be3775c4 (diff)
downloadfreebsd-ports-gnome-794485cc042ed4377176f75bc3ed278aa90b663e.tar.gz
freebsd-ports-gnome-794485cc042ed4377176f75bc3ed278aa90b663e.tar.zst
freebsd-ports-gnome-794485cc042ed4377176f75bc3ed278aa90b663e.zip
Replace www/qt5-webkit by a maintained fork.
Qt dropped WebKit in favour of WebEngine, and the used WebKit base in www/qt5-webkit is therefore very outdated. The fork at [1] is a QtWebKit implementation on a modern WebKit code base. [1] https://github.com/annulen/webkit PR: 221339 Exp-Run by: antoine Reviewed by: rakuco Differential Revision: https://reviews.freebsd.org/D9048
Diffstat (limited to 'www')
-rw-r--r--www/qt5-webkit/Makefile114
-rw-r--r--www/qt5-webkit/distinfo6
-rw-r--r--www/qt5-webkit/files/patch-Source_JavaScriptCore_assembler_ARMAssembler.h11
-rw-r--r--www/qt5-webkit/files/patch-Source_WTF_wtf_Platform.h12
-rw-r--r--www/qt5-webkit/files/patch-Source_WebCore_platform_graphics_cpu_arm_filters_FELightingNEON.cpp11
-rw-r--r--www/qt5-webkit/files/patch-Source_WebCore_platform_graphics_surfaces_GraphicsSurfaceToken.h11
-rw-r--r--www/qt5-webkit/files/patch-Source_WebCore_platform_leveldb_LevelDBDatabase.cpp13
-rw-r--r--www/qt5-webkit/files/patch-Source_WebKit_PlatformQt.cmake18
-rw-r--r--www/qt5-webkit/files/patch-Source__JavaScriptCore__runtime__JSCJSValueInlines.h26
-rw-r--r--www/qt5-webkit/files/patch-Source__QtWebKit.pro17
-rw-r--r--www/qt5-webkit/files/patch-Source__WebCore__page__NavigatorBase.cpp20
-rw-r--r--www/qt5-webkit/files/patch-Source__WebCore__platform__graphics__surfaces__GraphicsSurface.h11
-rw-r--r--www/qt5-webkit/files/patch-Source__WebCore__platform__graphics__surfaces__GraphicsSurfaceToken.h11
-rw-r--r--www/qt5-webkit/files/patch-Source_cmake_ECMGeneratePkgConfigFile.cmake38
-rw-r--r--www/qt5-webkit/files/patch-Source_cmake_KDEInstallDirs.cmake22
-rw-r--r--www/qt5-webkit/files/patch-Tools_qmake_config.tests_glx_glx.pro13
-rw-r--r--www/qt5-webkit/files/patch-Tools_qmake_config.tests_leveldb_leveldb.cpp13
-rw-r--r--www/qt5-webkit/files/patch-Tools_qmake_config.tests_leveldb_leveldb.pro14
-rw-r--r--www/qt5-webkit/files/patch-Tools_qmake_config.tests_libXcomposite_libXcomposite.pro12
-rw-r--r--www/qt5-webkit/files/patch-Tools_qmake_config.tests_libXrender_libXrender.pro12
-rw-r--r--www/qt5-webkit/pkg-descr4
-rw-r--r--www/qt5-webkit/pkg-plist50
22 files changed, 149 insertions, 310 deletions
diff --git a/www/qt5-webkit/Makefile b/www/qt5-webkit/Makefile
index c4ec03ece7df..8db128fbea4d 100644
--- a/www/qt5-webkit/Makefile
+++ b/www/qt5-webkit/Makefile
@@ -1,81 +1,49 @@
# $FreeBSD$
-PORTNAME= webkit
-DISTVERSION= ${QT5_VERSION}
-PORTREVISION= 1
-CATEGORIES= www
-MASTER_SITE_SUBDIR= community_releases/${QT5_VERSION:R}/${QT5_VERSION}/
-PKGNAMEPREFIX= qt5-
+PORTNAME= webkit
+DISTVERSION= 5.212.0-alpha2
+CATEGORIES= www
+MASTER_SITES= https://github.com/annulen/${PORTNAME}/releases/download/${DISTNAME}/
+PKGNAMEPREFIX= qt5-
+DISTNAME= qt${PORTNAME}-${DISTVERSION}
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= QtWebKit with a more modern WebKit code base
+
+LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
+ libgstapp-1.0.so:multimedia/gstreamer1-plugins \
+ libgstbase-1.0.so:multimedia/gstreamer1 \
+ libhyphen.so:textproc/hyphen \
+ libicui18n.so:devel/icu \
+ libpng16.so:graphics/png \
+ libwebp.so:graphics/webp
+
+USES= bison cmake:outsource gperf jpeg pathfix perl5 pkgconfig \
+ python:build sqlite:3 tar:xz
+USE_GNOME= glib20 libxml2 libxslt
+USE_GSTREAMER1= core
+USE_QT5= core gui location network opengl printsupport \
+ qml quick sensors testlib webchannel widgets \
+ buildtools_build qmake_build
+USE_RUBY= yes
+USE_XORG= x11 xcomposite xrender
+
+# Fix pkgconfig install paths.
+PATHFIX_CMAKELISTSTXT= PlatformQt.cmake
-MAINTAINER= kde@FreeBSD.org
-COMMENT= Qt WebKit implementation
-
-LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
- libicui18n.so:devel/icu \
- libleveldb.so:databases/leveldb \
- libpng.so:graphics/png \
- libwebp.so:graphics/webp
-BUILD_DEPENDS= ${LOCALBASE}/bin/flex:textproc/flex
-
-DISTINFO_FILE= ${MASTERDIR}/distinfo
-
-BROKEN_sparc64= cannot build: uses i386 assembler
-
-USE_GL= gl
-USE_GNOME= libxml2 libxslt
-USE_PERL5= build
-USE_QT5= core gui network opengl printsupport qml quick sql \
- widgets buildtools_build
-QT_DIST= ${PORTNAME}
-USE_RUBY= yes
RUBY_NO_RUN_DEPENDS= yes
-USE_XORG= x11 xcomposite xrender
-USES= bison gperf jpeg perl5 pkgconfig python:build qmake:outsource \
- sqlite
-# Use flex(1) from ports.
-MAKE_ENV= PATH="${LOCALBASE}/bin:${PATH}"
-# "all" builds many more targets. The default one is called "first" in
-# QtWebKit, and is invoked by default when make is called without arguments.
-ALL_TARGET= first
-USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
-
-QT_DEFINES= ACCESSIBILITY
-QT_CONFIG= accessibility accessibility-atspi-bridge
-
-OPTIONS_DEFINE= GSTREAMER
-OPTIONS_DEFAULT=GSTREAMER
-
-GSTREAMER_USE= GNOME=glib20 GSTREAMER1=yes
-
-.include <bsd.port.pre.mk>
-# Base ld(1) segfaults on PowerPC (inherited from Qt 4):
-# http://bugs.freebsd.org/173042
-.if ${ARCH} == "powerpc"
-BUILD_DEPENDS+= ${LOCALBASE}/bin/ld:devel/binutils
-.endif
+CMAKE_ARGS= -DPORT:STRING="Qt" \
+ -DKDE_INSTALL_INCLUDEDIR:PATH="${QT_INCDIR_REL}" \
+ -DKDE_INSTALL_LIBDIR:PATH="${QT_LIBDIR_REL}" \
+ -DENABLE_OPENGL:BOOL=TRUE \
+ -DUSE_QT_MULTIMEDIA:BOOL=FALSE
-post-patch:
- ${REINPLACE_CMD} -e 's,python,${PYTHON_VERSION},g' \
- -e 's,$$$${PYTHON},${PYTHON_VERSION},g' \
- ${WRKSRC}/Source/WebCore/DerivedSources.make \
- ${WRKSRC}/Source/WebCore/DerivedSources.pri \
- ${WRKSRC}/Source/WebKit2/DerivedSources.make \
- ${WRKSRC}/Source/WebKit2/DerivedSources.pri \
- ${WRKSRC}/Source/JavaScriptCore/DerivedSources.make \
- ${WRKSRC}/Source/JavaScriptCore/DerivedSources.pri \
- ${WRKSRC}/Tools/qmake/mkspecs/features/configure.prf
+# Add -DNDEBUG to CXXFLAGS which in turn gets sucked into
+# CMAKE_CXX_FLAGS_RELEASE where we actually want to have it.
+# [for the ASSERT in Source/WebCore/platform/graphics/texmap/GraphicsLayerTextureMapper.cpp ]
+CXXFLAGS+= -DNDEBUG
-pre-configure:
- @${REINPLACE_CMD} -Ee 's|linux-?\*|unix|g' \
- ${WRKSRC}/Source/JavaScriptCore/DerivedSources.pri \
- ${WRKSRC}/Source/JavaScriptCore/JavaScriptCore.pri \
- ${WRKSRC}/Source/JavaScriptCore/Target.pri \
- ${WRKSRC}/Source/WebCore/WebCore.pri \
- ${WRKSRC}/Tools/qmake/mkspecs/features/features.prf
-.if ! ${PORT_OPTIONS:MGSTREAMER}
- @${REINPLACE_CMD} -e 's|packagesExist.*gstreamer.*|false {|' \
- ${WRKSRC}/Tools/qmake/mkspecs/features/features.prf
-.endif
+PLIST_SUB= FULLVER="${PORTVERSION:R}"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/qt5-webkit/distinfo b/www/qt5-webkit/distinfo
index 33fca814c613..f547a03c14e9 100644
--- a/www/qt5-webkit/distinfo
+++ b/www/qt5-webkit/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1484659684
-SHA256 (KDE/Qt/5.7.1/qtwebkit-opensource-src-5.7.1.tar.xz) = a46cf7c89339645f94a5777e8ae5baccf75c5fc87ab52c9dafc25da3327b5f03
-SIZE (KDE/Qt/5.7.1/qtwebkit-opensource-src-5.7.1.tar.xz) = 35298736
+TIMESTAMP = 1502177654
+SHA256 (qtwebkit-5.212.0-alpha2.tar.xz) = f8f901de567e11fc5659402b6b827eac75505ff9c5072d8e919aa306003f8f8a
+SIZE (qtwebkit-5.212.0-alpha2.tar.xz) = 12456284
diff --git a/www/qt5-webkit/files/patch-Source_JavaScriptCore_assembler_ARMAssembler.h b/www/qt5-webkit/files/patch-Source_JavaScriptCore_assembler_ARMAssembler.h
deleted file mode 100644
index 22c0b902bf5b..000000000000
--- a/www/qt5-webkit/files/patch-Source_JavaScriptCore_assembler_ARMAssembler.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- Source/JavaScriptCore/assembler/ARMAssembler.h
-+++ Source/JavaScriptCore/assembler/ARMAssembler.h
-@@ -1064,6 +1064,8 @@
- linuxPageFlush(current, end);
- #elif OS(WINCE)
- CacheRangeFlush(code, size, CACHE_SYNC_ALL);
-+#elif CPU(ARM_TRADITIONAL) && OS(FREEBSD) && COMPILER(CLANG)
-+ __clear_cache(code, reinterpret_cast<char*>(code) + size);
- #elif OS(QNX) && ENABLE(ASSEMBLER_WX_EXCLUSIVE)
- UNUSED_PARAM(code);
- UNUSED_PARAM(size);
diff --git a/www/qt5-webkit/files/patch-Source_WTF_wtf_Platform.h b/www/qt5-webkit/files/patch-Source_WTF_wtf_Platform.h
deleted file mode 100644
index 06247d79c582..000000000000
--- a/www/qt5-webkit/files/patch-Source_WTF_wtf_Platform.h
+++ /dev/null
@@ -1,12 +0,0 @@
-This patch reportedly fixes build for ARM. See PR 208569
-
---- Source/WTF/wtf/Platform.h.orig 2016-04-10 06:48:36 UTC
-+++ Source/WTF/wtf/Platform.h
-@@ -218,6 +218,7 @@
- #elif defined(__ARM_ARCH_6__) \
- || defined(__ARM_ARCH_6J__) \
- || defined(__ARM_ARCH_6K__) \
-+ || defined(__ARM_ARCH_6KZ__) \
- || defined(__ARM_ARCH_6Z__) \
- || defined(__ARM_ARCH_6ZK__) \
- || defined(__ARM_ARCH_6T2__) \
diff --git a/www/qt5-webkit/files/patch-Source_WebCore_platform_graphics_cpu_arm_filters_FELightingNEON.cpp b/www/qt5-webkit/files/patch-Source_WebCore_platform_graphics_cpu_arm_filters_FELightingNEON.cpp
deleted file mode 100644
index 3ad37978314d..000000000000
--- a/www/qt5-webkit/files/patch-Source_WebCore_platform_graphics_cpu_arm_filters_FELightingNEON.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- Source/WebCore/platform/graphics/cpu/arm/filters/FELightingNEON.cpp.orig 2016-04-10 06:48:37 UTC
-+++ Source/WebCore/platform/graphics/cpu/arm/filters/FELightingNEON.cpp
-@@ -403,7 +403,7 @@ TOSTRING(neonDrawLighting) ":" NL
- "vmin.f32 " TMP2_D0 ", " TMP2_D0 ", " CONST_ONE_HI_D NL
- "vmul.f32 " TMP3_Q ", " COLOR_Q ", " TMP2_D0 "[1]" NL
- "vcvt.u32.f32 " TMP3_Q ", " TMP3_Q NL
-- "vmov.u32 r2, r3, " TMP3_S0 ", " TMP3_S1 NL
-+ "vmov r2, r3, " TMP3_S0 ", " TMP3_S1 NL
- // The color values are stored in-place.
- "strb r2, [" PIXELS_R ", #-11]" NL
- "strb r3, [" PIXELS_R ", #-10]" NL
diff --git a/www/qt5-webkit/files/patch-Source_WebCore_platform_graphics_surfaces_GraphicsSurfaceToken.h b/www/qt5-webkit/files/patch-Source_WebCore_platform_graphics_surfaces_GraphicsSurfaceToken.h
new file mode 100644
index 000000000000..db2d715aee93
--- /dev/null
+++ b/www/qt5-webkit/files/patch-Source_WebCore_platform_graphics_surfaces_GraphicsSurfaceToken.h
@@ -0,0 +1,11 @@
+--- Source/WebCore/platform/graphics/surfaces/GraphicsSurfaceToken.h.orig 2017-06-15 23:36:48 UTC
++++ Source/WebCore/platform/graphics/surfaces/GraphicsSurfaceToken.h
+@@ -33,7 +33,7 @@ struct GraphicsSurfaceToken {
+
+ #if OS(DARWIN)
+ typedef mach_port_t BufferHandle;
+-#elif OS(LINUX)
++#elif OS(LINUX) || OS(FREEBSD)
+ typedef uint32_t BufferHandle;
+ #elif OS(WINDOWS)
+ typedef HANDLE BufferHandle;
diff --git a/www/qt5-webkit/files/patch-Source_WebCore_platform_leveldb_LevelDBDatabase.cpp b/www/qt5-webkit/files/patch-Source_WebCore_platform_leveldb_LevelDBDatabase.cpp
deleted file mode 100644
index 5fc1906719fa..000000000000
--- a/www/qt5-webkit/files/patch-Source_WebCore_platform_leveldb_LevelDBDatabase.cpp
+++ /dev/null
@@ -1,13 +0,0 @@
-databases/leveldb installs the memenv.h header into a different location.
-
---- Source/WebCore/platform/leveldb/LevelDBDatabase.cpp.orig 2016-09-26 15:03:55 UTC
-+++ Source/WebCore/platform/leveldb/LevelDBDatabase.cpp
-@@ -38,7 +38,7 @@
- #include <leveldb/comparator.h>
- #include <leveldb/db.h>
- #include <leveldb/env.h>
--#include <helpers/memenv/memenv.h>
-+#include <memenv/memenv.h>
- #include <leveldb/slice.h>
- #include <string>
- #include <wtf/PassOwnPtr.h>
diff --git a/www/qt5-webkit/files/patch-Source_WebKit_PlatformQt.cmake b/www/qt5-webkit/files/patch-Source_WebKit_PlatformQt.cmake
new file mode 100644
index 000000000000..45c24851f226
--- /dev/null
+++ b/www/qt5-webkit/files/patch-Source_WebKit_PlatformQt.cmake
@@ -0,0 +1,18 @@
+--- Source/WebKit/PlatformQt.cmake.orig 2017-06-15 23:36:48 UTC
++++ Source/WebKit/PlatformQt.cmake
+@@ -481,6 +481,7 @@ if (NOT MACOS_BUILD_FRAMEWORKS)
+ BASE_NAME Qt5WebKit
+ DEPS "${WEBKIT_PKGCONGIG_DEPS}"
+ FILENAME_VAR WebKit_PKGCONFIG_FILENAME
++ DESCRIPTION "Qt WebKit module"
+ )
+ set(ECM_PKGCONFIG_INSTALL_DIR "${LIB_INSTALL_DIR}/pkgconfig" CACHE PATH "The directory where pkgconfig will be installed to.")
+ install(FILES ${WebKit_PKGCONFIG_FILENAME} DESTINATION ${ECM_PKGCONFIG_INSTALL_DIR} COMPONENT Data)
+@@ -671,6 +672,7 @@ if (NOT MACOS_BUILD_FRAMEWORKS)
+ BASE_NAME Qt5WebKitWidgets
+ DEPS "${WEBKITWIDGETS_PKGCONFIG_DEPS}"
+ FILENAME_VAR WebKitWidgets_PKGCONFIG_FILENAME
++ DESCRIPTION "Qt WebKitWidgets module"
+ )
+ install(FILES ${WebKitWidgets_PKGCONFIG_FILENAME} DESTINATION ${ECM_PKGCONFIG_INSTALL_DIR} COMPONENT Data)
+ endif ()
diff --git a/www/qt5-webkit/files/patch-Source__JavaScriptCore__runtime__JSCJSValueInlines.h b/www/qt5-webkit/files/patch-Source__JavaScriptCore__runtime__JSCJSValueInlines.h
deleted file mode 100644
index 44b68255a214..000000000000
--- a/www/qt5-webkit/files/patch-Source__JavaScriptCore__runtime__JSCJSValueInlines.h
+++ /dev/null
@@ -1,26 +0,0 @@
---- ./Source/JavaScriptCore/runtime/JSCJSValueInlines.h.orig 2013-10-22 01:49:45.000000000 -0700
-+++ ./Source/JavaScriptCore/runtime/JSCJSValueInlines.h 2013-11-08 00:51:34.238960064 -0800
-@@ -198,7 +198,11 @@
- u.asBits.tag = CellTag;
- else
- u.asBits.tag = EmptyValueTag;
-+#if defined(__sparc64__)
-+ u.asBits.payload = reinterpret_cast<int64_t>(ptr);
-+#else
- u.asBits.payload = reinterpret_cast<int32_t>(ptr);
-+#endif
- }
-
- inline JSValue::JSValue(const JSCell* ptr)
-@@ -207,7 +211,11 @@
- u.asBits.tag = CellTag;
- else
- u.asBits.tag = EmptyValueTag;
-+#if defined(__sparc64__)
-+ u.asBits.payload = reinterpret_cast<int64_t>(const_cast<JSCell*>(ptr));
-+#else
- u.asBits.payload = reinterpret_cast<int32_t>(const_cast<JSCell*>(ptr));
-+#endif
- }
-
- inline JSValue::operator bool() const
diff --git a/www/qt5-webkit/files/patch-Source__QtWebKit.pro b/www/qt5-webkit/files/patch-Source__QtWebKit.pro
deleted file mode 100644
index b2afeae43ceb..000000000000
--- a/www/qt5-webkit/files/patch-Source__QtWebKit.pro
+++ /dev/null
@@ -1,17 +0,0 @@
-Do not go into the examples/ directory, which contains only platformplugin/.
-
-Even though it is not part of the default target, it is included in `make
-install', and platformplugin's .pro file has a DESTDIR setting that causes the
-file system to be touched even though there is nothing to build or install.
---- Source/QtWebKit.pro
-+++ Source/QtWebKit.pro
-@@ -38,9 +38,4 @@ build?(webkit1) {
- tests.file = tests.pri
- SUBDIRS += tests
- }
--
-- examples.file = WebKit/qt/examples/examples.pro
-- examples.CONFIG += no_default_target
-- examples.makefile = Makefile
-- SUBDIRS += examples
- }
diff --git a/www/qt5-webkit/files/patch-Source__WebCore__page__NavigatorBase.cpp b/www/qt5-webkit/files/patch-Source__WebCore__page__NavigatorBase.cpp
deleted file mode 100644
index a784ca85189d..000000000000
--- a/www/qt5-webkit/files/patch-Source__WebCore__page__NavigatorBase.cpp
+++ /dev/null
@@ -1,20 +0,0 @@
---- ./Source/WebCore/page/NavigatorBase.cpp.orig 2012-12-18 20:04:33.000000000 +0100
-+++ ./Source/WebCore/page/NavigatorBase.cpp 2013-01-07 04:01:53.177339022 +0100
-@@ -30,7 +30,7 @@
- #include "NetworkStateNotifier.h"
- #include <wtf/text/WTFString.h>
-
--#if OS(LINUX)
-+#if OS(LINUX) || OS(FREEBSD)
- #include "sys/utsname.h"
- #include <wtf/StdLibExtras.h>
- #endif
-@@ -86,7 +86,7 @@
-
- String NavigatorBase::platform() const
- {
--#if OS(LINUX)
-+#if OS(LINUX) || OS(FREEBSD)
- if (!String(WEBCORE_NAVIGATOR_PLATFORM).isEmpty())
- return WEBCORE_NAVIGATOR_PLATFORM;
- struct utsname osname;
diff --git a/www/qt5-webkit/files/patch-Source__WebCore__platform__graphics__surfaces__GraphicsSurface.h b/www/qt5-webkit/files/patch-Source__WebCore__platform__graphics__surfaces__GraphicsSurface.h
deleted file mode 100644
index 184b5e202b0e..000000000000
--- a/www/qt5-webkit/files/patch-Source__WebCore__platform__graphics__surfaces__GraphicsSurface.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./Source/WebCore/platform/graphics/surfaces/GraphicsSurface.h.orig 2012-12-18 20:04:31.000000000 +0100
-+++ ./Source/WebCore/platform/graphics/surfaces/GraphicsSurface.h 2012-12-28 13:00:05.846909692 +0100
-@@ -36,7 +36,7 @@
- typedef IOSurfaceRef PlatformGraphicsSurface;
- #endif
-
--#if OS(LINUX)
-+#if OS(LINUX) || OS(FREEBSD)
- typedef uint32_t PlatformGraphicsSurface;
- #endif
-
diff --git a/www/qt5-webkit/files/patch-Source__WebCore__platform__graphics__surfaces__GraphicsSurfaceToken.h b/www/qt5-webkit/files/patch-Source__WebCore__platform__graphics__surfaces__GraphicsSurfaceToken.h
deleted file mode 100644
index bca58b6be1e2..000000000000
--- a/www/qt5-webkit/files/patch-Source__WebCore__platform__graphics__surfaces__GraphicsSurfaceToken.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./Source/WebCore/platform/graphics/surfaces/GraphicsSurfaceToken.h.orig 2012-12-18 20:04:31.000000000 +0100
-+++ ./Source/WebCore/platform/graphics/surfaces/GraphicsSurfaceToken.h 2012-12-28 13:02:03.566975217 +0100
-@@ -35,7 +35,7 @@
-
- #if OS(DARWIN)
- typedef mach_port_t BufferHandle;
--#elif OS(LINUX)
-+#elif OS(LINUX) || OS(FREEBSD)
- typedef uint32_t BufferHandle;
- #elif OS(WINDOWS)
- typedef HANDLE BufferHandle;
diff --git a/www/qt5-webkit/files/patch-Source_cmake_ECMGeneratePkgConfigFile.cmake b/www/qt5-webkit/files/patch-Source_cmake_ECMGeneratePkgConfigFile.cmake
new file mode 100644
index 000000000000..68beec29db7a
--- /dev/null
+++ b/www/qt5-webkit/files/patch-Source_cmake_ECMGeneratePkgConfigFile.cmake
@@ -0,0 +1,38 @@
+--- Source/cmake/ECMGeneratePkgConfigFile.cmake.orig 2017-06-02 18:33:03 UTC
++++ Source/cmake/ECMGeneratePkgConfigFile.cmake
+@@ -83,7 +83,7 @@
+
+ function(ECM_GENERATE_PKGCONFIG_FILE)
+ set(options INSTALL)
+- set(oneValueArgs BASE_NAME LIB_NAME FILENAME_VAR INCLUDE_INSTALL_DIR LIB_INSTALL_DIR)
++ set(oneValueArgs BASE_NAME LIB_NAME FILENAME_VAR INCLUDE_INSTALL_DIR LIB_INSTALL_DIR DESCRIPTION)
+ set(multiValueArgs DEPS DEFINES)
+
+ cmake_parse_arguments(EGPF "${options}" "${oneValueArgs}" "${multiValueArgs}" ${ARGN})
+@@ -119,6 +119,9 @@ function(ECM_GENERATE_PKGCONFIG_FILE)
+ set(EGPF_LIB_INSTALL_DIR "lib")
+ endif()
+ endif()
++ if(NOT EGPF_DESCRIPTION)
++ message(FATAL_ERROR "Required argument DESCRIPTION missing in ECM_GENERATE_PKGCONFIG_FILE() call")
++ endif()
+
+ set(PKGCONFIG_TARGET_BASENAME ${EGPF_BASE_NAME})
+ set(PKGCONFIG_TARGET_LIBNAME ${EGPF_LIB_NAME})
+@@ -148,6 +151,7 @@ function(ECM_GENERATE_PKGCONFIG_FILE)
+ file(WRITE ${PKGCONFIG_FILENAME}
+ "
+ Name: ${PKGCONFIG_TARGET_LIBNAME}
++Description: ${EGPF_DESCRIPTION}
+ Version: ${PROJECT_VERSION}
+ Libs: -L${CMAKE_INSTALL_PREFIX}/${EGPF_LIB_INSTALL_DIR} -l${PKGCONFIG_TARGET_LIBNAME}
+ Cflags: ${PKGCONFIG_TARGET_INCLUDES} ${PKGCONFIG_TARGET_DEFINES}
+@@ -156,7 +160,7 @@ Requires: ${PKGCONFIG_TARGET_DEPS}
+ )
+
+ if(EGPF_INSTALL)
+- set(ECM_PKGCONFIG_INSTALL_DIR "${EGPF_LIB_INSTALL_DIR}/pkgconfig" CACHE PATH "The directory where pkgconfig will be installed to.")
++ set(ECM_PKGCONFIG_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/libdata/pkgconfig" CACHE PATH "The directory where pkgconfig will be installed to.")
+ install(FILES ${PKGCONFIG_FILENAME} DESTINATION ${ECM_PKGCONFIG_INSTALL_DIR})
+ endif()
+ endfunction()
diff --git a/www/qt5-webkit/files/patch-Source_cmake_KDEInstallDirs.cmake b/www/qt5-webkit/files/patch-Source_cmake_KDEInstallDirs.cmake
new file mode 100644
index 000000000000..0bc1c9d01ecb
--- /dev/null
+++ b/www/qt5-webkit/files/patch-Source_cmake_KDEInstallDirs.cmake
@@ -0,0 +1,22 @@
+--- Source/cmake/KDEInstallDirs.cmake.orig 2017-06-15 23:36:48 UTC
++++ Source/cmake/KDEInstallDirs.cmake
+@@ -420,7 +420,7 @@ endif()
+ if(NOT KDE_INSTALL_DIRS_NO_DEPRECATED)
+ set(KF5_LIBEXEC_INSTALL_DIR "${CMAKE_INSTALL_LIBEXECDIR_KF5}")
+ endif()
+-_define_relative(CMAKEPACKAGEDIR LIBDIR "cmake"
++_define_relative(CMAKEPACKAGEDIR "" "lib/cmake"
+ "CMake packages, including config files"
+ CMAKECONFIG_INSTALL_PREFIX)
+
+@@ -442,8 +442,8 @@ if(KDE_INSTALL_USE_QT_SYS_PATHS)
+ file(RELATIVE_PATH LIB_INSTALL_DIR ${qt_install_prefix} ${qt_lib_dir})
+ set(KDE_INSTALL_LIBDIR ${LIB_INSTALL_DIR})
+
+- set(CMAKECONFIG_INSTALL_PREFIX "${LIB_INSTALL_DIR}/cmake")
+- set(KDE_INSTALL_CMAKEPACKAGEDIR "${LIB_INSTALL_DIR}/cmake")
++ set(CMAKECONFIG_INSTALL_PREFIX "${qt_install_prefix}/lib/cmake")
++ set(KDE_INSTALL_CMAKEPACKAGEDIR "${qt_install_prefix}/lib/cmake")
+
+ query_qmake(qt_include_dir QT_INSTALL_HEADERS)
+ file(RELATIVE_PATH INCLUDE_INSTALL_DIR ${qt_install_prefix} ${qt_include_dir})
diff --git a/www/qt5-webkit/files/patch-Tools_qmake_config.tests_glx_glx.pro b/www/qt5-webkit/files/patch-Tools_qmake_config.tests_glx_glx.pro
deleted file mode 100644
index 118e22fd29ab..000000000000
--- a/www/qt5-webkit/files/patch-Tools_qmake_config.tests_glx_glx.pro
+++ /dev/null
@@ -1,13 +0,0 @@
-Setting OBJECTS_DIR to "obj" causes problems with make(1), as "obj" is one of
-the directories make tries to enter in case it exists (because of .OBJDIR).
-Since qmake will create it because of OBJECTS_DIR, make will invoke the
-compiler from there and fail because it's trying to pass "-o obj/foo.o" while
-already in obj/.
-
---- Tools/qmake/config.tests/glx/glx.pro.orig 2016-09-26 14:56:31 UTC
-+++ Tools/qmake/config.tests/glx/glx.pro
-@@ -1,4 +1,3 @@
- SOURCES = glx.cpp
--OBJECTS_DIR = obj
- LIBS += -lX11 -lGL
-
diff --git a/www/qt5-webkit/files/patch-Tools_qmake_config.tests_leveldb_leveldb.cpp b/www/qt5-webkit/files/patch-Tools_qmake_config.tests_leveldb_leveldb.cpp
deleted file mode 100644
index 9fba722665b9..000000000000
--- a/www/qt5-webkit/files/patch-Tools_qmake_config.tests_leveldb_leveldb.cpp
+++ /dev/null
@@ -1,13 +0,0 @@
-databases/leveldb installs the memenv.h header into a different location.
-
---- Tools/qmake/config.tests/leveldb/leveldb.cpp.orig 2016-09-26 15:03:32 UTC
-+++ Tools/qmake/config.tests/leveldb/leveldb.cpp
-@@ -19,7 +19,7 @@
-
- #include <leveldb/db.h>
- #include <leveldb/env.h>
--#include <helpers/memenv/memenv.h>
-+#include <memenv/memenv.h>
-
- int main(int, char**)
- {
diff --git a/www/qt5-webkit/files/patch-Tools_qmake_config.tests_leveldb_leveldb.pro b/www/qt5-webkit/files/patch-Tools_qmake_config.tests_leveldb_leveldb.pro
deleted file mode 100644
index e161588d8b06..000000000000
--- a/www/qt5-webkit/files/patch-Tools_qmake_config.tests_leveldb_leveldb.pro
+++ /dev/null
@@ -1,14 +0,0 @@
-Setting OBJECTS_DIR to "obj" causes problems with make(1), as "obj" is one of
-the directories make tries to enter in case it exists (because of .OBJDIR).
-Since qmake will create it because of OBJECTS_DIR, make will invoke the
-compiler from there and fail because it's trying to pass "-o obj/foo.o" while
-already in obj/.
-
---- Tools/qmake/config.tests/leveldb/leveldb.pro.orig 2016-09-26 14:57:15 UTC
-+++ Tools/qmake/config.tests/leveldb/leveldb.pro
-@@ -1,5 +1,4 @@
- SOURCES = leveldb.cpp
--OBJECTS_DIR = obj
- LIBS += -lleveldb -lmemenv
-
- load(qt_build_config)
diff --git a/www/qt5-webkit/files/patch-Tools_qmake_config.tests_libXcomposite_libXcomposite.pro b/www/qt5-webkit/files/patch-Tools_qmake_config.tests_libXcomposite_libXcomposite.pro
deleted file mode 100644
index fbd6975e7b8b..000000000000
--- a/www/qt5-webkit/files/patch-Tools_qmake_config.tests_libXcomposite_libXcomposite.pro
+++ /dev/null
@@ -1,12 +0,0 @@
-Setting OBJECTS_DIR to "obj" causes problems with make(1), as "obj" is one of
-the directories make tries to enter in case it exists (because of .OBJDIR).
-Since qmake will create it because of OBJECTS_DIR, make will invoke the
-compiler from there and fail because it's trying to pass "-o obj/foo.o" while
-already in obj/.
-
---- Tools/qmake/config.tests/libXcomposite/libXcomposite.pro.orig 2016-09-26 14:56:58 UTC
-+++ Tools/qmake/config.tests/libXcomposite/libXcomposite.pro
-@@ -1,3 +1,2 @@
- SOURCES = libXcomposite.cpp
--OBJECTS_DIR = obj
- LIBS += -lXcomposite -lX11
diff --git a/www/qt5-webkit/files/patch-Tools_qmake_config.tests_libXrender_libXrender.pro b/www/qt5-webkit/files/patch-Tools_qmake_config.tests_libXrender_libXrender.pro
deleted file mode 100644
index bc725c8f2220..000000000000
--- a/www/qt5-webkit/files/patch-Tools_qmake_config.tests_libXrender_libXrender.pro
+++ /dev/null
@@ -1,12 +0,0 @@
-Setting OBJECTS_DIR to "obj" causes problems with make(1), as "obj" is one of
-the directories make tries to enter in case it exists (because of .OBJDIR).
-Since qmake will create it because of OBJECTS_DIR, make will invoke the
-compiler from there and fail because it's trying to pass "-o obj/foo.o" while
-already in obj/.
-
---- Tools/qmake/config.tests/libXrender/libXrender.pro.orig 2016-09-26 14:56:47 UTC
-+++ Tools/qmake/config.tests/libXrender/libXrender.pro
-@@ -1,3 +1,2 @@
- SOURCES = libXrender.cpp
--OBJECTS_DIR = obj
- LIBS += -lXrender -lX11
diff --git a/www/qt5-webkit/pkg-descr b/www/qt5-webkit/pkg-descr
new file mode 100644
index 000000000000..e343bb4c51b6
--- /dev/null
+++ b/www/qt5-webkit/pkg-descr
@@ -0,0 +1,4 @@
+Qt WebKit is the port of WebKit on top of Qt.
+This is a project aiming to upgrade QtWebKit to modern WebKit code base.
+
+WWW: https://github.com/annulen/webkit
diff --git a/www/qt5-webkit/pkg-plist b/www/qt5-webkit/pkg-plist
index 6e28fab83d41..29ad8c36ec73 100644
--- a/www/qt5-webkit/pkg-plist
+++ b/www/qt5-webkit/pkg-plist
@@ -1,39 +1,14 @@
-%%QT_INCDIR%%/QtWebKit/%%FULLVER%%/QtWebKit/private/bytearraytestdata.h
%%QT_INCDIR%%/QtWebKit/%%FULLVER%%/QtWebKit/private/qhttpheader_p.h
-%%QT_INCDIR%%/QtWebKit/%%FULLVER%%/QtWebKit/private/qquicknetworkreply_p.h
-%%QT_INCDIR%%/QtWebKit/%%FULLVER%%/QtWebKit/private/qquicknetworkrequest_p.h
-%%QT_INCDIR%%/QtWebKit/%%FULLVER%%/QtWebKit/private/qquickurlschemedelegate_p.h
-%%QT_INCDIR%%/QtWebKit/%%FULLVER%%/QtWebKit/private/qquickwebpage_p.h
-%%QT_INCDIR%%/QtWebKit/%%FULLVER%%/QtWebKit/private/qquickwebpage_p_p.h
-%%QT_INCDIR%%/QtWebKit/%%FULLVER%%/QtWebKit/private/qquickwebview_p.h
-%%QT_INCDIR%%/QtWebKit/%%FULLVER%%/QtWebKit/private/qquickwebview_p_p.h
-%%QT_INCDIR%%/QtWebKit/%%FULLVER%%/QtWebKit/private/qrawwebview_p.h
-%%QT_INCDIR%%/QtWebKit/%%FULLVER%%/QtWebKit/private/qrawwebview_p_p.h
-%%QT_INCDIR%%/QtWebKit/%%FULLVER%%/QtWebKit/private/qtwebsecurityorigin_p.h
-%%QT_INCDIR%%/QtWebKit/%%FULLVER%%/QtWebKit/private/qwebchannelwebkittransport_p.h
%%QT_INCDIR%%/QtWebKit/%%FULLVER%%/QtWebKit/private/qwebdatabase_p.h
-%%QT_INCDIR%%/QtWebKit/%%FULLVER%%/QtWebKit/private/qwebdownloaditem_p.h
-%%QT_INCDIR%%/QtWebKit/%%FULLVER%%/QtWebKit/private/qwebdownloaditem_p_p.h
%%QT_INCDIR%%/QtWebKit/%%FULLVER%%/QtWebKit/private/qwebelement_p.h
%%QT_INCDIR%%/QtWebKit/%%FULLVER%%/QtWebKit/private/qwebhistory_p.h
-%%QT_INCDIR%%/QtWebKit/%%FULLVER%%/QtWebKit/private/qwebiconimageprovider_p.h
-%%QT_INCDIR%%/QtWebKit/%%FULLVER%%/QtWebKit/private/qwebkittest_p.h
-%%QT_INCDIR%%/QtWebKit/%%FULLVER%%/QtWebKit/private/qwebloadrequest_p.h
-%%QT_INCDIR%%/QtWebKit/%%FULLVER%%/QtWebKit/private/qwebnavigationhistory_p.h
-%%QT_INCDIR%%/QtWebKit/%%FULLVER%%/QtWebKit/private/qwebnavigationhistory_p_p.h
-%%QT_INCDIR%%/QtWebKit/%%FULLVER%%/QtWebKit/private/qwebnavigationrequest_p.h
-%%QT_INCDIR%%/QtWebKit/%%FULLVER%%/QtWebKit/private/qwebpermissionrequest_p.h
%%QT_INCDIR%%/QtWebKit/%%FULLVER%%/QtWebKit/private/qwebplugindatabase_p.h
-%%QT_INCDIR%%/QtWebKit/%%FULLVER%%/QtWebKit/private/qwebpreferences_p.h
-%%QT_INCDIR%%/QtWebKit/%%FULLVER%%/QtWebKit/private/qwebpreferences_p_p.h
-%%QT_INCDIR%%/QtWebKit/%%FULLVER%%/QtWebKit/private/qwebscriptworld.h
%%QT_INCDIR%%/QtWebKit/%%FULLVER%%/QtWebKit/private/qwebscriptworld_p.h
%%QT_INCDIR%%/QtWebKit/%%FULLVER%%/QtWebKit/private/qwebsecurityorigin_p.h
-%%QT_INCDIR%%/QtWebKit/%%FULLVER%%/QtWebKit/private/testwindow.h
-%%QT_INCDIR%%/QtWebKit/%%FULLVER%%/QtWebKit/private/util.h
%%QT_INCDIR%%/QtWebKit/QWebDatabase
%%QT_INCDIR%%/QtWebKit/QWebElement
%%QT_INCDIR%%/QtWebKit/QWebElementCollection
+%%QT_INCDIR%%/QtWebKit/QWebFullScreenRequest
%%QT_INCDIR%%/QtWebKit/QWebFullScreenVideoHandler
%%QT_INCDIR%%/QtWebKit/QWebHapticFeedbackPlayer
%%QT_INCDIR%%/QtWebKit/QWebHistory
@@ -55,6 +30,7 @@
%%QT_INCDIR%%/QtWebKit/qtwebkitversion.h
%%QT_INCDIR%%/QtWebKit/qwebdatabase.h
%%QT_INCDIR%%/QtWebKit/qwebelement.h
+%%QT_INCDIR%%/QtWebKit/qwebfullscreenrequest.h
%%QT_INCDIR%%/QtWebKit/qwebhistory.h
%%QT_INCDIR%%/QtWebKit/qwebhistoryinterface.h
%%QT_INCDIR%%/QtWebKit/qwebkitglobal.h
@@ -81,26 +57,22 @@
%%QT_INCDIR%%/QtWebKitWidgets/qwebinspector.h
%%QT_INCDIR%%/QtWebKitWidgets/qwebpage.h
%%QT_INCDIR%%/QtWebKitWidgets/qwebview.h
-%%QT_CMAKEDIR%%/Qt5WebKit/Qt5WebKitConfig.cmake
-%%QT_CMAKEDIR%%/Qt5WebKit/Qt5WebKitConfigVersion.cmake
-%%QT_CMAKEDIR%%/Qt5WebKitWidgets/Qt5WebKitWidgetsConfig.cmake
-%%QT_CMAKEDIR%%/Qt5WebKitWidgets/Qt5WebKitWidgetsConfigVersion.cmake
-%%QT_LIBDIR%%/libQt5WebKit.prl
+lib/cmake/Qt5WebKit/Qt5WebKitConfig.cmake
+lib/cmake/Qt5WebKit/Qt5WebKitConfigVersion.cmake
+lib/cmake/Qt5WebKit/WebKitTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/Qt5WebKit/WebKitTargets.cmake
+lib/cmake/Qt5WebKitWidgets/Qt5WebKitWidgetsConfig.cmake
+lib/cmake/Qt5WebKitWidgets/Qt5WebKitWidgetsConfigVersion.cmake
+lib/cmake/Qt5WebKitWidgets/Qt5WebKitWidgetsTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/Qt5WebKitWidgets/Qt5WebKitWidgetsTargets.cmake
%%QT_LIBDIR%%/libQt5WebKit.so
%%QT_LIBDIR%%/libQt5WebKit.so.5
-%%QT_LIBDIR%%/libQt5WebKit.so.%%SHORTVER%%
%%QT_LIBDIR%%/libQt5WebKit.so.%%FULLVER%%
-%%DEBUG%%%%QT_LIBDIR%%/libQt5WebKit.so.%%FULLVER%%.debug
-%%QT_LIBDIR%%/libQt5WebKitWidgets.prl
%%QT_LIBDIR%%/libQt5WebKitWidgets.so
%%QT_LIBDIR%%/libQt5WebKitWidgets.so.5
-%%QT_LIBDIR%%/libQt5WebKitWidgets.so.%%SHORTVER%%
%%QT_LIBDIR%%/libQt5WebKitWidgets.so.%%FULLVER%%
-%%DEBUG%%%%QT_LIBDIR%%/libQt5WebKitWidgets.so.%%FULLVER%%.debug
%%QT_MKSPECDIR%%/modules/qt_lib_webkit.pri
-%%QT_MKSPECDIR%%/modules/qt_lib_webkit_private.pri
%%QT_MKSPECDIR%%/modules/qt_lib_webkitwidgets.pri
-%%QT_MKSPECDIR%%/modules/qt_lib_webkitwidgets_private.pri
%%QT_QMLDIR%%/QtWebKit/experimental/libqmlwebkitexperimentalplugin.so
%%QT_QMLDIR%%/QtWebKit/experimental/qmldir
%%QT_QMLDIR%%/QtWebKit/libqmlwebkitplugin.so
@@ -108,5 +80,7 @@
%%QT_QMLDIR%%/QtWebKit/qmldir
libdata/pkgconfig/Qt5WebKit.pc
libdata/pkgconfig/Qt5WebKitWidgets.pc
+%%QT_LIBEXECDIR%%/QtWebDatabaseProcess
+%%QT_LIBEXECDIR%%/QtWebNetworkProcess
%%QT_LIBEXECDIR%%/QtWebPluginProcess
%%QT_LIBEXECDIR%%/QtWebProcess