aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-11-18 18:33:34 +0800
committerantoine <antoine@FreeBSD.org>2014-11-18 18:33:34 +0800
commit7bb7fc37481efcf0c0599bdef9a416a9baf763fa (patch)
tree489f255a686804494510e5e8679fb72bb4b67fd0 /www
parent4619c44ccd591519d95ba090480bc4786f3e02fe (diff)
downloadfreebsd-ports-gnome-7bb7fc37481efcf0c0599bdef9a416a9baf763fa.tar.gz
freebsd-ports-gnome-7bb7fc37481efcf0c0599bdef9a416a9baf763fa.tar.zst
freebsd-ports-gnome-7bb7fc37481efcf0c0599bdef9a416a9baf763fa.zip
Ignore on the package builders when the default version of python is different
from the requested one
Diffstat (limited to 'www')
-rw-r--r--www/xist/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/www/xist/Makefile b/www/xist/Makefile
index 30bee9bd55db..b3ace371b7ad 100644
--- a/www/xist/Makefile
+++ b/www/xist/Makefile
@@ -15,10 +15,16 @@ COMMENT= XML-based extensible HTML generator
LICENSE= MIT
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}lxml>=3.4:${PORTSDIR}/devel/py-lxml \
- ${PYTHON_PKGNAMEPREFIX}pillow>2.6:${PORTSDIR}/graphics/py-pillow \
+ ${PYTHON_PKGNAMEPREFIX}pillow>=2.6:${PORTSDIR}/graphics/py-pillow \
${PYTHON_PKGNAMEPREFIX}cssutils>=1.0:${PORTSDIR}/www/py-cssutils
USES= python:3 tar:bzip2
USE_PYTHON= autoplist distutils
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if defined(PACKAGE_BUILDING) && ${PYTHON_VER} != ${PYTHON_DEFAULT}
+IGNORE= you have python ${PYTHON_DEFAULT} set as the default, and this needs ${PYTHON_VER}
+.endif
+
+.include <bsd.port.post.mk>