aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-05-26 17:24:47 +0800
committerbapt <bapt@FreeBSD.org>2014-05-26 17:24:47 +0800
commit7dcd1a763487d49074d59f3a31bd151284134ebd (patch)
tree61b71e9b35b9bf982a153ac7b8823feeb60e1418 /www
parent276ff68a9b6f7cd49885d853491ee45448f0119b (diff)
downloadfreebsd-ports-gnome-7dcd1a763487d49074d59f3a31bd151284134ebd.tar.gz
freebsd-ports-gnome-7dcd1a763487d49074d59f3a31bd151284134ebd.tar.zst
freebsd-ports-gnome-7dcd1a763487d49074d59f3a31bd151284134ebd.zip
Convert to USES=dos2unix
With hat: portmgr
Diffstat (limited to 'www')
-rw-r--r--www/ajaxplorer/Makefile3
-rw-r--r--www/autoindex2/Makefile2
-rw-r--r--www/pear-HTTP_Session2/Makefile2
-rw-r--r--www/pear-Services_Delicious/Makefile2
-rw-r--r--www/sahi/Makefile3
-rw-r--r--www/tickr/Makefile4
-rw-r--r--www/xpi-live_http_headers/Makefile2
-rw-r--r--www/zen-cart/Makefile3
8 files changed, 10 insertions, 11 deletions
diff --git a/www/ajaxplorer/Makefile b/www/ajaxplorer/Makefile
index e4c5d6edcddf..803fad6c2ba9 100644
--- a/www/ajaxplorer/Makefile
+++ b/www/ajaxplorer/Makefile
@@ -12,13 +12,12 @@ COMMENT= Ajax web file management system
LICENSE= AGPLv3
NO_BUILD= yes
-USES= shebangfix
+USES= dos2unix shebangfix
php_OLD_CMD= /php
SHEBANG_FILES= plugins/core.mq/ws-server.php \
plugins/core.mq/vendor/phpws/demo_ssl.php \
plugins/core.mq/vendor/phpws/demo.php
USE_PHP= dom mcrypt gd
-USE_DOS2UNIX= yes
DOS2UNIX_REGEX= .*\.php
WANT_PHP_WEB= yes
SUB_FILES= pkg-deinstall pkg-install pkg-message
diff --git a/www/autoindex2/Makefile b/www/autoindex2/Makefile
index 6dd930169c10..9e0867562dc5 100644
--- a/www/autoindex2/Makefile
+++ b/www/autoindex2/Makefile
@@ -11,7 +11,7 @@ COMMENT= PHP 5.x script that makes a table that lists the files in a directory
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-USE_DOS2UNIX= yes
+USES= dos2unix
USE_PHP= session
DEFAULT_PHP_VER= 5
CONFLICTS= AutoIndex-1*
diff --git a/www/pear-HTTP_Session2/Makefile b/www/pear-HTTP_Session2/Makefile
index 3177703bd411..59dc53953847 100644
--- a/www/pear-HTTP_Session2/Makefile
+++ b/www/pear-HTTP_Session2/Makefile
@@ -13,7 +13,7 @@ LICENSE= BSD
BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-USE_DOS2UNIX= yes
+USES= dos2unix
PEAR_AUTOINSTALL= yes
.include <bsd.port.pre.mk>
diff --git a/www/pear-Services_Delicious/Makefile b/www/pear-Services_Delicious/Makefile
index 43034626f929..bf11f64e7014 100644
--- a/www/pear-Services_Delicious/Makefile
+++ b/www/pear-Services_Delicious/Makefile
@@ -15,7 +15,7 @@ RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
${PEARDIR}/XML/Serializer.php:${PORTSDIR}/devel/pear-XML_Serializer \
${PEARDIR}/HTTP/Request.php:${PORTSDIR}/www/pear-HTTP_Request
-USE_DOS2UNIX= yes
+USES= dos2unix
USE_PHP= openssl
PEAR_AUTOINSTALL= yes
diff --git a/www/sahi/Makefile b/www/sahi/Makefile
index f27b01709899..0abee1d8eefa 100644
--- a/www/sahi/Makefile
+++ b/www/sahi/Makefile
@@ -59,7 +59,8 @@ REINPLACE_ARGS= -i '' -E \
SUB_FILES= ${PORTNAME}.sh
SUB_LIST= BROWSER=${BROWSER} JAVA_HOME=${JAVA_HOME}
-USE_DOS2UNIX= linux.xml os.properties sahi.properties
+USES= dos2unix
+DOS2UNIX_FILES= linux.xml os.properties sahi.properties
post-patch:
@${FIND} ${WRKSRC} -type f \( -name "*.orig" -or -name "*.bat" \) -delete
diff --git a/www/tickr/Makefile b/www/tickr/Makefile
index 9682f9d09d71..d034a2f53013 100644
--- a/www/tickr/Makefile
+++ b/www/tickr/Makefile
@@ -19,9 +19,9 @@ PLIST_SUB= DESKTOPDIR=${DESKTOPDIR:S,${PREFIX}/,,}
REINPLACE_ARGS= -e 's,%%PREFIX%%,${PREFIX},1' -i.bak
-USE_DOS2UNIX= tickr.h
+DOS2UNIX_FILES= tickr.h
USE_GNOME= desktopfileutils gtk20 libxml2
-USES= pkgconfig
+USES= dos2unix pkgconfig
NO_STAGE= yes
post-patch:
diff --git a/www/xpi-live_http_headers/Makefile b/www/xpi-live_http_headers/Makefile
index 71eb8bed8b32..5f7ca2b8c39d 100644
--- a/www/xpi-live_http_headers/Makefile
+++ b/www/xpi-live_http_headers/Makefile
@@ -31,7 +31,7 @@ XPI_DIRS= chrome/icons/default \
defaults/preferences \
defaults
-USE_DOS2UNIX= yes
+USES= dos2unix
DOS2UNIX_REGEX= .*\.(js|rdf|txt)
post-patch:
diff --git a/www/zen-cart/Makefile b/www/zen-cart/Makefile
index f31ba46119de..a25cdad1d3a7 100644
--- a/www/zen-cart/Makefile
+++ b/www/zen-cart/Makefile
@@ -14,10 +14,9 @@ COMMENT= PHP-based user-friendly, open source shopping cart
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/license.txt
-USES= zip
+USES= dos2unix zip
USE_PHP= yes
WANT_PHP_WEB= yes
-USE_DOS2UNIX= yes
DOS2UNIX_REGEX= .*\.php
EXAMPLESDIR= ${PREFIX}/share/examples/${PORTNAME}