aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-04-12 01:12:16 +0800
committermiwi <miwi@FreeBSD.org>2008-04-12 01:12:16 +0800
commit7f20b33416b94c82dc59758892b9e4513a0f6620 (patch)
treeefe44967872be2884c17bbad91b6eec2309fa2ab /www
parente283fd3f0d453a722d016294b034b75dc0799c02 (diff)
downloadfreebsd-ports-gnome-7f20b33416b94c82dc59758892b9e4513a0f6620.tar.gz
freebsd-ports-gnome-7f20b33416b94c82dc59758892b9e4513a0f6620.tar.zst
freebsd-ports-gnome-7f20b33416b94c82dc59758892b9e4513a0f6620.zip
The HTTP_FloodControl package can be used to detect and protect a
Web site from attempts to flood it with too many requests. It also allows to protect the site from automatic downloading many pages or files from the same IP address, session ID or other unique identifier. The detection of flood is determine according to a set of parameters indicating the maximal allowed number of requests for the certain time interval. It is possible to set several parameters at once in order to perform more effective protection. The package uses various storage containers (regular files, DB, MDB, MDB2) to handle counter logs. WWW: http://pear.php.net/package/HTTP_FloodControl/ PR: ports/119999 Submitted by: Ditesh Shashikant Gathani <ditesh at gathani.org>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/pear-HTTP_FloodControl/Makefile49
-rw-r--r--www/pear-HTTP_FloodControl/distinfo3
-rw-r--r--www/pear-HTTP_FloodControl/pkg-descr17
4 files changed, 70 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 86759fd79afc..a2ab97250d67 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1005,6 +1005,7 @@
SUBDIR += pear-HTTP
SUBDIR += pear-HTTP_Client
SUBDIR += pear-HTTP_Download
+ SUBDIR += pear-HTTP_FloodControl
SUBDIR += pear-HTTP_Header
SUBDIR += pear-HTTP_Request
SUBDIR += pear-HTTP_Server
diff --git a/www/pear-HTTP_FloodControl/Makefile b/www/pear-HTTP_FloodControl/Makefile
new file mode 100644
index 000000000000..2db71386fba7
--- /dev/null
+++ b/www/pear-HTTP_FloodControl/Makefile
@@ -0,0 +1,49 @@
+# Ports collection makefile for: pear-HTTP_FloodControl
+# Date created: 22 Jan 2007
+# Whom: Ditesh Shashikant Gathani <ditesh@gathani.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTTP_FloodControl
+PORTVERSION= 0.1.1
+CATEGORIES= www pear
+
+MAINTAINER= ditesh@gathani.org
+COMMENT= PEAR classes to detect and protect from attempts to flood a site
+
+BUILD_DEPENDS= ${PEARDIR}/HTTP.php:${PORTSDIR}/www/pear-HTTP
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+CATEGORY= HTTP
+FILES= FloodControl.php FloodControl/Container.php \
+ FloodControl/Container/DB.php FloodControl/Container/File.php \
+ FloodControl/Container/MDB.php FloodControl/Container/MDB2.php
+
+LATEST_LINK= pear-HTTP_FloodControl
+DOCS= README LICENSE
+OPTIONS= DB "Enable PEAR::DB support" Off \
+ MDB "Enable PEAR::MDB support" Off \
+ MDB2 "Enable PEAR::MDB2 support" Off
+
+post-extract:
+ ${MKDIR} ${WRKSRC}/docs
+ ${MV} ${WRKSRC}/README ${WRKSRC}/LICENSE ${WRKSRC}/docs
+ ${MV} ${WRKDIR}/package2.xml ${WRKDIR}/package.xml
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_DB)
+RUN_DEPENDS+= ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB
+.endif
+
+.if defined(WITH_MDB)
+RUN_DEPENDS+= ${PEARDIR}/MDB.php:${PORTSDIR}/databases/pear-MDB
+.endif
+
+.if defined(WITH_MDB2)
+RUN_DEPENDS+= ${PEARDIR}/MDB2.php:${PORTSDIR}/databases/pear-MDB2
+.endif
+
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
+.include <bsd.port.post.mk>
diff --git a/www/pear-HTTP_FloodControl/distinfo b/www/pear-HTTP_FloodControl/distinfo
new file mode 100644
index 000000000000..52b62f087264
--- /dev/null
+++ b/www/pear-HTTP_FloodControl/distinfo
@@ -0,0 +1,3 @@
+MD5 (PEAR/HTTP_FloodControl-0.1.1.tgz) = 848fc5590d607b12f480faaf84fbf7c5
+SHA256 (PEAR/HTTP_FloodControl-0.1.1.tgz) = 60b7612be832284c6c40355d82d7664e7b291fbea9e1d0da925f7ef275acba4c
+SIZE (PEAR/HTTP_FloodControl-0.1.1.tgz) = 15519
diff --git a/www/pear-HTTP_FloodControl/pkg-descr b/www/pear-HTTP_FloodControl/pkg-descr
new file mode 100644
index 000000000000..b7d65c80545f
--- /dev/null
+++ b/www/pear-HTTP_FloodControl/pkg-descr
@@ -0,0 +1,17 @@
+The HTTP_FloodControl package can be used to detect and protect a
+Web site from attempts to flood it with too many requests. It also allows to
+protect the site from automatic downloading many pages or files from the same
+IP address, session ID or other unique identifier.
+
+The detection of flood is determine according to a set of parameters indicating
+the maximal allowed number of requests for the certain time interval. It is
+possible to set several parameters at once in order to perform more effective
+protection.
+
+The package uses various storage containers (regular files, DB, MDB, MDB2) to
+handle counter logs.
+
+WWW: http://pear.php.net/package/HTTP_FloodControl/
+
+- Ditesh Shashikant Gathani
+ditesh@gathani.org