aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2015-01-18 09:56:39 +0800
committerwen <wen@FreeBSD.org>2015-01-18 09:56:39 +0800
commit81be69a239422bbc98da8471563a106e7479bd83 (patch)
treee2e281d82f2c9d09ac5aaf3bc9184e65748c48fb /www
parentacc62f7e849066f30df136ac1ec62dc555f38122 (diff)
downloadfreebsd-ports-gnome-81be69a239422bbc98da8471563a106e7479bd83.tar.gz
freebsd-ports-gnome-81be69a239422bbc98da8471563a106e7479bd83.tar.zst
freebsd-ports-gnome-81be69a239422bbc98da8471563a106e7479bd83.zip
- Replace deprecated @dirrmtry with @dir
PR: 196482 Submitted by: freebsd-ports@charlieroot.de(maintainer)
Diffstat (limited to 'www')
-rw-r--r--www/typo3-lts/Makefile26
1 files changed, 12 insertions, 14 deletions
diff --git a/www/typo3-lts/Makefile b/www/typo3-lts/Makefile
index 5ac6d8f148c8..204130a68151 100644
--- a/www/typo3-lts/Makefile
+++ b/www/typo3-lts/Makefile
@@ -63,28 +63,26 @@ do-install:
post-install:
@cd ${STAGEDIR}${PREFIX}; \
${FIND} * \( -type f -or -type l \) -path "${TYPO3WWW}/${PORTNAME}-${TYPO3RELEASE}/*" | \
- ${SORT} >> ${TMPPLIST}
- @${ECHO_CMD} -e "@owner ${WWWOWN}\n@group ${WWWGRP}" >> ${TMPPLIST}
+ ${SORT} | ${SED} -ne 's#^#@(root,wheel,) #p' >> ${TMPPLIST}
@cd ${STAGEDIR}${PREFIX}; \
${FIND} * \( -type f -or -type l \) -path "${TYPO3WWW}/${TYPO3SRC}/typo3/ext/*" | \
- ${SORT} >> ${TMPPLIST}
- @${ECHO_CMD} -e "@owner root\n@group wheel" >> ${TMPPLIST}
+ ${SORT} | ${SED} -ne 's#^#@(${WWWOWN},${WWWGRP},) #p' >> ${TMPPLIST}
@cd ${STAGEDIR}${PREFIX}; \
${FIND} * \( -type f -or -type l \) \
-not \( -path "${TYPO3WWW}/${PORTNAME}-${TYPO3RELEASE}/*" -or \
-path "${TYPO3WWW}/${TYPO3SRC}/typo3/ext/*" \) | \
- ${SORT} >> ${TMPPLIST}
- @${ECHO_CMD} -e "@owner ${WWWOWN}\n@group ${WWWGRP}" >> ${TMPPLIST}
- @cd ${STAGEDIR}${PREFIX}; ${FIND} -d * -type d -regex "${TYPO3WWW}/${PORTNAME}-${TYPO3RELEASE}/*.*" | \
- ${SORT} | ${SED} -ne 's#^#@dirrmtry #p' >> ${TMPPLIST}
- @${ECHO_CMD} -e "@owner ${WWWOWN}\n@group ${WWWGRP}" >> ${TMPPLIST}
- @cd ${STAGEDIR}${PREFIX}; ${FIND} -d * -type d -regex "${TYPO3WWW}/${TYPO3SRC}/typo3/ext/*.*" | \
- ${SORT} | ${SED} -ne 's#^#@dirrmtry #p' >> ${TMPPLIST}
- @${ECHO_CMD} -e "@owner root\n@group wheel" >> ${TMPPLIST}
- @cd ${STAGEDIR}${PREFIX}; ${FIND} * -type d \
+ ${SORT} | ${SED} -ne 's#^#@(root,wheel,) #p' >> ${TMPPLIST}
+ @cd ${STAGEDIR}${PREFIX}; \
+ ${FIND} -d * -type d -regex "${TYPO3WWW}/${PORTNAME}-${TYPO3RELEASE}/*.*" | \
+ ${SORT} | ${SED} -ne 's#^#@dir(root,wheel,) #p' >> ${TMPPLIST}
+ @cd ${STAGEDIR}${PREFIX}; \
+ ${FIND} -d * -type d -regex "${TYPO3WWW}/${TYPO3SRC}/typo3/ext/*.*" | \
+ ${SORT} | ${SED} -ne 's#^#@dir(${WWWOWN},${WWWGRP},) #p' >> ${TMPPLIST}
+ @cd ${STAGEDIR}${PREFIX}; \
+ ${FIND} * -type d \
-path "${TYPO3WWW}/*" \
-not \( -regex "${TYPO3WWW}/${PORTNAME}-${TYPO3RELEASE}/*.*" -or \
-regex "${TYPO3WWW}/${TYPO3SRC}/typo3/ext/*.*" \) | \
- ${SORT} | ${SED} -ne 's#^#@dirrmtry #p' >> ${TMPPLIST}
+ ${SORT} | ${SED} -ne 's#^#@dir(root,wheel,) #p' >> ${TMPPLIST}
.include <bsd.port.mk>