aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2007-04-03 06:56:15 +0800
committerpav <pav@FreeBSD.org>2007-04-03 06:56:15 +0800
commit85f93575663adb5a7fa7799d5b3b6bdb05f3eda7 (patch)
tree9444ec7f98d0f2faaf4734217466e921e7d27034 /www
parentc12598153f1706af748413173a0b3dc1a5e4fed7 (diff)
downloadfreebsd-ports-gnome-85f93575663adb5a7fa7799d5b3b6bdb05f3eda7.tar.gz
freebsd-ports-gnome-85f93575663adb5a7fa7799d5b3b6bdb05f3eda7.tar.zst
freebsd-ports-gnome-85f93575663adb5a7fa7799d5b3b6bdb05f3eda7.zip
- Convert existing ports to a new bsd.tcl.mk order
PR: ports/109097 Submitted by: Martin Matuska <martin@matuska.org> Tested on: pointyhat exp-run
Diffstat (limited to 'www')
-rw-r--r--www/tdom/Makefile14
-rw-r--r--www/websh/Makefile2
2 files changed, 4 insertions, 12 deletions
diff --git a/www/tdom/Makefile b/www/tdom/Makefile
index 130322d278d4..bed6221b1c6d 100644
--- a/www/tdom/Makefile
+++ b/www/tdom/Makefile
@@ -17,14 +17,8 @@ COMMENT= High performance XML data processing with Tcl (ARGS for OpenACS)
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/unix
TDOMBASE= ${PREFIX}/lib/tdom${PORTVERSION}
-USE_TCL_VER?= 84
-
-.if ${USE_TCL_VER} != 84 && ${USE_TCL_VER} != 85
-IGNORE= supported values for USE_TCL_VER are only 84 and 85
-.endif
-
-# by default we want a threaded build
-LIB_DEPENDS= tcl${USE_TCL_VER}-threads:${PORTSDIR}/lang/tcl${USE_TCL_VER}-thread
+USE_TCL= 84+
+USE_TCL_THREADS= yes
USE_GMAKE= yes
HAS_CONFIGURE= yes
@@ -45,8 +39,8 @@ HTMLDOCS= category-index.html dom.html domDoc.html domNode.html \
.include <bsd.port.pre.mk>
CONFIGURE_ARGS+= --enable-threads --disable-tdomalloc \
- --with-tcl=${LOCALBASE}/lib/tcl${USE_TCL_VER:S/8/8./}-threads \
- --with-tclinclude=${LOCALBASE}/include/tcl${USE_TCL_VER:S/8/8./} --prefix=${PREFIX}
+ --with-tcl=${TCL_LIBDIR} \
+ --with-tclinclude=${TCL_INCLUDEDIR} --prefix=${PREFIX}
post-install:
.if !defined(NOPORTDOCS)
diff --git a/www/websh/Makefile b/www/websh/Makefile
index f70d5400f974..8062010e27bd 100644
--- a/www/websh/Makefile
+++ b/www/websh/Makefile
@@ -15,8 +15,6 @@ EXTRACT_SUFX= -src.tar.gz
MAINTAINER= mi@aldan.algebra.com
COMMENT= Embeds a TCL8 interpreter in the Apache server
-LIB_DEPENDS= tcl${TCL_DVER}:${PORTSDIR}/lang/tcl${TCL_DVER}
-
OPTIONS= WSMDEBUG "memory(n) and checkmem(n) commands in web-scripts" on
OPTIONS+= WSSTATIC "Link the objects into the module statically" off